teamviewer.com link icon
or
Ask The Community

No activation email? No activate link?

eamon
eamon Posts: 3 ✭✭

Just paid the annual cost for a license and received many auto emails about my payment and joining this site etc, but no email to activate my license.


Please advise...

Answers

  • JeanK
    JeanK Posts: 3,846 Moderator

    Hello @eamon,

    Did you check your spam folder?

    French Community Moderator
  • eamon
    eamon Posts: 3 ✭✭

    I did - The activation email that TV has set up is missing the actual link. Have someone look into it. The template needs updating.

    I just received a new activation email - no link still. ( I assume you or someone who saw this request sent the canned activation email).

    I got this sorted out by calling the sales rep who manually sent me a link to click to activate and it worked immediately.


    Here is the entire activation email I have received 3 times - the only links (which I cant post) are to the guide PDF and the community forums):


    Hi eamon,

    Thank you for choosing TeamViewer.

    Please read the License Activation Guide before you activate your license.

    Description

    TeamViewer Remote Access

    QTY

    1

    The terms of our End User License Agreement (EULA) and Data Processing Agreement (DPA) are applicable.

    Need help?

    Check out our License Activation Guide or the Remote Access Community page.

    Happy Connecting,

    TeamViewer

  • KL0K
    KL0K Posts: 3

    I have the same problem. I tried calling but the message tells me I don't have phone support.

  • eamon
    eamon Posts: 3 ✭✭

    I assume most people have this problem with this product package - My guess is the email template needs top be fixed to actually include the activation link.


    On the phone, I had to say that I am not calling for support. I am calling to finish my purchase and if they could not help me activate that I would have to cancel for a refund because they could not deliver the product I paid for. Took 2 minutes for them to send the activation link.


    Good luck

  • KL0K
    KL0K Posts: 3

    Hi eamon,


    Thank you for the advice. I was disconnected after holding with billing for 15 minutes. I am trying a second time.

Sign In or Register to comment.