teamviewer.com link icon
or
Ask The Community

Permission to access yum repository denied

The yum repo, that still worked on January 15, 2018, now returns:

Permission to access 'http://linux.teamviewer.com/yum/stable/main/binary-x86_64/media.1/media' denied.

This is the repository as provided by installing 13.0.6634:

/etc/yum.repos.d/teamviewer.repo

Comments

  • I'm getting the same denied message when trying to update through Ubuntu.

  • Permission to access 'http://linux.teamviewer.com/yum/stable/main/binary-x86_64/media.1/media' denied.


    what's wrong with that?

     

    System:    Host: wolfbook.itrus.su Kernel: 4.15.1-1-default x86_64 bits: 64 gcc: 7.3.0 Console: tty 0
    Distro: openSUSE Tumbleweed 20180208
    Machine: Device: portable System: Dell product: Vostro 3460 serial: JM6G2W1
    Mobo: Dell model: 0J1V31 v: A00 serial: .JM6G2W1.CN486432CK0025. UEFI: Dell v: A19 date: 08/22/2013
    Battery BAT0: charge: 18.5 Wh 100.0% condition: 18.5/48.8 Wh (38%) model: SIMPLO Dell status: Full
    CPU: Dual core Intel Core i5-3210M (-HT-MCP-) arch: Ivy Bridge rev.9 cache: 3072 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9976
    clock speeds: max: 3100 MHz 1: 2561 MHz 2: 2987 MHz 3: 2848 MHz 4: 2686 MHz
    Graphics: Card: Intel 3rd Gen Core processor Graphics Controller bus-ID: 00:02.0
    Display Server: X.org 1.19.6 drivers: intel (unloaded: modesetting,fbdev,vesa)
    tty size: 191x31 Advanced Data: N/A for root out of X
    Audio: Card Intel 7 Series/C216 Family High Definition Audio Controller
    driver: snd_hda_intel bus-ID: 00:1b.0
    Sound: Advanced Linux Sound Architecture v: k4.15.1-1-default
    Network: Card-1: Intel Wireless 7260 driver: iwlwifi bus-ID: 01:00.0
    IF: wlp1s0 state: up mac: fc:f8:ae:50:4a:06
    Card-2: Qualcomm Atheros AR8161 Gigabit Ethernet driver: alx port: 2000 bus-ID: 02:00.0
    IF: p4p1 state: down mac: 5c:f9:dd:55:b9:6f
    Drives: HDD Total Size: 1080.2GB (54.8% used)
    ID-1: /dev/sda model: KINGSTON_SV300S3 size: 120.0GB temp: 42C
    ID-2: /dev/sdb model: SAMSUNG_MZ7LM960 size: 960.2GB temp: 0C
    Partition: ID-1: / size: 96G used: 31G (33%) fs: ext4 dev: /dev/sda2
    ID-2: /home size: 881G used: 509G (58%) fs: ext4 dev: /dev/sdb1
    ID-3: swap-1 size: 13.73GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
    Sensors: System Temperatures: cpu: 68.0C mobo: 70.0C
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 266 Uptime: 0:18 Memory: 3644.6/11868.6MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
    Client: Shell (bash 4.4.181) inxi: 2.3.40
  • DanielStm
    DanielStm Posts: 224 Staff

    @Angelwind: I doubt that. Ubuntu does not have yum. Have a look here.

    @Werwolf: did you make any manual changes to the repository configuration? What does 'zypper repos' give you? (Or: which tools are you using?)

    @Guus013: Does the problem still exist? Which distribution are you on? Which commands do you use?

    Best regards,

    Daniel

    Linux Developer
  • No, I don't change repo
    Only create symlink
    ln -s /etc/yum.repos.d/twrepo /etc/zypper/repos.d/twrepo
  • DanielStm
    DanielStm Posts: 224 Staff

    'zypper repos' output? 'zypper refresh' output?

    Linux Developer
  • @DanielStm: I just now added the repo again and it works fine!

    I am on openSUSE Leap 42.3 and had simply copied /etc/yum.repos.d/teamviewer.repo to /etc/zypp/repos.d/teamviewer.repo. I use the YaST Software Repositories and Software Management GUIs, which execute zypper commands and zypper read the original yum repo file:

    [teamviewer]
    name=TeamViewer - $basearch
    baseurl=http://linux.teamviewer.com/yum/stable/main/binary-$basearch/
    gpgkey=http://linux.teamviewer.com/pubkey/TeamViewer2017.asc
    gpgcheck=1
    enabled=1
    failovermethod=priority

    ... and updated it to this, I only enabled auto-refresh using the GUI:

    [teamviewer]
    name=TeamViewer - $basearch
    enabled=1
    autorefresh=1
    baseurl=http://linux.teamviewer.com/yum/stable/main/binary-$basearch/
    type=rpm-md
    gpgcheck=1
    gpgkey=http://linux.teamviewer.com/pubkey/TeamViewer2017.asc
    keeppackages=0
  • marcos13
    marcos13 Posts: 1

    Same problem here. Command 'zypper refresh' fails!

    OS: OpenSuSE 42.3; x86_64

    /zypp/repos.d/teamviewer.repo

    foo:~ > cat /etc/zypp/repos.d/teamviewer.repo
    [teamviewer]
    name=TeamViewer - $basearch
    enabled=1
    autorefresh=1
    baseurl=http://linux.teamviewer.com/yum/stable/main/binary-$basearch/
    gpgkey=http://linux.teamviewer.com/pubkey/TeamViewer2017.asc
    gpgcheck=1
    type=rpm-md
    keeppackages=0

    Output of 'zypper refresh teamviewer'

    foo:~ # zypper refresh teamviewer
    Permission to access 'http://linux.teamviewer.com/yum/stable/main/binary-x86_64/media.1/media' denied.
    Abort, retry, ignore? [a/r/i/...? shows all options] (a):

    It seems that 'zypper' works slightly different to 'yum' and needs reading permission for some extra files or directories. E.g. Google has managed to set up a repository that functions with both, 'zypp' and 'yum'!!

    marcos

  • DanielStm
    DanielStm Posts: 224 Staff

    @Guus013, @Werwolf, @marcos13: we have released an update.
    Please have a look: [Update: 13.1.3026] Spring Update

    Please uninstall the current package and replace it with the dedicated SUSE package.

    Linux Developer
Sign In or Register to comment.