teamviewer.com link icon
or
Ask The Community

Microphone volume decreases automatically

Everytime I seeing someone else's computer, the volume of the microphone in Windows settings decreases 10 by 10.

I noticed that if I speak loud enough that the microphone volume bar hits max, the volume on Windows setting will be decreased to 90 and I can't increase it back to 100. If the max is reached again, it goes to 80 and so on.

Until I close the remote connection, I'm not able to regain microphone volume and people start not hearing what I'm saying.  When I close the connection I'm able to increase the volume back to 100.

This only happens when I have a remote connection looking at another computer.

Please look into this. I thought it was my sound drivers, but I have used more than one version and it only happens with Teamviewer.

Thanks.

Comments

  • JLTJLT Posts: 7

    I too have this issue. It happens to both parties - whenever teamviewer is active as TeamViewer supports voice chat. For me, when the noise threshold is reached (configurable in TeamViewer under options > Audio conferencing) it does decrease the voume of the microphone and then locks it in place. This locking feature is undesirable.

    Real world example is your dog comes up to you and barks. A bark is quite loud. This will lock the microphone at a lower volume making it hard for others to hear you. The volume should fluctuate, reducing the volume with louder signals and increasing the volume for quieter signals. I think Windows does this natively but if not, then it's Chrome as I always have that open. With TeamViewer closed, the volume does fluctuate.

    Edit: furthermore, TeamViewer should not adjust the microphone volume when the microphone is muted. I use other platforms for voice chat so my microphone in TeamViewer is always muted but yet the volume is still affected.

  • Thanks for replying. Hopefully the devs will acknowledge this issue soon.

    For the time being, I found a workaround that might be useful for people with this issue. By going to Teamviewer options, inside Audio Conferencing, you can select a different microphone besides the one you actually need to use, like Sound Mixing. If your sound card presents you with something like this, just choose that for Teamviewer and your main microphone should be unaffected.

  • JLTJLT Posts: 7

    I did think of this too and it's what I may do.

    What I've done at the moment is used a "VolumeLock" thing (14 day trial) which works fine although I would rather not use this long term as there is a proper use for having the volume decrease in loud environments and increase in quiet environments.

    I'm not sure how to gain the attention of the devs. This issue has been posted about a few times and has been present for around a year to my recollection so I'm surprised they haven't took notice.

  • Yes we use SIP phones and this is becoming an increasingly big issue. When we open team viewer it auto corrects the volume so low that our customers cant hear us at all.
  • If you're using Skype um you go to the tools option up. here you go to your options and if you go to your audio settings. it should say automatically adjust microphonesettings. ... it automatically adjusts your microphone level it'll automatically go up and down tutuapp.software/.

  • JLTJLT Posts: 7
    I don't use Skype so I can't clarify if Skype overrides Teamviewer's mic volume. Regardless though, this is clearly a bug and shouldn't require third part apps to fix.
  • NataschaNatascha Posts: 1,013 Senior Moderator

    Hi there, 

    Thank you for your posts. 

    Maybe the following workaround helps to fix your issue: 

    Please right click on the speakers item in the tray menu --> Open "Sounds" --> Go to "Communication" and set the value to "Do nothing". Confirm the settings and try it again. 

    For further questions, please do not hesitate to contact us again. 

    All the best, 
    Natascha

    German Community Moderator
  • Have done this already as per all the other people moaning about this it needs to be checked by development. I work in a call center and we all have the same issue. We have explored every option possible and only when you open team viewer does it adjust your volume.
  • NataschaNatascha Posts: 1,013 Senior Moderator

    If I already wrote as an answer to the other topic:

    If you are a customer, I recommend contacting our support team.

    They can have a deeper look at what happens in your case or open a ticket for our colleagues in the 2nd level. 

    Thank you very much and have a great day. :) 

    Best, 
    Natascha

    German Community Moderator
  • JLTJLT Posts: 7

    @Natascha wrote:

    Hi there, 

    Thank you for your posts. 

    Maybe the following workaround helps to fix your issue: 

    Please right click on the speakers item in the tray menu --> Open "Sounds" --> Go to "Communication" and set the value to "Do nothing". Confirm the settings and try it again. 

    For further questions, please do not hesitate to contact us again. 

    All the best, 
    Natascha


    This is certainly not the issue.

    The problem is that when loud audio is detected, the microphone volume is decreased and stays decreased.

    Real world example:
    My volume idles at 87 under normal speaking conditions which is fine for me. When loud audio occurs such as a dog bark, the volume will drop sometimes to 40 or lower. When the dogs bark has finished, there will be no loud audio however, the volume still remains dropped making it hard for the other party to hear me speak.

    What should happen instead?
    If a dog bark occurs, the volume should drop due to the audio being too loud and therefore clipping. This is great, and this is what happens anyway. What should happen is the volume should increase when there is quiet audio.

    Try it yourself (Windows 10):
    Open up "Sounds" --> "Recording" and open up the properties of your microphone. Head over into the "Levels" tab. Here, you can raise or lower the volume of the microphone. Keep this open. Open up teamviewer and make a presentation (remote control might also have this issue - I haven't tested that). Create a loud sound. You will see the volume of the microphone decrease, and you will also see that it doesn't increase. If you tried to manually increase the volume, it will get reset back to that decreased state that Teamviewer has set.

  • luviniluvini Posts: 1

    i have been having this problem for the past 3 years, so i made this AutoHotKey script, it forces the mic volume to be set to 100 every 100ms (10x per second)  for device 6 (my mic, your device number may be different)

    #singleinstance force
    loop
    {
    SoundSet, 100, Master, Volume, 6
    SoundSet, 100, N/A, Volume, 6
    sleep 100
    }

    There is the "set the recording device of TeamViewer to a different one" approach, but then you have no way to make calls from within TeamViewer, so my script solves that.

    Still. TeamViewer SHOULD FIX THIS, we should not have to rely on my script for that long

    even Skype have a button to enable/disable auto adjusting of mic volume, why does TeamViewer have to have this forced on without a way to disable?

  • A proper fix for this has finally been found.  Since Teamviewer is now COMPLETE AND UTTER GARBAGE,  the fix is to simply STOP USING IT.  A ny Desk (http s://**Third Party Product**.com/) is now far superior anyway and it does NOT have this problem.  Good bye TeamViewer,  I hope you rot in h3ll.

  • A proper fix for this has finally been found.  Since Teamviewer is now COMPLETE AND UTTER GARBAGE,  the fix is to simply STOP USING IT.  A ny Desk (http s:// an yd esk. com) is now far superior anyway and it does NOT have this problem.  Good bye TeamViewer,  I hope you rot in h3ll.  The URL is messed up on purpose because the forum here sensors it for obvious reasons and it also wont let you say the name of competitors.  This is why TV is now garbage as far as I'm concerned.

  • A proper fix for this has finally been found.  Since Teamviewer is now COMPLETE AND UTTER GARBAGE,  the fix is to simply STOP USING IT.  There are plenty of other alternatives,  one is called **Third Party Product** A ny Des k.  Of course this forums it'll try to sensor the name for obvious reasons so I'll post it with full name and a **bleep** up version of the name.  It's FAR better than this **bleep**.

  • A proper fix for this has finally been found.  Since Teamviewer is now COMPLETE AND UTTER GARBAGE,  the fix is to simply STOP USING IT.  There are plenty of other alternatives,  one is called **Third Party Product** A ny Des k.  Of course this forums it'll try to sensor the name for obvious reasons so I'll post it with full name and a **bleep** up version of the name.  It's FAR better than this **bleep**.  Such a simple bug that has gone unfixed for over 2 yrs now is THE BEST reason to switch.  It's completely inexcusable to have such a bug exist for so long.  There is nothing they can do now that so much time has passed.  Even if they were to fix it now,  it's FAR to late,  they have already shown they are to incompetant and can no longer be trusted.  If they cant fix something this simple,  do you REALLY want to trust them with your PC's security?  I think NOT.

  • MannyMMannyM Posts: 1

    The problem can clearly be visualized by going to Meeting -> Extras -> Options -> Audio conferencing. There, look at the live signal cursor of the voice input. The green line is the autoadjust.

    When a loud noise is detected, it moves right (reduces volume) and stays there. From that point on, the volume of this voice is decreased, the guy is told to speak louder, does so, that microphone is automatically decreased even more, etc. Very frustrating. 

    Ms TeamViewer, please fix this bug!

  • Please fix this, we really want to use teamviewer as we are familiar with it, but right now we will have to choose another service.

Sign In or Register to comment.