link icon
Ask The Community

Commercial use - Connection time out



  • I received an email saying my Teamviewer ID has been successfully reset, but when I try to connect to my remote computer I still am flagged as a commercial user. I tried to submit another reset request for my remote computer's Teamviewer ID, but the website says "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    Please help!

  • MsBee
    MsBee Posts: 1

    I use this to support my 87 year old mom who lives in another state.  I followed the steps to get my ID reset and cannot reach the form.  I am getting the error "504 Gateway Time-out" when the form should appear.  The message above that states, "Sorry, that page is missing.  Do you want to check if a saved version is available on the Wayback Machine?"  If I click "Check for saved versions" apparently the wayback machine can't find it either.  I have tried this on both Brave and Chrome browsers, still can't get there from here.  Any suggestions?


  • same

  • I have happily used TeamViewer for more than a year to access my home computer's Plex library and to remote access my kid's laptops to monitor what they are doing when I'm out of the house and troubleshoot issues they may have when uploading their school assignments. Today, when attempting to troubleshoot an issue my son was having with his laptop I received the following message:

    "This software seems to used in commercial environments. Please note that the free version may only be used for personal use."

    "Your session will be terminated after 5 minutes. Please check our web site for further information"

    I do not have any commercial business to conduct in any way, much less remotely, so I do not know why I am receiving this message. Also, while I was still able to login to my son's laptop I was disconnected after less than 60 seconds and blocked from logging in again for nearly 10 minutes. Then, when I was able to login I was again disconnected after less than 60 seconds.

    Does anyone have any ideas?

  • Greetings, I keep getting the commercial use notice but I only use the application to help family/friends with problems as well as to transfer files from one of my systems to another of my systems, I have three systems. How do I get teamviewer to verify this?

  • same issue here. I use TV on my personal laptop at home, and only use it to support my mother who is 80 years old and doesn't live near me. Not sure why TV thinks I am commercial use.

  • Unfortunately I'm now a victim of this as well. This is absolutely a terrible idea, during the pandemic. 

  • Getting same issue with my iphone...

  • FWIW:  got the same message today, Chrome and FF, both latest versions.  Windows 10, just updated.

  • Hello I am using the free license (non comercial use only account) until today I had no problem accessing my home computer from my laptop. Today I logged in and then got this message after it logged me out of my PC,  "Connection blocked after timeout. Your license limits the maximum session duration to a partner, imediate reconnects are blocked. Please try agian later or upgrade your license".Was there a policy change? I have been using this free account for years with no issues. Thanks for any help

  • My computer was initially identified as "Commercial use" about a year ago. I requested a reset, because I never get a single penny from this use and I got it. After this reset some months ago, I again got the message that I was using it commercially. I requestaed again a reset for my computers and I received it a few days ago. But just one of my computers kept giving off the message of commercial use. I requested again (third time) a reset, but this is not being done. I even received a link that is sending me (after asking to log in) to a "Bad gateway". 

    Is there a way to be able to use TeamViewer as "Private use" without all these issues? If following all the requested steps does not solve the problem, what should I do?

  • klefr
    klefr Posts: 1

    For the second time, my connections throught Teamviewer free were cut-off with accusations of commercial activity.  I mostly use Teamviewer to communicate with the computer at the telescope in my backyard while I control and monitor the activity from indoors.  With the Teamviewer connection disabled I lost both nights observing and photographing activities.  

    I understand that you need to monitor for users using the Teamviewer inappropriately.  But couldn't you give a warning and a chance to respond without cutting it off withiout notice?

    Also, your procedure to cure the problem is unreasonable.  You requiire that I find some hidden links to request a form (and yesterday this did not respond for a couple hours, giving broken or time-out links).  Then print a form, sign it and scan it adn upload.  Not everyone has a printer and scanner.  I bought a car over the web using digital signing and didn't need a printer and scanner.

    While you have reenabled my access to Teamviewer, I am unhappy that you have cost me two nights of astronomical observing.  I am now looking into moving to **Third Party Product** to see how they stack up.

    Fred Klein

  • I am affected also, and submitted the form. However, there's no ETA on when this will get resolved. This is absolutely inexcusable to do to people during a pandemic and worldwide crisis where people rely on your software/service to support their families. 

  • Same problem here. I have already requested the reset, submitted the "affidavit" and received a response that it was received and a reset done, yet I still get the commercial warning and quick lockdown.


    OMG... The Nightmare on The Teamviewer Way is back!

  • Hello,

    Teamviewer closed my account maybe about a month ago, citing that I am using it for commercial use. I sent in the declaration of non-commercial use form (2nd time I've done so in the last year or two) and was approved to have my account reset and reinstated. However, my account is still closed. I've tried contacted them further and explaining that I have been disabled for over 10 years and don't work, offered to send them copies of that documentation, but have not received any response from them. I've tried calling teamviewer and the automated response directed me here. Can someone look into my account and help? I've only ever connected from my laptop to my desktop computer at home.

    Thank you,

    NAGDT Posts: 6 ✭✭

    @JWKinRVA wrote:


    OMG... The Nightmare on The Teamviewer Way is back!

    I think this is absolutely ridiculous! 

    I only run and use TV on two computers; i.e., the first one is my desktop with three internal and two external hard drives that is my family's file and backup server that sits next to my internet router on the first floor and the second one is my laptop that sits in my ManCave on the second floor to which I have attached my desktop monitor, keyboard and mouse. TV is the only way I can access my desktop and I only do this two to four times per month.

    What possibly activity could be construed as commercial? Copying a downloaded movie from the downloads folder on my laptop to the videos folder in my desktop, perhaps?

    This is horse manure!

  • Having the same problem as everyone else here, was flagged like a month ago. I've been disabled for 10+ years and only every used my laptop to access my home desktop computer. Offered to show them copies of my disability documentation, no response.

  • Nearly a week, with multiple people having issues, and no response.

    Needless to say I will be finding another solution.

  • My account is blocked, pls remove

  • Wow.... 111 pages of replies (and counting I'd suspect) and not one peep from TV. Just outrageous. A few weeks ago, all the sudden I got the **bleep** lecture that I was using my TV account for commercial use.I have used TV for YEARS to support my octegenarian parents and keep them and their computers on speaking terms. ;-) They're 800 miles away so remote connection is the only way. All TV's self congratulatory messaging about "greater good" **bleep** of offering a free version for personal use is just that. **bleep**.

    I jumped through their stupid hoops to "prove" that I was still using it for personal use, got a confirmation email that my account and the verified machine IDs had been unlocked. A few days later I tried to use it to help my mom and got the "unusually high activity" **bleep**. I hadn't even used the product AT ALL and they pull this **bleep**. Now, they won't respond to any message I send. TV "support" (and I use that term very losely) has gone dark.

    Disgusting level of dishonesty. They can spare me the noble messages about offering a free solution to help people. That obviously is no longer the case.

    I see that their community bots are blocking Third Party software names. Just so you all know, this probably isn't actual people doing it. They're likely bots. So you can get by them with special characters. (Note how **bleep** is showing in my post?) [removed per Community Guidelines]

    I'm off to PCMag to leave a public review for anyone looking for software, so they avoid this dishonest company for either paid or free. If this is their practice and how they choose to run their company, I wouldn't pay them either.

  • Just so you know, TV has removed my post I made about an hour ago outlining how this same thing is happening to me, and they have done NOTHING to resolve this for anyone. Apparently their model is "do nothing to help and remove anyone who calls them out on it." Great company policy guys.

    Beyond this one issue, this really shows what kind of company this is.

    [removed per Community Guidelines]

  • Thanks, I will try that out when I don't need unattended access for support. But the main reason I use Teamviewer is for unattended personal access. 

  • Hello,
    I was setting up remote assistance on my elderly mother’s new phone ( ) when I received the same commercial use message. Tried going through the unlock process online but the form and the site wouldn’t load properly. Finally Got as far as generating PDF then everything reset. One time the pdf downloaded but it was just a copy of the policy page.  Please help. 
  • i use free version for my home computer and laptop and also on my phone at times. i havnt used in while, when i went on to connect to my laptop it said commerical use dected. I am noy a comerical envirement, i use only for persional use. could you look into this, you can email me at**Information removed as per Community Guidelines**

    thank you

    michael peluso

  • Hello;

    I am a long-time user (free and paid) and am familiar with the commercial-use-suspected thing.  But I just got hit by something new.  

    I tried to connect to a machine (not commercial, and previous to this always accessible) and got a new message "because of very high usage" i was totally blocked from the machine.

    "very high usage" is unlikely because this machine is just an extra box that sits in my garage and does periodic backups from the rest of my families laptops, etc.  BUT, I went ahead and did the "commercial use" dance, listing all 8 of my families TV ID's, Printing, Signing, Scanning, Etc -- including the backup machine in question in the list of computers.  I was pleasantly surprised when my ID was "reset" super quickly, like within a day or two.

    However, when I went to actually connect to the machine again, I got the same thing. I looked at my teamviewer logs, they just say "blocked". 

    Following the instructions on the TV website, I tried to submit another form using JUST that machine's ID.  However when I log into the form creator part of the website, it then says "Your request has already been submitted and is pending further review. Thank you for your patience as we process your request."

    But the email you sent said the review was over?  So Now I can't do ANYTHING to fix this? 

    Please can I get some help here?         

  • So I thought I posted about this a week ago but apparently didn't.. My account the past month has been saying im not using it for personal use.

    I only connect to one friend to help him fix things with his computer and other than him I dont remember the last time I connected to anyone else. I read online my account needs to be reset and I need someone to do it for me. Could this be looked into please?

    Thank you

  • jbarnett455
    jbarnett455 Posts: 1


    because i have had the same issue when connecting to 1 of my machines however i can connect to all others on the same network just fine

  • I submitted a reset for reset about a week ago and I forgot to add the second ID involved in the connection, I don't see any way to add the second ID and the Reset Management page isn't allowing me to submit a second request. Is there anyway to "clear" or update this request for reset?

  • shrike4242
    shrike4242 Posts: 2 ✭✭

    I tried to fill out the form, which I was able to complete, though when trying to upload it, the website didn't provide any feedback that it did complete.   Further attempts to try and complete the process ended up with a 502 or 504 error on the website. 

    So, it's unclear of this will be fixed or not.  In the meantime, I'll go find use of another product less likely to ignore its users and make judgements without any easy way to resolve the issues.