link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

TeamViewer Host on Samsung Android?

Lucario Posts: 2


I tried TeamViewer Host on 2 of my samsung phones. Both of them will disconnect after a certain time, so they are not on my list of online devices. I will have to click on the teamviewer host icon again for it to be online again. It's definitely disconnected, because right after I click on the teamviewer host icon, it shows that teamviewer is activating again with a yellow dot, before becoming activated (Ready to connect) with a green dot.



  • Mferrell
    Mferrell Posts: 2

    This happens to me as well.  I believe the trigger is when the Samsung device goes to sleep.

  • Bill75
    Bill75 Posts: 4

    Hi , i have exactly the same problem with my S4 . I don t think this is an issue with the S4 going to sleep because i prevent it from doing so with an app and it also happens when i remote control it (after a few minutes ) .

    Any idea ?

  • Bill75
    Bill75 Posts: 4
  • I have had this issue also - any suggestions would be welcome on fixes or reasons,

  • bartlanz
    bartlanz Posts: 315 ✭✭✭

    In the Android Host settings there is one called Echo Mode, Try turning that off... or On...

    If my post was helpful, Please throw me a Kudos.
    If my post fixed your issue, please mark it as the solution to help the next person find a solution quickly.
    Bart Lanzillotti
  • Scotty
    Scotty Posts: 492 Staff member 🤠

    Hi Everyone!

    Unfortunately the "Eco Mode" wake feature is not available for the Samsung version of the app yet. I am sorry for any hassle there.

    But I have a Samsung device and experienced the same issue. The problem was the Samsung power saving option that was putting the app to sleep after about an hour. When I unchecked the power save option, it stayed online.

    Hope this helps!


    Senior Moderator
    Did my reply answer your question? Why not accept it as a solution to help others?
  • Bill75
    Bill75 Posts: 4
    Hi , thank you for the answer . It isn t a sleep mode issue . I prevent the Samsung from going to sleep and the issue also happens while i remote control it (after less than 2 minutes). Worst of all , after the disconnection , the phone isn t to be seen by the group . The app is unfortunately not usable at this stage . I m pretty sure a fix is needed (will it ever happen ?)
  • elbubi
    elbubi Posts: 2

    This issue happens to me as well since a few months ago.

    It's definetly not a sleep issue (it happens with energy saving 100% disabled too).

    In my case (Galaxy Note5), it started with Nougat update, as it used to work flawlessly under Marshmallow.

    Please, fix this annoying issue in order to use this great app again!

    Regards and thanks in advance!

  • I encountered the same problem today... Many thanks for posting it.

    My phone is Samsung Galaxy 7 and the Android platform is 7.0. The "Host for Samsung" went offline on my phone this morning after five days' normal working. A similar problem was reported by "boojay" in another post:

    Sincerely hope that TeamViewer could give some suggestions towards it.

  • I have that problem too. OnePlus 5, Andorid Nougat (seems that would be the problem)...

    Like someone said above, atm app is unusable to control smartphone :(

  • Same problem here on Galaxy Note 8 and Galaxy S6. After short time the phone's dosent listed online.


  • Same problem here. TeamViewer shows Android devices in standby when the screen timeouts and locks so you cannot connect and remote control. Tried different smartphone brands and Host for Samsung as well as TeamViewer Host on Android version 7. It does not show online again until the device is unlocked and you switch to the host app to get to display "Ready to connect".

    This did not happen with previous Android versions so you could remote control and unlock. Can someone please investigate fix this bad bug/malfunction?

  • Avara
    Avara Posts: 1

    Same problem. Devices will not be connectable after a while. If i activate any of my devices manually, in a few seconds the host app seems to wake up in the background for a while. Tested on Lenovo A806, Huawei Honor 5c and PLK-L01. It's probably some power saving / sleep related problem ~ the host app just isn't staying awake enough.

  • I had this problem on Samsung and found out that it happens when the device goes to sleep without having the Host application in foreground.  

    My crude workaround, until this is sorted, was to install Tasker and set a profile & task which launches Host (without new copy) whenever the screen goes off.   Works well enough.

  • Hi , the fix wouldn t work for me because TW disconnects even if the phone never goes to sleep (i ve installed an specific app to be sure it never does) Thanx
  • I downloaded tasker several months ago for this issue but just haven't had the time to sort it out.  Is it a straightforward setup and if not, can you nudge us in the right direction by posting instructions?

  • I' ve solved this problem by unisntalling "Samsung Host" and installing just "Host".

    Not only this version solved unwanted disconnection issue, but is also adds "Eco Mode".

    Hope it helps you too.


  • Just tried this but unfortunately it didn't change a thing for me.
    On my s8 and on my gf's A3 2017, host keeps disconnecting after a while.

    I've tried to exclude it from power saving monitoring, i've tried disabling eco mode but no way, it just goes to sleep after some time.

    Btw on my mother's in law's J3 this doesn't happen.
  • YvesKlein11
    YvesKlein11 Posts: 1

    Non-Samsung HOST on Samsung Tab A T555 with android 7.0 required activation of Knox - and then did the trick at least for 12 hours now. Thanks  for sharing!