link icon
Ask The Community

Commercial use - Connection time out



  • SoCalStephen
    SoCalStephen Posts: 1 ✭

    WHY won't TeamViewer provide an answer to this????

  • Strangetrip
    Strangetrip Posts: 0 ✭

    What is the recourse for private non profit users getting flagged as commercial users?

  • Grandview
    Grandview Posts: 1 ✭

    I have a family farm. Soon after I signed up with Teamviewer I called them to see if I needed to buy a commercial license. They told me I didn't. Now I always receive a message saying that commercial use is detected and then it just kicks me out. It is of no use to me now. How can this be changed?

  • The same thing is happening to me. I am a student. Please fix.

  • My wife and I are volunteer archivists at a small, all volunteer museum, which is closed due to COVID. We have been using Teamviewer to work on cataloging our collection from home. Last year we got flagged as commercial users. I wrote a protest and my wife got reinstated, but my account never did. I can log in and connect for about two minutes before I get kicked out.

    I have tried emailing the company repeatedly over the past few months, but have never gotten a response. What can I do to get access again?

  • dondd
    dondd Posts: 0 Newbie

    A few months ago, trying to assist my brother, I tried connecting to his PC but got the msg that your system thinks I made too many remote connections and blocked my connection. I'm not sure how that is possible, as I'm not on Team Viewer for months at a time, but when I have a friend or relative with a problem, I may connect 2 or 3 times to resolve their issue.

    Today I got an email from Team Viewer indicating that their legal stuff has been updated. In the process of signing in, I got an alert that the system doesn't recognize this device. Strange, as this device is my main computer and I use it 99% of the time. So they sent a confirmation link to "trust" this device. And is how I'm able to ask this question. The only possible reason I may be blocked is that occasionally I use my VPN, and they got an IP that maybe has been used by someone with Team Viewer. Otherwise, I use this very little, and only connect to about 10 friends and relatives sparsely.

    Any thoughts would be appreciated! And if possible, remove the block.

    Thanks, dondd

  • User2358945321
    User2358945321 Posts: 6 ✭✭

    Is there any resolution for not being able to get connected? This started before Christmas and I keep getting a time out then unable to reconnect for a time period.

    I only use it with my parents and it worked for years until recently.

    I have tried to contact Team viewer for help but never received a response.


  • I have the same issue, started about the same time, have had the same results. I use it to help my brother with his "techno-phobia" Have been a user for years without issue.... but now they seem to think I am a commercial user. That is NOT the case. It is a shame... This really helped me keep my elderly brother in the 21st century.

  • catt0301
    catt0301 Posts: 0
    edited January 2021

    Why do I keep getting kicked off when I sign on less than a minute seconds it shuts me down

  • For the last few months I can only remote to my computers for about 30seconds before it kicks me out!

  • Slingshot41
    Slingshot41 Posts: 0 ✭

    For the last few months I can only remote to my computers for about 30seconds before it kicks me out!

  • JZDeath
    JZDeath Posts: 0 Newbie

    I applied for and received a reset just a few weeks ago and already it is locked again. I have 3 personal PCs I occasionally connect to. All 3 are personal: 2 family members and one friend. My only purpose is to help them (all older people) with their computer problems. It is VERY frustrating to be locked out right when I am trying to help them. Can you please fix your algorithm or whatever it is that incorrectly tags me as commercial?

  • User2358945321
    User2358945321 Posts: 6 ✭✭

    Have you figured out how to resolve it? Or had any feedback from Team Viewer?

  • dbassman
    dbassman Posts: 1 ✭✭
    edited April 2021

    I've been having the same issue for some time, along with a couple friends. After not hearing back from TeamViewer I basically gave up and switched to ** Third Party Product **. Just like any other program and has pros and cons to TeamViewer, but seems to work fine and is also free for personal use!

  • Jon_P
    Jon_P Posts: 0


    I use Teamviewer to remotely help my parents with their computers. I have never had a problem logging in until today. I connected and immediately was kicked out with a message of:

    Connection blocked after timeout.

    Your license limits the maximum session duration to a partner, immediate reconnects are blocked. Please try again later or upgrade your license.

    Connections to this partner will be blocked until xx:xx

    Can someone point me in the right direction to alleviate this issue?

    Thank you

  • I'm trying to find out what this change of the rules are to affect private users I use team viewer to help friends can anyone give me any help as far as deciding if team viewer is going to be free for a while for private use and how many times can you connect to the same person with this version Michelle

  • mochajane2009
    mochajane2009 Posts: 1 ✭

    Why do I keep getting blocked out? I use TeamViewer for personal use only!

  • Dgutkin
    Dgutkin Posts: 5 ✭✭

    Your site is very difficult to get answers. I have a personal use account and I keep getting message that I have a commercial account and has expired. This happens only on my ipad.. what gives.. your support is not easy to use. I tried to reset and got nowhere

  • Alex3012
    Alex3012 Posts: 0 Newbie

    I'm trying to connect to a remote machine. It works for a few seconds, but then TeamViewer says that session has timed out. I've tried rebooting the remote machine and restarting TeamViewer, but that didn't help.

    On a second reconnect, TeamViewer shows a message - "Connection blocked after timeout. Your license limits the maximum session duration to a partner, immediate reconnects are blocked"

    I use TeamViewer a couple of times per year, and previously it was not an issue.

  • I am using the Teamviewer free personal version in my PC(Windows 10 Pro) and my laptop. I was able to connect whitout any problem until recently. When I connect now to my laptop, it connects only for 1 minute and then disconnects. If I try again, Teamviewer will send me a message that I it detected a commercial use.

    I do not know what changed the behavior of Teamviewer .

    Any thoughts?

  • Darktwain
    Darktwain Posts: 6 ✭✭

    This is probably not the right place to leave this post but I can't get a response from anyone @ Teamviewer. It's funny too 'cause someone from there contacted me last year when I was getting blocked for 'commercial use' which was not happening. I finally gave up and found something else and then this year I decided to give it a try again and it has been allowing me use. Here's the thing. I have 2 desktop computers that I connect with using my laptop and I'm only connecting to 1 at the moment out of fear of being flagged again for 'commercial' use. I just want to ask someone if it is OK now for me to connect to both without being flagged. Who can answer me?

  • User2358945321
    User2358945321 Posts: 6 ✭✭

    Thanks, I will check that out. It is frustrating that it just doesn't work any more. I wish Team Viewer was interested to help. It has always been an easy connect before.

  • I have used Team Viewer for years on my personal computer but now every time I try to use it it times out and says I am a commercial user. How do I get this corrected?

  • IndygoDave
    IndygoDave Posts: 0 Newbie

    Before I can see what problem my friend is having, TeamViewer disconnects and tells me I am locked out for 20 seconds, but even after waiting long past that, will not allow reconnect. What am I doing wrong?

  • dumas_blr
    dumas_blr Posts: 9 ✭✭
    edited January 2021


    I've been using your teamviewer software for more than 12 years and I find it awesome !

    However, we're encountering issues I cannot explain, and I need your expertise.

    I use teamviewer for non-commercial use, especially in a supporting association connected to a protestant church with volunteers.

    This allows me to remotely perform maintenance operations in case of issues.

    Due to COVID situation, this remotely use is more important than ever.

    In order to be the most efficient as possible, I have created a dedicated account which allows me to gather all the computers I use to work in "computer & contact".

    Actually, all my remote access operations work perfectly, using my**Information removed as per Community Guidelines**account.

    I'm now pushed to delegate some of my operations to another person. For obvious reasons, I do not wish to give him my ID & Passwd, as some of my contacts are private (family). 

    Therefore, we have created a personal teamviewer account : **Information removed as per Community Guidelines**

    Then we have added the same device to his contact, in order to allow him the remote access to the same computers. We have tested locally & remotely on January, 15 and it worked perfectly.

    Today, my colleague made another attempt to remotely connect to the computers from his home, and each attempt came to failure. Most of the time, it asks for a password, although never been required before, even with this account.

    With dumas.blr, connexion behavior is not similar (see attached video)

    connexion to "entraide accueil" (timestamps 00:00:00 to 00:00:29) -> connexion successful

    With Philipe Weber:

    connexion to "entraide accueil" (timestamps 00:00:39 to 00:00:46) -> connexion failed 

    you can see the different option setup attached to this account timestamps 00:00:46 to 00:01:20

    My question :

    can we have a restraint or conflict issue in the free version with the same ID declared with different accounts ?

    For information

    Here are the different TeamViewer ID.

    Expecting for your expertise.


    Jean-Yves DUMAS

  • Zierde
    Zierde Posts: 0

    I just opened up a personal use account and when I reach out to my connection, it won't stay on longer than about 10 seconds.

  • jbadboy332000
    jbadboy332000 Posts: 1 Newbie

    My free account is being treat aa business account but I don't use it for a business

  • PeteS
    PeteS Posts: 0 Newbie

    Why did I get get off after a few second and locked out on subsequent retry attempts

  • upgradde
    upgradde Posts: 1 ✭
    edited January 2021

    I have used team viewer for years to help my friends with issues, and yesterday I tried to remote into my friend's computer and it the application said that it had detected commercial use. I've never charged for my help, and I've never used teamviewer for work (we have our own remote software). When I connect, it automatically disconnects and says I can't reconnect for ~18 minutes.

    I was hoping someone could go into my account and clear this issue up.

    His ISP is Cox Communications (persona, non-business) and my ISP is AT&T (personal, non-business).

    I can provide IP's if necessary, but I was hoping this would be easy to clear up.

    We had to use **Third Party Product** last time, hoping to switch back.

  • jbadboy332000
    jbadboy332000 Posts: 1 Newbie

    I have a free account and it saying I'm using it for a business. How do I submit I'm using it for personal use