link icon
Ask The Community

Connectivity issue Android 10.

Doggy Posts: 2 ✭✭
edited February 13 in Mobile


I'm new to this so, I'm sorry if its in the wrong section.

Can anyone explain to me why, after installing Host on three different phones with three different versions of Android (6,10,10), only the one with Android 6 works most successfully. For example, on an Android 9 device, if I haven't run Host, it doesn't work. On the Android 10 device, even if I run Host manually, it disappears after about 10 minutes and I can't connect. On all devices I stopped the dependence on the battery and there, whatever it is, as an obstacle for the Host app. I've been doing tests for a week, the cleanest works with the device with Android 6, the other two give anomalies. Second example with the Android 10 device, I run the host app manually, try to connect to it from a computer, make a connection, but I don't get a screen, none. And the phone reports a connection. Where do you think I should look for the problem?

edit: two device with android 10 and one with 6.

update: three work well when cable charger is plugged in. after restart of the phones only the one with android 6 can be connected. Other two need manual start of the Host app.


  • Fiona_G
    Fiona_G Posts: 689 Staff member 🤠

    Hi @Doggy,

    Thank you for your post.

    Possible reasons for this may include: 

    1. Background app management closes the TeamViewer Host
    2. The device cuts off the apps internet connection when the device is locked.

    Please turn off the advanced battery optimization (Different for every brand and some phones even have 2 layers of this) or try eco mode.

    I hope the information above would be helpful. If this doesn't fix it, please raise a ticket to get 1-0n-1 support if you are a licensed user.

    Best regards,

  • Doggy
    Doggy Posts: 2 ✭✭

    I already tried those steps, and many more.

Sign In or Register to comment.