link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

Commercial use - Connection time out



  • DBquick
    DBquick Posts: 8 ✭✭
    edited February 19


    I hope you are all fine and healthy!

    Today, I have installed TeamViewer (free license) for a first test on my computers. In general, I am very happy with the product, but I have recognized that the connection closes itself after 30 seconds. Reason for that: Timeout of the connection.

    Do you have any idea how to fix it? 30 seconds is really short to test a remote control software.



    a reinstallation is not fixing the problem and I have for sure a free license! Furthermore a commercial use is NOT suspected

  • DBquick
    DBquick Posts: 8 ✭✭
    edited February 19


    I hope you are all fine and healthy!

    Today, I have installed TeamViewer (free license) for a first test on my computers. In general, I am very happy with the product, but I have recognized that the connections close themselves after 30 seconds. Reason for that: Timeout of the connection.

    Do you have any idea how to fix it? 30 seconds is really short to test a remote control software.



    a reinstallation is not fixing the problem and I have for sure a free license! Furthermore a commercial use is NOT suspected

  • DBquick
    DBquick Posts: 8 ✭✭

    Same problem here!😬

  • cyberpunk2324
    cyberpunk2324 Posts: 1

    I just used to use Teamviewer for private purposes.

    But when yesterday, every connection showed the messages below.

    I tried to remove Teamviewer and reinstall it, but things have never changed.

    I have never tried to used Teamviewer for commercial purposes.

  • FloMUC
    FloMUC Posts: 1 Newbie
    edited February 20

    I experienced the problems described above as well: "Connection blocked after timeout. Your license limits [...]"

    I'm especially disgusted, that there is ABSOLUTE ZERO TRANSPARENCY in this message:

    • Neither a REASON given ("commercial use" is NOT mentioned anywhere).
    • Nor a link/help how to RESOLVE the issue. (Leve alone, that block until times are incorrect.)

    IMO it's a very shallow way of trying to trick users into payed licenses? IMO that will hugely backfire.

    BTW: I also use TV on work (totally different machines/accounts); that was the reason I installed it for private use in my home too, as I already was familiar with the software.

    Guess, what will happen, when the (100+) prof. licenses need to be renewed? If this issue (described in this forum) isn't resolved quickly, I will definately speak out in our company to switch to a competitor software.

    I don't like to do business (nor be involved in any way) with a company which:

    • is 0% transparent
    • seems to assume I'm cheating
    • lies to me (it says, it's free for personal use; but I just waste time with a non-functional software - with the time wasted I could easily afford a couple of licenses)
    • tries to lure me into giving them money with cheap tricks.

    Either fix these issues QUICKLY or I will predict you will lose quite some PAYING customers in the future...

    Your choice. Not mine. I have options. And I definately won't pay for a commercial license to use it in a private setup, after what I'm experiencing right now.

  • derKarl
    derKarl Posts: 3 ✭✭
    edited February 21

    pretty much the same issue since today... using TeamViewer for quite a few years now to access my computers at home from one single system (as I got a few older systems running with technical difficulties... like broken built in keyboards in the notebook for example)

    today I was logged on to a longer session and accidently closed it... after reconnecting and trying to work from my windows 10 machine in my home network (both systems in the same network and both are actually in the same room) I got a timeout message after a few minutes of using... and no, I am not getting any warning or info that I am suspected of using it commercially... which I don't do by the way... I am just sick of trying to type on non working keyboards and have no space to use a external one on my notebook as the desk is too small then

    and after getting a new one for my big tower (as the old mechanical one had some keys stopped working after like 4 years of daily use) I enjoyed working from one system on both machines via Teamviewer... but now it is a pain in the ***bleep*** with getting bumped and locked for a few minutes before being able to reconnect... even reinstalling didn't fix the issue... so I tried to create an account... to see if this works... nope... got me the same result...

    ...and support seems to only be for users that got a company license... which I don't have (as I am not a businessowner and never used it commercially)

    I did send feedback today so let's see if there is something coming back... if not... yeah... then I gotta find a different solution

  • kkrisz75
    kkrisz75 Posts: 0

    The same thing happens to me.

    I work in Germany, but my family is in Hungary.

    I monitor the computers of my children, my parents, my family through this. For years, even living in Hungary, I have used this so that I don't have to travel a lot to solve a problem.

    But today I can't fix the kid's machine because after 20-30 seconds it will be disabled and the system will throw it out.

    Due to timeout. The license only entitles you to this.

    although I am not using it for business purposes. But I have been using it for private purposes for years. A free license is also registered. Even in my profile, it still doesn’t allow me to work on machines.

    A solution soon would be good. This is not a fair procedure. No warning, nothing. However, it is advertised for private use as free.

  • Runar1234
    Runar1234 Posts: 0

    Picture under is a message i get when connecting to my home. In my job i travel around the world, and i use Teamveiwer to connect to two computers home, and booth has the same issue. This message will come 1-20 sec after connecting. Same issue if i get someone home using one of these two computer to connect to mine.

    Translate int something like this.

    Connection blocked after timeout.Your license limits the maximum session duration to a parntner - immediately repeated connections are blocked. Please try again later or upgrade your license

    If i wait for 10 min or 2 hours, it will just report the same, and im not able to connect.

    Ideas ?

  • I am using Teamviewer non-commercially and I requested a free license in the past already as a commercial use was detected at that time. I remember that I have received a notice that commercial use was detected.

    Now I am not getting a notice about commerical use, I just get a timeout after a few seconds and cannot login again for some time. Is this again related to a detection of non-commerical use? Or something different? I was also not able to find anything in the management console.



  • Teri_Lee
    Teri_Lee Posts: 0

    I have the same problem, and not sure why it is happening either.

  • Leling
    Leling Posts: 1 ✭✭


    I'm using TeamViewer for multiple private computers, but since a few days I'm getting a message that I'm banned because I don't have a license and commercial use is detected. I think your algorithms to detect commercial use have been failed - do you need support with your algorithms?

    Luckily I'm from Göppingen and know your new impressive building and I'm open for a position as Data Scientist/AI Engineer - interested? I'm waiting for your message.

    Otherwise thanks for unbanning my account.

  • Hello I am using the free license (non comercial use only account) until today I had no problem accessing my home computer from my laptop. Today I logged in and then got this message after it logged me out of my PC, "Connection blocked after timeout. Your license limits the maximum session duration to a partner, imediate reconnects are blocked. Please try agian later or upgrade your license".Was there a policy change? I have been using this free account for years with no issues. Thanks for any help

  • Pirte1
    Pirte1 Posts: 1

    Why do teamviewer limits my connection to my desktop (remote from phone)? If i remote my desktop from another desktop, it works fine...

  • Chris_123
    Chris_123 Posts: 0 Newbie
    edited February 23


    My ID is **Information removed as per Community Guidelines**, I just use teamViewer to communicate parents on computer program, never use for any commercial reason

    Pls help to chk & reply email to **Information removed as per Community Guidelines**

    I have been waiting for a few days already!

  • dxnnyy
    dxnnyy Posts: 0

    as well as the title said, ive been using teamviewer for years and this was my first encounter, the popup said im using teamviewer for commercial purposes and automatically ended the season, what did I do wrong here?

  • IngridB
    IngridB Posts: 0


    I am having the same problem

    Have you found a way to solve it?

  • DBquick
    DBquick Posts: 8 ✭✭

    Thanks to both of you for your comments!

    Hopefully, we get a official feedback soon.

    By the way, I am working also from Germany. Maybe this is a country or continent related issue 🤔

  • MonteChristo
    MonteChristo Posts: 1 Newbie
    edited February 22

    Nope, the remote PC is running the latest (at least the check for a new version says so) and the session keeps timing out after 3 or so minutes. TeamViewer is useless to me now. This is on Win 10 Pro 20.04 H2.

  • Heinvomberg
    Heinvomberg Posts: 0 Newbie

    Hi All!

    I have the same issue with my Win10 version since a view days.

    And no idea, how to fix them.

    Interesting: The IOS version is working properly.

    Will anybody of TV read this blog???


  • PeziSbg
    PeziSbg Posts: 0 Newbie

    I have the same problem,

    I am using TeamViewer free license since many years, But after the latest update after some minutes the connection has been interrupted. Furthermore, I deleted the program and reinstalled the Free license Version. But the same happened.

    I am predominantly using TeamViewer to connect my smartphone with quick support to my notebook. Sometimes I am helping friends and family members with remote support.

    I am hoping it's only a bug

  • jenskirch
    jenskirch Posts: 1

    Hello fellow sufferers,

    I am also having this problem right now. Based in Germany and taking care of my families PCs and my own ones while I am at my gf's place.

    Getting time outs and blocked from direct reconnects.

    Can't tell when it has started to behave like this, since I am not constantly using it.

    Hopefully it gets resolved quickly.

  • DBquick
    DBquick Posts: 8 ✭✭

    Looks like a big bug!

    Hopefully, we will get a quick response. I wrote a pm to the moderators, maybe it will help us.

    @Moderators: We all have a free license for sure and a commercial use is NOT suspected! @Natascha @JeanK

    (Just to be sure, because I have seen threads of other people regarding this topic which were randomly merged to the "commercial use" topic)

  • MrLargent
    MrLargent Posts: 2

    Same here- one account out of 3 I have been connecting to for many years is now having this issue. I am 100% using for personal/family...

  • dprobst
    dprobst Posts: 0 Newbie

    Same with me until last week everything ok. Update today 22-2-2021, timeout after some 30 seconds

  • Battousai124
    Battousai124 Posts: 4 ✭✭

    Is this how you are trying to bully customers into paying for a commercial license they don't need?

    I have been using TeamViewer for years now and never once had a problem, today however it started.

    I have a stable internet connection, but still, when trying to remotely control my computer that is about 3 meters to my right, because I am a lazy guy, I cannot connect to it for even a single minute, without it giving me the timeout **bleep** and blocks any attempts to reconnect.

    I timed it!!! 51 seconds. 51 seconds is all I get, when I want to use it to control my PC, so I can listen to music with an actual sound system or do anything else.

    Then I get the message, that reconnection attempts are being blocked for 1 minute, of course I wait that minute and of course, after that minute, I get the same message again, with the same 1 minute cooldown.

    I reinstalled the program TWICE!! and absolutely no change in behavior.

    Thank You!


    a former user

  • Frimuz
    Frimuz Posts: 0

    Same Story here. Using it to help a friend with computer problems.

  • Teri_Lee
    Teri_Lee Posts: 0

    Good evening,

    I keep getting logged out of my connection and it says "connection refused due to timeout". I'm not sure why this keep happening or how to fix it.

    Please advise and thank you.

  • DBquick
    DBquick Posts: 8 ✭✭

    Same problem in my discussion. So far, we are waiting for a response

  • Keifus
    Keifus Posts: 4 ✭✭

    I have been having issues with TeamViewer timing out after like 5 minutes I been using the free version and i think maybe someone i connected to installed it commercial and not the private. Can you fix my account back to normal please

  • Tracy1
    Tracy1 Posts: 0 Newbie

    Same issue here. Worked fine last I am unable to connect for more than a few seconds and then it times out. This is very frustrating as the connection is needed to work from home (and impending deadlines for work are not able to be met due to this new issue). FWIW, I am also in Germany and using a free license for personal use only.