Commercial use - Connection time out



  • melloa
    melloa Posts: 0 Newbie

    Why my post was merged here? It has nothing to do with commercial use. I have 8 computers using it and use once or twice/week if that. Just been disconnected after a minute or so.

  • Katy35_onSt
    Katy35_onSt Posts: 2

    Hi there,

    I have been using Teamviewer for over a year now. I help my nephew with his schoolwork. I got a message saying that I have reached my maximum session duration with him due to licence limits.

    What do I do now to stay connected to him?

  • dopalaczxl
    dopalaczxl Posts: 0 Newbie
    Hello. I have had a problem for some time, my connection is disconnected because the system has detected that the program is used for commercial purposes.
    What can I do with this?
    I had a laptop connected with a phone and once in a while I needed it when even my other half could not print documents.
    I don't run a company, I don't work remotely.

  • icaruswp
    icaruswp Posts: 0 Newbie

    Dear Sirs

    I'd like to claim that my TeamViewer account is suspected as Commercial, however I'm using it only to access a couple of my own devices and my parents' PCs. I can prove it by providing all the necessary data about each device. Waiting for your comments. Thank You!

  • kellyloraine
    kellyloraine Posts: 2 ✭✭
    edited March 2021

    Hi all,

    I'm having an issue where my connection times out (free license non-commercial use) after just a few minutes, then when I try to reconnect, I keep getting the message "Connection blocked after timout. Your license limits the maximum session duration...... Connection to this partner will be blocked until..." and even when I wait until past that specified time, I get the same error again with a new time.

    I have three computers connected to my account -- my new laptop, my older laptop, and my mom's laptop -- so I can act as tech support for my mom (lol). I only have this issue connecting to or from my new laptop. Older laptop is on the same wireless internet and is fine.

    Thanks in advance!

  • Jules55
    Jules55 Posts: 0 Newbie


    Is anyone else having issues with the windows updates released on the 23rd March 2021 ?

    I think the numbers are KB4589212 and KB4601554.

    I have two systems both Windows 10 - i5 Platform Systems

    One did the updates the other didn't.

    The updated system now times out within a minute the other stays connected as it all ways had.

    Nothing else has changed as far as I can see.

    I have had a issue / Dymo had issues this month when an update stopped all their label software from printing,

    all you got was a blank label.

    Looks like Teamviewer may have similar issues........



  • Jules55
    Jules55 Posts: 0 Newbie

    Both systems are using:

    Teamviewer 15.15.5 ( 32bit )

    Feb 17th 2021 18:13

    Version Software

  • kellyloraine
    kellyloraine Posts: 2 ✭✭

    Hey, There is no mention of suspected commercial use in any of the messages that pop up or anywhere on my account when I face my issue of a timed out session. My question was merged with this thread. Is it indeed then suspected commercial use? Thanks!!!

  • JeffMc4
    JeffMc4 Posts: 0
    edited March 2021

    Hey Everyone.. I've been using Free TeamViewer for years.. I connect to my home computer every day to assist my children with remote learning. I love the program. Starting yesterday, after about 1 minute of being connected, the session times out. This has never happened before. I've tried this for 2 days now and can't stay connected for longer than a minute.

    I have the latest version installed and nothing has changed from Friday when I used this and it worked fine. Is anyone else having this issue?

    Thanks for any help!

  • Rootdet
    Rootdet Posts: 0 Newbie

    they deleted a big thread here on it. seems like this is the new "free tier", and they rather have people just leave the platform.

  • tinem
    tinem Posts: 7 ✭✭

    I have the same problem and are about going crazy. Did you solve this problem, please tell how?

  • priyankapotluri
    priyankapotluri Posts: 0 Newbie

    How to resolve this issue? Please help meASAP

  • CNewhouse
    CNewhouse Posts: 1 Newbie

    Message reads connection blocked after time out. Your license limits ..... to partner

  • degarmoj
    degarmoj Posts: 1

    I have the  free version and it keeps timing out. Only after 1 minute.

    Error Message:

    Connection blocked after time out.

    Your license limits the maximum session duration to a partner.. Immediate reconnects are blocked.

    Try later or upgrade your license.

    I never had this problem before

  • José_António54
    José_António54 Posts: 10 ✭✭
    edited March 2021

    Good afternoon

    I have long used the free version of Teamviewer for private use of Teamviewer for remote sessions.

    Now I have a problem when I enter the remote computer, I get a message "Connection blocked after time exceeds" and cancels the connection in less than 1 minute.

    I don't know why, but I'd like you to enlighten me.

    My Account: **Do Not Post Email Addresses**

    Best regards.

    I await your answer.

    Thank you very much


    I can't attach the file with the error, so I report it here. "Connection blocked after time is over." "Your license limits the maximum session duration for a partner and new immediate calls are blocked.

  • I've been having issues with the same. Any updates? I am going to reach out to them for an answer. Will check back.

  • Just tried calling and no phone support for free users. I've tried uninstalling and reinstalling to no avail. I'm starting to believe Rootdet is correct.

  • Johnny_B
    Johnny_B Posts: 0

    That's a shame - I've been using it for years, especially to help my family etc. Hopefully it's something with a MS update that is causing this and not them, if so, I will not be paying 50/month. I'd pay 50 a year but a month? For personal use? Nuts...

  • BJK
    BJK Posts: 2 ✭✭

    I am not flagged as a commercial user. The newest version of the personal Teamviewer times out.

  • Even if you're not getting the commercial warning you do need to reset. My teamviewer is back to working normally but I had to do resets on both my client and remote IDs. Took about 24 hours.

    To be clear I never got the warning about detecting commercial use. Not once ever. So it's doing this to people without the proper warnings TEAMVIEWER. Pay attention.

    Again: The reset link is on page 1 of this thread

  • So obviously you guys wanna keep your helping of free users to an absolute minimum. I get it, but you're shooting yourselves in the foot if your program wont at least give them the error messages you tell your users to look for on the community forums.

    Tons of people have having the 'commercial use detection' issue right now but your current version of TeamViewer doesn't actually give that error. It just disconnects the user after a minute saying to try again in another minute. Nothing about commercial use is in the error at all. There are plenty of screenshots that show that in the main thread about it.

    Yet your guides all say "Why do I see 'Commercial use suspected' / 'Commercial use detected'"

    That's not what your program tells the users. It's not even close. Maybe fix your app?

  • Krell356
    Krell356 Posts: 0

    Reset link isn't working. It won't do anything when you click the generate PDF button after I fill in the info. So what am I supposed to do at this point?

  • paul-emil
    paul-emil Posts: 1

    How is that it's not about commercial use detected, when the author ends his post by «[...] and now suddenly "suspecting commercial use"?»

  • Jvijssel
    Jvijssel Posts: 0

    How do I know what my Account Registration ID is? How do I know if I haven't downloaded a commercial kind version of TeamViewer? A few weeks ago I could use TeamViewer without any kind of problems and now I suddenly saw a popup with the message, that I'm using TeamViewer commercially..........I think that very strange 😣

  • 12_Dns
    12_Dns Posts: 7 ✭✭

    Hello! Why am I only given 1 minute per session? This is very small. Previously, it was given for private use without restrictions.

  • alan-hurley
    alan-hurley Posts: 5 ✭✭

    As of the new upgrade to TeamViewer available as of March 24, 2021, my free license has been limited to a connection duration of just a few minutes. After that, I am disconnected and when I try to reconnect, I am told I will have to wait a few more minutes. Why is this happening? I didn't do anything to deserve this!

  • kklosterman3
    kklosterman3 Posts: 1

    I am using your free PERSONAL USE TeamViewer to access my grandkid, and older sisters

    pc's for non business use just to help them out with things.

    In the past, you have listed or flagged me as business use, and after correspondence with

    your teams, have been put back under personal use verified again.

    Everything has been working fine until the other day, when I was accessing my sisters pc,

    and doing some screen sharing with her to me. I noticed I didn't have the ability to share

    my screen with her. So I had her go into her TeamViewer account to the remote access area.

    And do a remote connection to me. Which allowed her to see some ancestry pages with me showing her my view.

    Now all of a sudden, when ever I connect to her, or even my other relatives, it times out

    the connection and drops me out in under a minute.

    Is there something that is causing that like being flagged again as business use?

  • Kraschman1111
    Kraschman1111 Posts: 0 Newbie

    Having the exact same problem. I use it to connect to other machines in the house or to/from my mobile devices. Whatever this problem is, it's making the software unusable.

  • Slorrin
    Slorrin Posts: 1 Newbie

    Hi. I have a personal license, and every time i connect to my desktop from my laptop, the connection lasts 2 minutes, then says it timed out.

    In extras/options/advanced/connections to other computers i have the timing out inactive session slider set to "off" on both computers. I have also tried setting it to 8 hours on both computers, but it doesnt' matter.

    It doesn't matter if i'm behind a VPN or connecting raw, the session lasts about 2 minutes, then says it is inactive and times out.

    What can I do?