teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Teamviewer goes "offline" when locking pc.

On my Microsoft Surface Pro 3 I have installed Teamviewer as a service. Everytime the pc is locked and screen goes black, Teamviewer seems to go offline after a short period of time, and I am not able to access it by Teamviewer client. In the Teamviewer clients it is shown as offline.

Other Windows services like e.g. Plex server are still alive and accessible by other clients. 

Any idea on how I keep Teamviewer online?

Thanx in advance.

«1

Comments

  • no6mis
    no6mis Posts: 2

    I have the same problem on a surface book running win 10. The energy settings are correct and standby is set to 'never'. This worked before for several months and stopped working a few days ago.

  • Mine stopped working a few days ago too.

  • Miziobt
    Miziobt Posts: 3

    hi, some problem in a Tablet with windows 10. all ok until 3 days ago. then when the screen off the teamviewer go offline.

  • me, too !!!!!!  how to fix this problem?
  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi all,

    I've noticed this happening on my own Surface Pro 3 as well. Specifically, when I lock the device, the screen will turn off after about 40-60 seconds, and the device will go offline on my TeamViewer Computers & Contacts list.

    (The fact that TeamViewer goes offline is expected behaviour. When the Surface's display turns off, it enters Modern Standby mode, which is a new and more advanced sleep state. As a result, programs like TeamViewer are not able to stay connected. You can learn more about the Windows 10 Modern Standby feature in this video from Microsoft.)

    So the issue here is why the screen is turning off after the Surface is locked. According to my research, this is caused by a setting in Windows 10 which is hidden by default, but which you can unhide and change with a simple edit to the Windows Registry.

    Rather than repeat the instructions, I'll point you to the article that contains the solution, and give credit where credit's due:
    https://www.windowscentral.com/how-extend-lock-screen-timeout-display-turn-windows-10

    In summary, if you carefully follow the instructions there (and bearing in mind that editing the Registry is risky business), you'll end up with a new Display setting called Console lock display off timeout, which is located in the Advanced Power Settings in the Control Panel. This previously-hidden setting causes Windows to turn off the display (by default) 60 seconds after it's locked, and on a Surface tablet this means it enters Modern Standby mode.

    Now that this setting is no longer hidden, you can change it to something longer, or else set it to 0 which disables it completely. If you set it to 0, then the Surface's display will turn off after the amount of time specified in the Turn off the display setting in the Control Panel's Power Options - usually this is 10 minutes.

    As to why this seems to have changed within the past few days - my guess is that a recent update from Microsoft may have changed this behaviour on these devices.

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • no6mis
    no6mis Posts: 2

     

    @Jeremy wrote:
    [...] 
    So the issue here is why the screen is turning off after the Surface is locked. According to my research, this is caused by a setting in Windows 10 which is hidden by default, but which you can unhide and change with a simple edit to the Windows Registry.

    Rather than repeat the instructions, I'll point you to the article that contains the solution, and give credit where credit's due:
    https://www.windowscentral.com/how-extend-lock-screen-timeout-display-turn-windows-10

     

    [...]

    Hi Jeremy,

    thank you for your response. But I don't think that this is causing the issue as I usually close the lid of my surface book, which switches off the display aswell. This was never a problem and teamviewer stayed connected the whole day. 

    Kind regards,

    Simon


  • @no6mis wrote:

     

    @Jeremy wrote:
    [...] 
    So the issue here is why the screen is turning off after the Surface is locked. According to my research, this is caused by a setting in Windows 10 which is hidden by default, but which you can unhide and change with a simple edit to the Windows Registry.

    Rather than repeat the instructions, I'll point you to the article that contains the solution, and give credit where credit's due:
    https://www.windowscentral.com/how-extend-lock-screen-timeout-display-turn-windows-10

     

    [...]

    Hi Jeremy,

    thank you for your response. But I don't think that this is causing the issue as I usually close the lid of my surface book, which switches off the display aswell. This was never a problem and teamviewer stayed connected the whole day. 

    Kind regards,

    Simon



    Maybe this a solution, but I also doubt that this is the whole story, since this was never an issue earlier. This behavior just suddently started some days ago. '

    Also it would be nice to have screen go black to save energy. 

    Furthermore...I have services installed that I CAN access. So why is this only an issue for Teamviewer service?

  • after i tried, that's not work for me.

    i edit the reg setting, and change the console timeout=999999. but when power save time =1miute, display turn off. teamviewer offline.

     

  • I think teamviewer should fix this problem.

    because i use win10 tablet pc, i want to save power, so set display turn off after 1 minute, system keep alive always, network keep alive always.
    1. I write a program run in background, wait for remote command through network.
    2. I install teamviewer for remote control.

    when the display turn off after 1 minute, teamviewer go offline, but my program keep alive online, i can communicate with it. If i send mouse_event move message, the display will turn on, and teamviewer back online.

    so i think, though this is a feature to save power. but teamviewer as a remote controller and tool, as i configure keep network, the teamviewer should keep online, if teamviewer's remote display need display turn on, use some tricks to do so.

    If teamviewer go offline while my program still online, i think this is a problem, not a feature.

    otherwise, after i install the teamviewer's display driver, i can not change the display light level by power setting. may be this is also a issuie.
    WIN 10.0.14393.726 x64
    TEAMVIEWER 12.0.81460
    Interl Atom X5-Z8350

  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi all,

    I've spent a bit more time digging deeper into this.

    There is no doubt in my mind that when TeamViewer on the Surface Pro is going offline, it is because the Surface is entering Modern Standby mode. This is evident from the TeamViewer log files I've seen from Surface devices, including the Surface Pro 3 I'm using.

    You can also search within your own log files for the phrase Service::CheckModernStandbyChange and you should see entries that say either "entering modern standby" or "leaving modern standby", and these entries should correspond with the times that TeamViewer goes offline or online.

    You should also find that these times correspond to the settings you have on the device for either the "Turn off the display" value, or else the hidden "Console lock display off" value which I discussed in my previous post above.

    For example, if your "Turn off the display" setting is set to 10 minutes, and you stop using your Surface at 15:10, you will probably notice that the display turns off, and TeamViewer goes offline, at around 15:20, and you'll see a corresponding entry in your log file at 15:20 which says "Service::CheckModernStandbyChange: entering modern standby".

    Please understand that Modern Standby is a Microsoft feature which TeamViewer has no control over. This feature puts the entire device into a special sleep mode. Microsoft have an informative video here which explains how it works: https://channel9.msdn.com/Shows/Mechanics/Understanding-Surface-Power-Management-with-Modern-Standby-in-Windows-10

    As to the question of why some programs are able to remain running when a device is in Modern Standby and other programs - like TeamViewer - are not, the answer is that only Windows Store apps (the ones from https://www.microsoft.com/store/apps) are allowed to remain running and online during Modern Standby - and even then, only those Store apps with specific support built in for Modern Standby.

    For example, the Skype app remains online during Modern Standby, and some streaming music apps like Spotify can also remain online and playing music, because they have specific support built in for this. But regular desktop programs like TeamViewer - and also the desktop versions of Skype and Spotify - are not able (not allowed) to stay online during Modern Standby, because of the way Microsoft has designed Modern Standby to work. Sadly this is a Microsoft restriction (or "feature") that we have no control over, and it's therefore not a problem that we are able to fix. :(

    I installed the Plex server on my Surface to test this, and installed the Plex client on my PC. When my Surface entered Modern Standby (and TeamViewer went offline), the Plex client showed that the Plex server on the Surface was offline and not reachable (although I had to refresh the Plex client's page to make it show this). When I woke up the Surface, the Plex server became available again.

    @skyyearxp you wrote that you changed the setting for the lockscreen timeout to 999999 minutes, but you still have your "display off" setting set to 1 minute. Therefore your device will turn off its display after 1 minute of non-usage, and this will make your device enter Modern Standby mode.

    The remaining question is what changed in the past few days to make your devices start using Modern Standby. I don't know the answer, but I can only assume that it was caused by a patch or firmware update from Microsoft. As I've explained, TeamViewer doesn't cause or enable Modern Standby. It simply behaves according to the restrictions that Modern Standby imposes on it, by going offline.

    Probably the best solution is to set both the "Turn off display" value and the "Console lock display off" value to something very high. Then you can manually put your device to sleep using the device's physical power button.

    I hope this is helpful and informative!

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Update: I'm also going to pass on the details from this conversation to our developers to take a look at. Although it's certain that TeamViewer should go offline when Modern Standby is active, I want to make sure that TeamViewer only goes offline at that point, and to check that there aren't any other factors at play here.

    I'm grateful for the input you've all given on this topic!

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • I also have Plex server, Sonarr, Radarr and Sabnzb running on my Surface and they are always accessible when screen goes off. Always, except Teamwiewer.
  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Thanks @Cronqvist. I'm going to do some more research into this. I'll keep you posted.

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • my program node.exe is just build by vs2015 .net 4, connect to redis.

    when display turn off, i still could publish or receive msg with node.exe through redis. it's just a exe, .net, start from double click. not as a service.

    i don't want to always turn display on, i want to save power and protect the screen not work all day. so i want display turn off 1min, and system work no sleep.

    please do more research, thanks a lot.

     

  • Miziobt
    Miziobt Posts: 3
    Ok, but at today there are not a solution?? Can i do to use teamviewer with windows 10 modern suspend mode on a tablet?? Always on the screen?? Uninstall the windows upgrade patch?? Can you resume, please?? Thanks.
  • Miziobt
    Miziobt Posts: 3

    Hello friends, Yesterday I worked and told you how I resolved, waiting for a teamviewer patch:

    - I set Never to standby and turn off monitor;

    - I activated the dear old screen sever (set "black screen") at 4 minutes.

    Now Teamviewer remains online and the screen seem "turned off."

    bye...

  • Hi Jeremy

    Do you know if there as been any new finding on this issue ?

     

     

  • Ax
    Ax Posts: 1

    I have the same problem since a while on a Dell XPS 13, it's super annoying since I used to leave that laptop on to connect to it later from other locations, and now thats impossible. It's also true, that other services on the same laptop are accessible at the same time from remote!!

  • Hi, same over here. I have this problem since Microsoft rolled out the 1703 "creators update". It is no option for me, to leave the screen of my Surface 4 Pro on all the time or to keep it unlocked in some other way. Teamviewer worked flawlessly before that update and now after 5 Minutes it is going offline even though every single energy saving option of the SurfaceDock ethernet adapter is turned off and all windows energy saving options are optimized (it had worked before after all). This too made me suspect the "Modern Sleep"-feature. After the post(s) from Jeremy I experimented with that and I think he is right. But what I don't get is why there is no workaround for this. For me personally Teamviewer is the best (free) solution to help my family with their everyday computer problems right when they are facing them. - So don't get me wrong: I am very (!!!) thankful to you guys for making such a powerful software free to use for personal stuff. However other (free) remote control services do not have the same problem. I installed another remote controll service. I am not sure if I may state the name here and to me it is not important because I do not want to advertise it here (and I want to keep using Teamviewer). The interessting thing about that is: Both services (Teamviewer and the other product) run simultaneously on my Windows 10 driven Surface tablet. And while the Teamviewer goes offline when my tablet shuts down the screen and locks, the other service keeps running and stays online. I am testing it since yesterday from my office. So is there really no way to patch this?

  • xy
    xy Posts: 1

    This is the answer that fixed it for me!  Finaly my pc stays awake all the time and Teamview is always availible.  I'm using a Surface Book with windows 10 creator. 

    Please try the following registry key to disable the Modern Standby feature.
    HKLM\System\CurrentControlSet\Control\Power\CsEnabled (1->0)
  • @xy wrote:

    This is the answer that fixed it for me!  Finaly my pc stays awake all the time and Teamview is always availible.  I'm using a Surface Book with windows 10 creator. 

    Please try the following registry key to disable the Modern Standby feature.
    HKLM\System\CurrentControlSet\Control\Power\CsEnabled (1->0)

    Great stuff!! That's sorted it for me too!  Thank you! :smileyhappy:

  • I just wonder why this is necessary at all, when other services are working just fine witout this hack!?


    @Vodaholic wrote:
    @xy wrote:

    This is the answer that fixed it for me!  Finaly my pc stays awake all the time and Teamview is always availible.  I'm using a Surface Book with windows 10 creator. 

    Please try the following registry key to disable the Modern Standby feature.
    HKLM\System\CurrentControlSet\Control\Power\CsEnabled (1->0)

    Great stuff!! That's sorted it for me too!  Thank you! :smileyhappy:


     

  • I agree we need to get an answer and a fix for this ASAP. TeamViewer, we pay a lot in license fee and now it's unusable and things like Plex works and that is FREE.

    Silence is not an option here be transparent or we will stop using your service.

  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi all,

    Please rest assured that we haven't forgotten about this issue - we are still invesetigating it and looking at how to make TeamViewer's detection of modern standby more accurate.

    I'm sorry for the inconvenience this is causing you in the meantime.

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi all,

    We've made some improvements to the latest insider build of TeamViewer 12, with regards to how it detects the Modern Standby sleep mode on devices which use it, such as Microsoft Surface devices. We may make some further adjustments in the future, but so far it's working more accurately than before.

    To give it a try, open TeamViewer on the Surface device and go into the options, and on the Advanced page you'll find "Receive insider builds" at the top. After enabling this and clicking OK, you should be prompted to download a new version (otherwise click Help > Check for new version). The current insider build is 12.0.85060.

    Tip: you'll also find the layout is a little different!

    Regards,
    Jeremy
    TeamViewer Quality Assurance Engineer
  • Unfortunaty, even after installing the 85060 build, I still can't see my surface on my iphone. As soon as the surface goes in sleep mode, it is not accessible anymore

  • GGetty
    GGetty Posts: 3

    Thanks I'm running a Surface Studio and this insider build seems to have fixed it for me.

  • Will this fix be included in 13 beta or is everything fixed there anyway? We are in the process of deciding if we should upgrade our licence or not... My boss want me too look at other solutions but i kind of like TV and it's well known..

  • Ntegra
    Ntegra Posts: 1

    I am also having this issue with my Surface Pro 4 and I believe Teamviewer is possibly doing something it shouldn't be upon disconnection.

    Somehow one of my machines upgraded itself to 13. I was then forced to upgrade all in order to connect to/from the first machine that upgraded. So hopefully the "fix" isn't isolated only to some version 12 "insider build".

    30 seconds after closing a remote session to my SP4, Teamviewer goes OFFLINE. The only way to stop it is to uncheck "turn off display" (while plugged in). It does not matter what the timeout is set to. It always goes OFFLINE within 30 seconds of disconnect. I've tried the various registry edits, none work.

    All other network functions to the SP4 are alive. I can PING, I can open a remote CMD prompt, I can remote regedit, etc.

    Two ways to bring the machine back ONLINE. 1. open remote cmd prompt and restart teamviewer service. 2. RDP into SurfacePro.

    Why do I feel this is a Teamviewer issue? BECAUSE when I close my RDP session from my SP4, Teamviewer never goes OFFLINE. Only when disconnecting a TV session.

    UPDATE: So, as I was hitting "POST", my TV client crashed. Once I reopened it, disconnecting from my SP4 no longer goes OFFLINE. I guess the client was sending a "go offline" signal?

  • drluc
    drluc Posts: 1

    @Jeremy

    I am having the same exact problem using  the latest version of TeamViewer 12 on Surface Book 2.

    I tried your "insider build" suggestion, but when I try to update it only allows some version 13 insider build, while I must use version 12 due to my company license.

    Where can I download the latest version 12 insider build manually or how can I force it to update to the latest v12 insider build or how can I get it fixed on the current latest release of version 12?

    Thanks