"Partner started the internet call. Do you want to unmute your microphone?" dialog box.



  • Yazzoo7
    Yazzoo7 Posts: 2 ✭✭

    Lighten people. I am betting the majority of you are using the FREE version and this program is extremely robust for FREE. Is having to execute ONE keystroke to get rid of the "extremely annoying" box really that cumbersome?  Geez. 

  • The issue is it appears to be a security hole, or may mess up audio on one end or the other.  It also is something that should be a preference setting, yet there's no checkbox to disable it.

    But my own take on it is it looks like a security hole more than an issue that you have an extra button to click.

  • Seems to be fixed now in the new version

  • Chima
    Chima Posts: 5

    Yazzoo7 is right. No freeloader complaining about this has a leg to stand on. You get what you pay for! — that is as true today as it's ever been. Licensed users, on the other hand, who constitute TeamViewer's breadbasket — at no small expense, I might add — shouldn't have to put up with this unforced error. A single click/keystroke may not seem like much, but it adds up very quickly if you have to do that 10, 20, 50, 100 times a day. I doubt very much that the chorus of loud calls for urgent course correction is coming from freeloaders who typically use the product a handful of times a year.

    Perhaps it is time for TeamViewer to consider unbundling the free and licensed editions. It may well be the only effective way to avoid cross-pollination of muddled experimentation with sloppy coding.

    And believe me, I use those words advisedly.

    To date, I still can't put my finger on a specific problem that the beleaguered rollout which unleashed all the fury was attempting to solve. I don't recall anyone complaining that the preceding stable release did not provide for unmuting the microphone on a nonexistent internet call.

    While I do not purport to be schooled in TeamViewer's development protocol, what is clear is that implementation of the code segment responsible for this debacle was not well thought out, which might explain the difficulty in coming up with a patch to quickly fix the problem. Given the ease with which scores of users are able to reproduce the problem, it does not appear that the update received even the most basic pre-release in-house testing, either. Not even the Agile development framework was intended for blind code commitment without human oversight.

    Finally, there is something called 'beta-testing' in programming circles. There's a reason for it, and it’s often a necessity, not a luxury. Even Microsoft — the 6,000-pound gorilla on virtually every desk — engages in fairly extensive pre-release beta-rollout of most software updates of functional significance. If TeamViewer has ever posted a pre-release beta-rollout notice, I’m not aware of it. I think we’d all agree that the age of father-knows-best is over.

  • beast-usa
    beast-usa Posts: 80 ✭✭

    Xubuntu/Ubuntu 16.04.2
    My System
    Cooling - Water cooled, Raystorm Waterblock, 270 GPH Pond Pump, 5 Gallon Reservoir.
    Motherboard - Asus Rampage v Extreme (Bios 3101)
    CPU - Intel i7-6950X Extreme Edition @ 4000MHZ
    Memory - 32 gigs Crucial Ballistix Tractical DDR4-3000 15-15-15-33 CR2
    Video Card - EVGA GTX 1080 SC Stock Clock & Cooling.
    Hard Drives - Windows OS's Crucial M550's Raid-0, Xubuntu Seagate SATA III 1tb 64meg cache.
    Storage Drives - 2 Western Digital 5TB 128meg cache, 2 Seagate 2TB 64meg cache.
    Power Supply - Corsair 1050 watt SINGLE RAIL
    OS's Xubuntu x64 (Ubuntu 16.04.2) and Windows 10 Pro x64 (RS2).
    VM (all on one of the 5TB WD drives) Fedora, Mint, Redhat, Centos, OSX, Win xp, Win 7, Win 8, Win 8.1, Win 10 home.

    It's not the version of Linux or the version of TeamViewer in Linux. I rolled back my TV in Linux to the 11's and it still had the error. Which would be the easy fix since I do 98% of my work on Linux. What does fix the error is un-installing Teamviewer on the Windows computers and reinstalling version 12.1.11706.0 or earlier. Then the error is gone and everything works, I see no difference or benefits in the newer version just the unmute mic error. The Windows computers I work on range from XP to Win 10 and all have the error.

    I don't know anyone that would complain using the free version. And if you use it daily on a mass scale TeamViewer won't let you use the free version. (FREE is non-commercial use) It may not seem like much to people that use it even 10, 20 30 times a month. But when you use it 10, 20, 30 up to 100 times per day it drives you crazy!

    Well rolling all the computers back to version 12.1.11706.0 or earlier fixes the problem. But so far has been a real pain in the behind. Trying to explain to my customers why they need to uninstall one and install the other is just not working well at all. I even put the working version on the desktop, start the uninstall... :( So it's a phone call and walking them through it one at a time. :(

    TeamViewer people please just update - back to a working version "12.1.11706.0" :)

  • ZS1
    ZS1 Posts: 1

    I just updated the TV on a PC yesterday and have started getting this pop up since.  The version is 12.081460. I also checked for update today and it says this is the latest version.

    Please confirm what was the versionin which this was fixed.

  • beast-usa
    beast-usa Posts: 80 ✭✭

    @ Photon
    No it's not fixed after god only knows how long! If you don't want to see the error roll back to a version that works. :) Version 12.1.11706.0 or earlier won't give you the error and you can't just install the working one on top. :( You must un-install the new broken one and re-install the working one to get rid of the unmute mic. Photon you can also just switch to DWS works well 100% free browser based. But it is free so there are limits on uploads and speed. :( But just to do work and no file transfer it works great and NO DUMB MIC error. https://www.dwservice.net

    @teamviewer-user staff
    PLEASE STOP MAKING EVERYONE VERIFY THE SAME BROWSER OVER & OVER & OVER AGAIN!!! Change to IP's PLEASE! So annoying what you must go through just to make a post or is that the point?

    And really how hard can it be to fix this it's been MONTHS? You already know version 12.1.11706.0 WORKS so use that to make a good WORKING COPY!

  • beast-usa
    beast-usa Posts: 80 ✭✭

    LOL It's listed as FIXED on page one but it is NOT!

    So I guess that means it will never be fixed?

  • beast-usa
    beast-usa Posts: 80 ✭✭

    Well another update for windows today and STILL NOT FIXED. :(

    LINUX to Windows UNMUTE - MIC!!!
    Rolling back my test system to the working version AGAIN!

    Take this off of fixed!

  • Not working in 12.0.82216

    I am still getting the unmute microphone prompt.

  • beast-usa
    beast-usa Posts: 80 ✭✭


    It's not fixed :( but they have it listed as FIXED on the first post so I guess it will NEVER get fixed. It's been BROKEN since May and to this date it is STILL BROKEN Linux to Winblows.

    You can roll back to a working version but it is a pain. :( You need to un-install the broken version, (keep settings) install FILE version 12.1.11706.0  or earlier and you won't see the annoying UNMUTE MIC! And be sure to DISABLE automatic updates.

    Or just switch to DWS I have about half my computers switched a lot less bells & whistles but no errors! Switching four more right now GRRRR I drove out rolled them all back to a working version. Then someone hit UPDATE when it kept telling them "There is a new version" I told everyone DO NOT UPDATE TV!!! So I will just install DWS and be done with the stupid UNMUTE MIC! Until someday when TeamViewer decides to ever FIX IT! 

  • beast-usa
    beast-usa Posts: 80 ✭✭

    New version today!!! YEP STILL BROKEN! At this point it's just a dam joke!
    I mean really guys HOW HARD CAN THIS BE TO FIX???






  • beast-usa
    beast-usa Posts: 80 ✭✭

    In case you need help THIS VERSION WORKS. If you can't seem to get it right at least let the newer NOT working version be over-written by an older version. Then I could just roll back to the working version remotely.


  • beast-usa
    beast-usa Posts: 80 ✭✭

    Easy fix for those trying to roll back remotely. :) Install DWS login (ERROR free), uninstall the broken version (KEEP THE SETTINGS), reinstall the version that works, DISABLE automatic updates! Boom easiest way or just switch to DWS. For uploading or downloading files TV but DWS is free. 

  • When someone releases the exploit that takes advantage of this bug (if they haven't already) TV will take notice of it.  Really don't understand this; there's a code change that implemented this bug, a change that could go back to a particular build.  Remove that code.  Patch the rest.  The longer they wait, the harder to re-implement subsequent code changes.

    As I say, it's a matter of when, not if this vulnerability will get exploited.

  • It is something that will not get fixed because they simply do not care. It is the same with requiring browser and computer verification over and over for the same machine and browser used from day 1.

  • beast-usa
    beast-usa Posts: 80 ✭✭

    Are you ever going to REMOVE fixed because it is STILL broken! This is by far the most costly software I have ever purchased. And it's been broken for almost 7 months! This is just stupid!

    I will just start phasing TeamViewer out for DWS since it looks like it will never get fixed! 

  • Jeremy
    Jeremy Posts: 106 Staff member 🤠

    Hi all,

    Please rest assured that we are very much aware of this issue and are still working to resolve it. It has not been forgotten. We certainly appreciate the annoyance it causes, and we apologise for the inconvenience.

    TeamViewer Quality Assurance Engineer
  • beast-usa
    beast-usa Posts: 80 ✭✭


    Thanks for the heads up and thanks to all the staff for removing "Solved" on this thread.

    It would be great if you guys could make it so we could remotely roll back any newer version to a older one? That way if there is ever a problem like this one it is easily fixed/patched/ until a permanent solution is found. Right now the only solution is un-install & reinstall which I have been doing. :smileysad: 

    And if Auto-update is turned off & set to NEVER check for updates - TURN OFF the update notifications so people will stop updating to the broken version.

  • It would be great if you guys could make it so we could remotely roll back any newer version to a older one? That way if there is ever a problem like this one it is easily fixed/patched/ until a permanent solution is found.

    And if Auto-update is turned off & set to NEVER check for updates - TURN OFF the update notifications so people will stop updating to the broken version.

    Unfortunately the second would require them to re-issue/recompile the last non-broken version to add that feature in.  Certainly a good suggestion for future builds for the next time some long-term defect becomes a problem.  (I know I'd like to see Android take on a "don't prompt to update blocked updates" function, but I don't think Google is competent enough to implement it).

    Ultimately it seems a lot could be fixed by fixing/updating the Linux client, but it seems TV no longer has anyone working on the Linux client.

  • beast-usa
    beast-usa Posts: 80 ✭✭


    I just upgraded my Windows test machine to the newest version (which causes the error) upgraded my Linux and checked it. NO MORE MIC MESSAGE! This one is working in Linux!
    I have been looking at that error so long I gave on hoping for a fix.


  • It's really annoying. This did not use to happen in the past. I can see many people have the same issue here. Could someone from the teamviewer devs give us a bit of help with it?

    My regards,


  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @saivajr, just install the update, as suggested 3 posts above.

    Linux Developer
  • Tauro
    Tauro Posts: 2

    Updated and issue resolved thank you.

    Bit annoyed though it states upgrading to version 13 I will need a new license?  I paid my annual subscription back in July so that is suppose to give me access to all new builds I thought!


  • Yes indeed. I had to read through the whole discussion to find the solution in the last post. I was quick to comment. Thanks.

  • Esther
    Esther Posts: 4,057 Former Community Manager

    Hi @Tauro

    with a running subscription license you can use the current version without the need to pay an extra fee.

    With a perpetual license, you can update your exisiting license to the new version to work with TeamViewer 13.

    I hope this info helps you.

    All the best, Esther

    Former Community Manager

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    Dear @Tauro,

    I assume you are talking about the Windows version?
    Actually, it doesn't matter: You don't have to install TeamViewer 13 beta, you can install the latest TeamViewer 12 for Windows or Linux. The issue is fixed in each.

    In case you are trying to connect to TV13 machines: Yes, in that case you would need a new license and install TV13 on your side, too.

    Linux Developer
  • Gregg
    Gregg Posts: 2 ✭✭

    Well it "might" be a solution if I was running Linux on either end.

    But I am not, so this is a rather poor excuse for a "solution"

    Maybe you should just call it "Viewer"??, because it sure appears there is no "team"-work going on here. Very poor for commercial software. Most of the people using this software are techs, involved with solving clients problems. What the heck do you do when the makers of the tech software cannot solve a simple problem??

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    @Gregg, can you please clarify which exact version you use on each side and what the remaining issue is?

    Linux Developer