ctrl key not working on remote computer

I have team viewer set up with Linux Mint on the viewer computer and raspbian linux on the remote (server) computer.   I can use ctrl key combinations on the viewer computer but it won't register on the remote computer.  If I connect directly to it (with keyboard and monitor) then I can use ctrl key.  I've tried the obvious ctrl+shift and that doesn't work.  It makes teamviewer of limited use in controlling the headless pi.

Grateful for any suggestions / fixes.



  • mhb
    mhb Posts: 8

    Further to this, It does look likea linux issue as ctrl works when accessing the remote computer from a Windows 10 machine.  As I far prefer linux I do hope you'll sort this bug out (and the lack of file transfer on linux too) soon.

  • fedir
    fedir Posts: 1

    +1, same situation.

  • ianb
    ianb Posts: 2

    Ctrl key not working for me either with the Linux client and a remote Windows host.

    Is this a known problem? Anything we can do?


  • 7i4g0
    7i4g0 Posts: 1

    Did you find any solution?

  • DanielStm
    DanielStm Posts: 224 Staff member 🤠

    I can't reproduce that. Please add details, e.g. local and remote OS. In which cases does it work and in which cases not?

    @JM325, you might want to add your findings here.

    Best regards,

    Linux Developer
  • @DanielStm

    I've just upgraded to TV13 and joined the community to get support on this issue.

    My local system is Kubuntu Linux 14.04, tv13.1.3026 and the remote is Windows 10, tv 13.1.1548 (updated today). Both are 64 bit.

    The Alt key gets passed through, the Shift key gets passed through, and the windows key gets passed through, but not the Ctrl - it's as it's not pressed - if you try ctrl-c copy or ctrl-s save or anything like that you just get the letter. This worked fine in v12 (and v10).

    I assume this is supposed to work? It's unusable without it.

    The new Linux client doesn't have any options for "send key combinations" like the old one did.

  • ianb
    ianb Posts: 2

    Hello again

    I've investigated further with my Linux (Mint) client and remote Windows host.
    The control key isn't completely dead - mouse clicks with control key seem to work.

    But Ctrl-C Ctrl-V in wordpad/notepad don't work - they react as if just "c" or "v" are entered alone.

    I tried logging key events with a little Tcl/Tk script.
    Pressing and releasing the control key on my Linux client logs this (event-keycode-keysym):


    On a remote Windows machine via TV-12 (local) and TV-11 (remote):


    On the remote Windows machine via TV-13 (local) and TV-11 (remote):


    I tried with a TV-13 remote Windows too - same result.

    The state of the numlock key makes no difference.

    Maybe this helps?

    Best regards,

  • I'm using KDE rather than Gnome, and I don't have that effect active ... and I don't see anywhere to turn it on or off.  But it's an interesting point.

    I've had to uninstall tv13 temporarily so I can't test the ctrl-click or the keyboard events but will do when I can...

  • mozo
    mozo Posts: 28 ✭✭

    My problem is a little different. Ctrl hotkeys doesn't work for me. If I use Ctrl+C, Ctrl+V, Ctrl+Z etc. it begins spaming the related letter C, V, Z etc. infinitely until I press Esc. This problem is present since the first native version 'till now. I use only Linux without Windows. Host and guest are Linux machines. I don't have a middle click also. Here you are a video: 

  • sdunlap1
    sdunlap1 Posts: 1
    edited May 19



    For me (Ubuntu 17.10), the fix was to turn off the "show mouse pointer location when Ctrl key pressed."

    I had to use dconf-editor to locate that setting, as Ubuntu no longer includes it on the regular settings dialog panel.

    (in dconf-editor: org/gnome/settings-daemon/peripherals/mouse)

    This drove me **bleep** crazy. This solultion worked for me.


  • mozo
    mozo Posts: 28 ✭✭

    This doesn't work for me either no matter if "Show remore cursor" is selected or not. It continue to spam the corespond letter as I show in the video in my previous post.

  • I'm connect from Linux/Windows (13.x) to Linux (12.x), and sometimes host start to type the Ctrl+ letter continuosly. That occurs if I do the shortcut very quickly. If I retain Crtl key pressed 1-2 seconds and then the letter, dosen't occur that. The same is applicable to Ctrl+Shift


  • exactt
    exactt Posts: 22


    I am on Ubuntu 17.10 (Xorg) and have quite the opposite effect. For me often the Ctrl key hangs. Than if I click something on the remote system (Windows) I get a Ctrl+CLICK.

    It doesn't happen all the time and if close the session window and start a new session the issue is gone. It might come up again after a little while though. I haven't figured out what actually triggers it. Appears sort of random...

    Thought it might be related.


  • tobalur
    tobalur Posts: 1

    Same problem here. Seems it does not matter what OS the host is running, it appears on Ubuntu and Windows  hosts equally when using the Linux client. TV13 all of them...

  • Ubuntu 14.04 LTS, same issue, no ctrl forwarding.

  • emmenlau
    emmenlau Posts: 4 ✭✭

    I'm affected by a similar combination of problems. A fix would be highly appreciated.

    I connect from Linux to Windows or Linux. In both cases, I can randomly not use the CTRL key. Sometimes it works, but most often it instead endlessly hangs the modified key. For example pressing "CTRL+C" would typically end up in an endless list of 'c' printed on the remote. I can end this by pressing escape. Other key combinations just never work. For example "CTRL+." always is received as a single '.' on the remote.

    This worked fine in Teamviewer 12 but broke in Teamviewer 13. Please keep up the good work and fix the Linux issues. Thanks!

  • mozo
    mozo Posts: 28 ✭✭

    This is exactly the problem I have from the first native release till now.

  • emmenlau
    emmenlau Posts: 4 ✭✭

    This is quite a big problem for Linux users, because many operations require the CTRL key. I can not use the well-known text editor 'nano', let alone more complex operations like programming. This used to work very well.

    A fix would be highly appreciated. Please keep up the good work!

  • I found that if you put the teamviwer in fullscreen mode, all buttons work well!

  • emmenlau
    emmenlau Posts: 4 ✭✭

    The tip with fullscreen is interesting. But it would be great to have a real solution. I used TV a lot on various machines in the past, but for programmers the lack of special key combinations is a deal breaker :smileysad:

  • Ales
    Ales Posts: 4

    Same here. For me TeamViewer holds the CTRL key. There is nothing to make it stop except closing session and starting a new one. Kubuntu 18.04.1, TV 13.1.8286.

  • si001
    si001 Posts: 1

    For me it fixed when i exit tool "gxneur" - so this not TV problem.

    Client system - Kubuntu 18.4




  • emmenlau
    emmenlau Posts: 4 ✭✭

    @si001 I think your reply is misleading. You say "...so its not aTeamViewer problem" as if the interaction between programs is unrelated to the program itself. But that is not true. I tested a fresh copy of vanilla Ubuntu 18.04.0 and 18.04.1 installed on three completely different computers, and they *all* have the problem present. That means that TeamViewer is currently not fully functional on Ubuntu, at least not on my set of hardware and with my default locale and other system settings.

    Unless it is known what is the cause of the problem, I would really appreciate not to put blame anywhere, neither to nor away from TeamViewer.

  • mozo
    mozo Posts: 28 ✭✭

    si001 it IS TeamViewer problem. I don't use gxneur and I don't use Ubuntu at all but the problem is here all the time.

  • Change this on the client Ubuntu machine

    1. sudo apt-get install dconf-editor

    2. (in dconf-editor: org/gnome/settings-daemon/peripherals/mouse)

    This work for Ubuntu 16.04!

  • I have the problem and my locate-pointer setting was already off.

  • ALso got this Problem. TV13 Ubuntu 18.04

    Disabled mouse pointer on ctrl.

    Reproduce: Connect to an W10 PC. Open putty in there and get nano on. Next press button down to scroll trough the text.

    What happens: Help is opening. If you try to close it via CTRL+x, it just wont work.. You can close it via Windows-on-screen Keyboard but it will open again as soon as you put you finger on that buttndown key...

  • For me, the solution mentioned here few times also worked on Ubuntu 18.04.2

    I have no idea why I had this option ON. 

    @jack1234 wrote:

    Change this on the client Ubuntu machine

    1. sudo apt-get install dconf-editor

    2. (in dconf-editor: org/gnome/settings-daemon/peripherals/mouse)

    This work for Ubuntu 16.04!


  • In my case (TV 14 on ubuntu 16.04 local, TV14 on Win7 remote) Ctrl+Shift+arrows (select cells in ms excel) does not work.

    Solution for me is change language switch in ubuntu to Alt+Shift L (to next language) and Shift+Alt L (to previous language, it was Ctrl+Shift L before)

    P.S. Sorry for my english, its not my first language.