teamviewer.com link icon
or
Ask The Community

TV13 Quit Unexpectedly on OSX

13»

Answers

  • Thankyou for this link.  Considering all the same help requests came through/reported around the same time, I thought TV would have updated their site ASAP, or put an alert out on all X versions of Mac etc...

    So far this updated link has basically solved the problem. It now just doesn't want to be set to "Start TeamViewer with System". But, it's better than nothing.

    Now to update the TV support ticket person...

    This is the partial error report as it crashed on me. I basically got an error loop. It would crash, restart, crash, restart etc... Could only solve if by the removal/disabling of the TV services...

    /Applications/TeamViewer.app/Contents/MacOS/TeamViewer -RunAsAgent YES
    /Applications/TeamViewer.app/Contents/Helpers/TeamViewer_Desktop -RunAsAgent YES -Module Full
    /Applications/TeamViewer.app/Contents/MacOS/TeamViewer_Service -Module Full
    /Library/PrivilegedHelperTools/com.teamviewer.Helper

    Process:               TeamViewer [7065]
    Path:                  /Applications/TeamViewer.app/Contents/MacOS/TeamViewer
    Identifier:            com.teamviewer.TeamViewer
    Version:               13.1.2559 (1)
    Code Type:             X86-64 (Native)
    Parent Process:        ??? [1]
    Responsible:           TeamViewer [7065]
    User ID:               501
     
    Date/Time:             2018-03-19 22:08:35.724 +1000
    OS Version:            Mac OS X 10.13.3 (17D102)
  • Esther
    Esther Posts: 3,337 Community Manager

    Hi all,

    the version which is available on our website (v13.1.2559) does now include a fix for the crash you might have experienced earlier when installing TeamViewer on Mac OS.

    This version will have to be downloaded from the webite and cannot retrieved via the update function in the TeamViewer application.

    We will keep you updated as soos as the update will be available via the software itself again.

    Thanks, Esther

    Community Manager
  • H20JNKY
    H20JNKY Posts: 2

    Was having the same **bleep** problem! Not sure why TM isnt posting a link for Temaviewer 13.0.6447 for Mac?

    However, I googled it as you suggested and works like a charm with Mac OS 10.13.3. Thank you!

  • mscheurer
    mscheurer Posts: 14

    Fixed Version did not work here!

    Same issue, after installing 13.1.2559 - Teamviewer crashes immediately!

    Do we have to clean any settings / directories first?

    MacOS 10.13.3

     

    P.S.: nearly a week without a solution - really bad performance, teamviewer!

  • Esther
    Esther Posts: 3,337 Community Manager

    Hi all - I apologize for the confusion. I just got the information that it is still in the uploading process and that it will take a bit until it is available.

    I will keep you updated as soon as the fixed version is available.

    Once again - I am sorry! Please excuse me being too fast in sending you the GO.

    Best, Esther

     

    Community Manager
  • H20JNKY
    H20JNKY Posts: 2

    I did this first: 

    - Drag and drop the TeamViewer App in the trash and then empty the trash to uninstall TeamViewer

    - Please delete all the plist file of TeamViewer

    You will find this file under:
    Finder | Home directory | Library | Preferences. Here, delete all plist entries of TeamViewer.

    Please also remove all entries starting with "com.TeamViewer" from
    <home>\users\USERNAME\Libary\Preferences\

    Please note that on OS X Lion and later, the library folder is hidden.

    Here is a simple way to unhide the Library folder on the new Mac OSX Lion:
    1) Open a terminal window
    2) Type the following command : chflags nohidden /users/”username”/Library

    After doing this, you should be able to find the folder under the users directory.

    Once all old TM files have been deleted, google Temaviewer 13.0.6447 for Mac. Download and install. 

    Worked like a charm for me and I am running 10.13.3 in a 2011 iMac.

     

  • mscheurer
    mscheurer Posts: 14

    @H20JNKYthanks, but I am still on 13.0.6447 (timemachine backup) and I know how to get a working teamviewer, based on 13.0.6447

  • I was offered an update from inside TeamViewer. Did the update --> crash.

    Then I deleted the App via AppCleaner to include all .plist files. Clean reinstall via homepage of TeamViewer; downloaded Version 13.1.2559. Again, crash.

    So this may be a El Capitan-specific issue.

    After this I followed the link provided in the first post (an external file hoster, all said about trustworthyness) an this time, the old version 13.0.6447 started without complaints.

  • MKM111
    MKM111 Posts: 3

    @MARCELMARCEL: No, it is not an ElCapitan issue (the error occurs also under HighSierra) – it is an 13.1.2559 issue. Download the older version via the link in an earlier post, install and you will be happy.

    It is unbelievable that TeamViewer did not do better tests before releasing the software and it’s a shame they did not remove this bad version from the update servers, as soon as they know about the problems.

     

  • TB10
    TB10 Posts: 4

    Ester,

    Is TeamViewer also working on a fix for Windows XP which (I did not change a thing, the service just crashed last night) is also crashing?

    Do you have a link to the last version that works?   All I can see are links to Version 12. 

    Thank you,

  • Esther
    Esther Posts: 3,337 Community Manager

    @TB10

    You have to enable IPv6 on your Windows XP:

    Installing IPv6 on Windows XP ServicePack3:

    1. Press the keys [Windows] and [R] simultaneously on the keyboard. The Run window opens.
    2. Enter cmd in the Open field and confirm with OK. The command prompt opens.
    3. At the command prompt, type netsh interface ipv6 install and press the Enter key.

    IPv6 is now installed on your computer.

    Thanks, Esther

    Community Manager
  • TB10
    TB10 Posts: 4

    Thank you,

    A little hard to do when  you are not at the computer.  I had to go to another machine which thankfully has not crashed yet, and VNC to my XP machine.

    But it worked eventually. 

    I did not have auto-update enabled on my WinXP machine so someone at TeamViewer had to change something on the server side.  Was any regression testing done at all?

    Do I have do anything on my Windows 7 machine before it also crashes?

  • KenD
    KenD Posts: 3

    Is there anything NEW on this issue and its resolution?

  • mscheurer
    mscheurer Posts: 14

    ... maybe it is a good idea to update the changelog here too:

    https://www.teamviewer.com/de/download/changelog/

    P.S.: it seems 13.1.2991 is working...

  • Julia
    Julia Posts: 292 Staff

    Hi mscheurer,

    Thank you for your feedback. We are of course working on the changelog but the most important part for me was to inform you about the release.

    Cheers,

    Julia
    Senior Support Engineer - 2nd level Support
    Did my reply answer your question? Accept it as a solution to help others.
    Find this helpful? Say thanks by clicking on the Thumbs Up button.
  • tcuffe
    tcuffe Posts: 2

    Have tried the latest version from the home page and although it will install (took a long time 3 mins) it will not run.  Tries to start with the bouncing TV icon and then eventually stops and says that TV is not responding.

     

     

  • Pulicoti
    Pulicoti Posts: 4

    Thank you it works now. :D

    And for the support.

  • PeterZ
    PeterZ Posts: 1

    Hello,

    tried to install the latest version 13.1.4170 from TV website but still no working at all !!!

    after starting it bounces in the dock, then icon appears for 1-2 seconds and bump .. crash

    I had to update because of older version, but I'm very unhappy when paid software is not working and crashing ;-(

    UPDATE: even when downloaded legavy version v12, TV keeps crashing ;-(

  • I am also having the same issue, 13.1.4170 won't run at all. Uninstalled, cleaned the library folder, emptied the trash, rebooted, etc, and it just refuses to run.

    Thanks

    Kevin

     

  • This might have something to do with it:

    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: registerSessionSwitchHandler (NSWorkspaceSession)
    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:13 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:14 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:15 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): Shutdown socket returned error 9: Bad file descriptor
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: InterProcessBase::HandleRetryTimer(): Retrying TCP communication (failed to connect to service)
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: Local TCP connection failed with error 61
    May 15 12:01:16 Orion TeamViewer_Desktop[82664]: CTcpProcessConnector::CloseConnection(): PID=0

  • Here is a more succient transcript of what may be going on with TeamViewer.  Apparently it can't find itself in order to do some IPC?

     

    May 15 12:39:34 Orion TeamViewer[1257]: TeamViewer started as agent
    May 15 12:39:34 Orion TeamViewer[1257]: registerSessionSwitchHandler (NSWorkspaceSession)
    May 15 12:39:34 Orion TeamViewer[1257]: InterProcessBase::SecureNetwork created
    May 15 12:39:34 Orion TeamViewer[1257]: AutoLogin::Login: enabled: 1
    May 15 12:39:34 Orion TeamViewer[1257]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:39:34 Orion TeamViewer[1257]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:39:34 Orion TeamViewer[1257]: Service is running but IPC connection failed
    May 15 12:39:34 Orion TeamViewer[1257]: IPC connection failed. Starting Helper...
    May 15 12:39:34 Orion TeamViewer[1257]: Installed helper version: 13.1.4170; own bundle version: 13.1.4170
    May 15 12:39:34 Orion TeamViewer[1257]: InterProcessBase::StartTcpCommunicationInternal(): setting m_NetworkConnector to new TCP connector
    May 15 12:39:34 Orion TeamViewer[1257]: Opening local TCP connection to 127.0.0.1:5953
    May 15 12:39:34 Orion TeamViewer[1257]: Service is running but IPC connection failed
    May 15 12:39:34 Orion TeamViewer[1257]: IPC connection failed. Unloading GUI for UserId 2010970886

  • VST
    VST Posts: 2

    Hi,

    macOS MOJAVE 10.14.1 (18B75), when I install the app, it will not launch but for a few seconds then crash and quit, without any warning.

    Please help.

Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!