link icon
Ask The Community

TeamViewer is one of the winners of the European Customer Centricity Award 🥳

Please find more information here.

Error "Verification of your Teamviewer version failed!..." on Windows 10

On two different PCs running Windows 10 with Creators Update (64-bit & 32 bit), I have installed TeamViewer v12.0.77242. After a few days the program stops working with the following error: »Verification of your Teamviewer version failed! TeamViewer will quit for security reasons. Please reinstall TeamViewer«. If I reinstall TeamViewer I get the same error.

TeamViwer error.png

Best Regards


  • alucart93
    alucart93 Posts: 1

    I have the exact same problem!

    Got this Error on my Win7 x64 bit desktop pc, since I have a new one with win10, and got the same error today! And I got this Error on my Win7x64 Laptop!
    Everything else does operate normal.
    I have tried to delete with revo uninstaller, cleared the reg and the appdata. With teamviewer QS is get the same message, also with Teamviewer Portable!
    Also installed the zertification of the .exe

    Even tried installin an older version like TeamViewer_Setup_en_8.0.16284. Still nothing.
    I dont want to reinstall my OS only to solve this :/ And I cant tell for surfe if it does not come back.

    Thank you

  • nomad247
    nomad247 Posts: 12 ✭✭

     After tunning the command, is there a  way to know if this works, other than rebooting? I kinda figured it was due to windows creator issues. I Just had to re-install windows due to several issues.

    Thanks for the instruction. Funny how if did not effect teamvuewer operations in any way.

    Janelle Wolves
  • Had same problem and after execution of command:

    regsvr32 c:\windows\SysWOW64\wintrust.dll

    my Teamviwer is working again. Thank you!!!

  • javpac
    javpac Posts: 1
    regsvr32 c:\windows\SysWOW64\wintrust.dll

    Open CMD with administration rights.

    Thats works for me.

    thank you.

  • jennylo19
    jennylo19 Posts: 1

    I ran in powershell as admin but did not work for me.   I have Window 10 Teamviewer V13

  • Thx, very helpful! 

    Also, you need to run CMD as administrator to avoid DllRegisterServer failed with error code 0x80070005 problem.

    Best regards