teamviewer.com link icon
or
Ask The Community

A Comunidade TeamViewer chega ao Brasil 🎉


Check out our brand-new Portuguese Community 👉 here 👈.

Remote session always logs out when session ends

I'm running macOS 10.12.5 on 2 machines and Teamvewer 12.0.78517 on on my client and host. When I connect, I've verified that the Extra menu option to log out the host is NOT checked for either option. None the less, everytime I disconnect, my host logs out. I have the same problem when accessing the host from the iOS app as well... thoughts?

Best Answer

Answers

  • SebRD
    SebRD Posts: 1

    I deleted this folder and restarted my computer. However, everytime I restart my computer, this folder reappears. Any idea why?

    Thank you

  • DHK1
    DHK1 Posts: 15

    What folder did you delete? You were supposed to delete a FILE com.teamviewer.teamviewer.preferences.plist from the ~/library/preferences FOLDER. If you deleted the folder you sadly have given yourself a big problem because all of your OS X preferences have been deleted.

    If you did delete only the file, next time you start Team Viewer it would recreate it, hopefully without it causing the problem again, although now personally I'm not sure that is true. If you did delete the folder, that too might be re-created by programs writing their preferences to it.

  • JohnD
    JohnD Posts: 35

    You don't have to delete that file; if you're comfortable with it, you can also edit it with a plain-text editor like TextEdit or one of the various available macOS text editors and change the setting that controls the behavior.

    As DHK1 mentioned, the file on the host where the setting is located is ~/library/preferences/com.teamviewer.teamviewer.preferences.plist (i.e. in the host's logged-in user's home directory, then in the Library folder, then in the Preferences folder).

    You'll find the setting below in the file set to "1".  Change it to "0", save the file, and reload TeamViewer Host or just reboot and the problem should be resolved.

     

    	<dict>
    <key>PasswordOnSessionEnd</key>
    <integer>0</integer>
    </dict>

     

  • DHK1
    DHK1 Posts: 15

    Actually, I've found the problem remains. I looked and that key wasn't in the plist... added it and set it to 0. Now the key is 0, the menu item is unchecked and it still logs out... sigh.

  • JohnD
    JohnD Posts: 35

    @DHK1 wrote:

    Actually, I've found the problem remains. I looked and that key wasn't in the plist... added it and set it to 0. Now the key is 0, the menu item is unchecked and it still logs out... sigh.


    Yep, same experience here, unfortunately. After a while, the screen locking resumed, even though that key in the preference file remained set to "0".  The GUI is completely disconnected from that setting, and the setting seems to be ignored by the Host anyway.

    FWIW, I was able to confirm that this bug has been submitted to TeamViewer development, and should be fixed in an upcoming version.  Hopefully they will also add the Advanced pref in the Mac client (that the Windows client currently has) that controls this behavior globally from the client side.

  • DHK1
    DHK1 Posts: 15

    @JohnD You said: Hopefully they will also add the Advanced pref in the Mac client (that the Windows client currently has) that controls this behavior globally from the client side.

    My client V12.082953 on macOS 10.13 already has this pref under actions... it just doesn't work...

  • JohnD
    JohnD Posts: 35

    @DHK1 wrote:

    My client V12.082953 on macOS 10.13 already has this pref under actions... it just doesn't work...


    That's a per-host setting. that the client can set when controlling the host.  The Windows client had a global setting in the Advanced section of the app preferences that you can set once and it sets all hosts to not lock.  Hopefully they'll add that to the Mac client soon.

    In the meantime, the beta of TV v13 is out (it's available via the normal update mechanisms for both host and client), and in my testing (so far), if both the host and the client are updated to v13, the per-host setting that you mentioned now seems to work properly.

  • JohnD
    JohnD Posts: 35

    Unfortunately, this bug has been reintroduced in v13.1.4170 (or maybe a close previous version).  Many of my hosts are now constantly reverting to automatically locking the host on disconnect, even when I explicitly uncheck Action > Lock Computer > Lock On Session End.

    This needs to be fixed again.  And they need to explose a Host-side Advanced pref that can disable this useless and obnoxious feature, just like they have on the Windows Host.

  • JohnD
    JohnD Posts: 35

    I've found that in some circumstances, you can't easily edit this plist, at least not in BBEdit, and it's better not to edit it in a text editor anyway, due to potential mistakes.

    Instead, just paste this command into the Terminal and it should do the same thing (remember that you have to quit and relaunch TeamViewer Host or reboot the whole box before it will take effect):

     

    defaults write com.teamviewer.teamviewer.preferences "PasswordOnSessionEnd" -int 0

     

    @JohnD wrote:

    You don't have to delete that file; if you're comfortable with it, you can also edit it with a plain-text editor like TextEdit or one of the various available macOS text editors and change the setting that controls the behavior.

    As DHK1 mentioned, the file on the host where the setting is located is ~/library/preferences/com.teamviewer.teamviewer.preferences.plist (i.e. in the host's logged-in user's home directory, then in the Library folder, then in the Preferences folder).

    You'll find the setting below in the file set to "1".  Change it to "0", save the file, and reload TeamViewer Host or just reboot and the problem should be resolved.

     

    	<dict>
    <key>PasswordOnSessionEnd</key>
    <integer>0</integer>
    </dict>

     


     

  • DHK1
    DHK1 Posts: 15

    @JohnD I actually edited the plist in XCode, and it didn't. work. Then I tried the terminal command and it seemed to work for a day or two, and then stopped... sigh.

  • JohnD
    JohnD Posts: 35
    Yeah, I'm seeing the same thing, where the setting works (either the edit or the Terminal method) and then TV eventually does something that sets it back to locking every time. This is so obnoxious and has been for many years, I can't believe they haven't fixed it yet on the Mac side (the Windows side has a setting that you can set to never do this nonsense).
  • change the setting that controls the behavior. Acresso Software Manager

  • I think there's a simple solution to this. No editing using XCode or Terminal.  Just a simple unchecking of this particular setting and it's pretty much straight-forward.  Check this youtube link about it.

    https://youtu.be/psCXRDawIAg

  • DHK1
    DHK1 Posts: 15
    The excruciating long video was correct in that the actions button held the command to not lock the client computer. The problem is after I tried it several times (and it worked) I noticed that the "X" had a lock on it again, and the "lock at session end" menu item was checked again. I went and unchecked it. We'll see how often this happens.
  • JohnD
    JohnD Posts: 35

    The actions described in the video are not a solution...the problem is that the "solution" is always temporary...at some point the remote system will revet back to trying to lock again at the end of the session.  

    This is an extremely annoying and disruptive bug in the Mac Host that needs to be resolved by TeamViewer developers.  They need to implement the same solution that the Windows team did in the Window Host:  an Advanced Pref that tells the Host to never, ever trigger that "lock on session end" feature.

    Otherwise, we're stuck trying to remember to uncheck that option when it pops up, or annoying lock the host when our session ends.  That's not a solution.

     

  • I with Teamviewer v14 I don't see this code inthat file. When I add it it doesn't work.

  • Alforster
    Alforster Posts: 2 ✭✭
    edited January 31

    I too do not want the host logged out after each Teamviewer session. Has anyone listed to fix this bug for the Mac OS X 10.15 version of this software? there is no "BUTTON" under the Advance Preferences to disable this very annoying "FEATURE"!!

    [the personal information has been removed as per the community guidelines.]