Can't Connect to Any Partner/IDs on Windows Application

quick Posts: 2 ✭✭

I am unable to start a connection to any of my saved partners, or ID numbers on the Windows Application.

I have the latest Teamviewer version 12.0.77242, windows 10 64bit creators update etc...

When I double click on a partner in my saved list of pc's it doesn't do anything, just says "ready to connect" 

Normally it would say connecting.... then authenticating.... etc. 

I tried hitting the connect to partner button after manually putting in the ID, same issue.

Prior to this happening my internet was very slow, had connection issues, and I was trying to connect to a PC and was repeatedly pushing on connect over and over probably 15 times it was sticking on authenticating and connecting.

Once I noticed my internet was messed up, I rebooted my router and internet was working normally now.

However after that it doesn't even try to connect it just shows ready to conect. Rebooted, updated teamviewer to the newest version, logged out, logged in. Nothing will fix this issue.

Has teamviewer possibly put a block on me connecting, cause i had tried too many times earlier?? 

Also should mention I am able to connect to partners just fine using my android app.

Best Answer