link icon
Ask The Community

Do you want to enjoy the new TeamViewer user interface for Windows?

Download the new version and let us know what you think about it! 👉 Please click here 👈

GUI orientation is incorrect (Teamviewer Host App Android)

I have a Portrait signage screen running Android 4.4.4. I want to be able to control from my Win10 PC. So I installed Teamviewer on the PC and the Teamviewer Host App on the Android.

Problem is when I connect and Teamviewer and it shows the preview screen in portrait, which is correct and the GUI in portrait also correct, for some reason the Android GUI has been flipped 90 degrees> as you see in my image. Which means that the bottom of the GUI cannot be seen as it is going ot of the preview on the left. I cannot seem to find a solution. Any ideas? :(

I attached an image of the screen I have + screen grab of my problem in teamviewer.

Portrait screen and Portrait GUI Not correctPortrait screen and Portrait GUI Not correctScreen I haveScreen I haveScreen DetailsScreen Details



  • I found same this problem.
  • On Samsung Tab S5e same problem: mismatch betwen TAB orientation and remote Window orientation. Android version 9.0, Windows 10 and TV 15.

    I 'm not able to match the TAB orientation with the remote window orientation, so the remote connection is unusable

    With my Samsung S10+ everything is OK.

    I tried to disconect reconnect in different orientations, remove the S5e and re-register it. But nothing change.

    Any solution for S5e?

  • How to fix that on S5e  with TV Host for android?How to fix that on S5e with TV Host for android?

  • No way to get right orientationNo way to get right orientation

  • SadSack963
    SadSack963 Posts: 4 ✭✭

    Same problem here on Galaxy Tab S5e.

    I found that the Teamviewer QuickConnect app works correctly though. The problem with using that is that it doesn't start automatically when the tablet is rebooted, whereas Host does.


  • SadSack963
    SadSack963 Posts: 4 ✭✭

    Another "Me Too" post...

    I am connecting to a Samsung Galaxy Tab 5Se SM-T720 which is running TeamViewer Host version 15.2.2 on Android version 9, Kernel 4.9.112-16982790, Build PPR1.180610.011.T720XXS1ASL3, connecting from a Windows 10 client using TeamViewer version 15.2.2756.

    Interestingly, my Linux Teamviewer does not even offer the option to make a connection to either the new Samsung Galaxy Tab S5e SM-T720 or the old Samsung Galaxy SM-T310.

    I have posted a video on YouTube showing many of the symptoms of the graphics fault. The quality isn't brilliant (apologies), but it shows what is going on.

    Video link:

    In further experimentation I eventually found the location of the 3 main buttons as roughly marked on the attached picture.

    WebConnector attempts to connect and then says that the mobile app isn't compatible!

    Samsung is at the top of the list of supported manufacturers, so the manufacturer should be working with TeamViewer to solve these issues.

    To be fair to the app, the Play Store pages do state "This app may not be optimised for your device", but really, what alternative is there? I certainly don't want to use **Third Party Product**!


  • llPac
    llPac Posts: 3 Newbie

    Hey i solved this on Tab S7+

    But it isnt working on Tab A7

    Install a app like Rotation Control Pro (it was for free few months ago). There you can give any app a orientation. So i gave the teamviewer Host App a Non Landscape setting. On my s7+ i just need to open after connecting the keyboard an press 3 times space and voila. It works perfectly in bouth orientations.

    But this 1 doesnt works on the tab a7. Maby Teamviewer @Esther can put out an version of the host app which starts always in Non Landscape. Or with a button in the app.

    So we have a solution for the tab s7 without any external app.

    In case of tab a7 maby samsung needs to do something. I just saw that there is no secure folder.

    I tryed with the app **Information removed as per Community Guidelines**. Its much slower then teamviewer and it only works if somebody turns on the screen (on tab a7. Tab s7 works perfect). You need to use adb for grand 1 right so you can use unattended access.

    I hope this helps some of you, still we get an fix for my favorite app.