Posted by LincolnAEL
Henagon

Batch file not working

Hi, I created a batch file which seemed to worked fine yesterday, but today it isn´t. This is the script msiexec.exe /i "\\server\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=XXXXXXX APITOKEN=XXXXXXX DESKTOPSHORTCUTS=0 IMPORTREGFILE=1 Thanks
1 Accepted Solution

Accepted Solutions
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Batch file not working

Hello LincolnAEL,

No problem, I'm happy to assist!!! The "%computername%" is the variable to grab the computer name of the machine and add it to the computers and contacts in TeamViewer. 

The way I posted the code for you, will achieve what you want, which is to add the machine with their computer name to the contacts list.

Thank you!!!

3 Replies
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: Batch file not working

Hello LincolnAEL,

Please try the example below for your batch script:

REM			INSTALLMSI
start /wait msiexec.exe /i \\XXXXX\XXXXX\XXXXX\TeamViewer_Host.msi /qn customconfigid=xxxxxx apitoken=xxxxxx importregfile=1 desktopshortcuts=0 assignmentoptions="--alias %computername%"

 

Let me know if this works for you or if you have any questions! 

2 Replies
Posted by LincolnAEL
Henagon

Re: Batch file not working

Thank you very much W_deFazio. Just one question. Do I have to add --alias %computername%"? In that case, shall I select the computer name? as I don´t want to set names, just use each computer name.
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Batch file not working

Hello LincolnAEL,

No problem, I'm happy to assist!!! The "%computername%" is the variable to grab the computer name of the machine and add it to the computers and contacts in TeamViewer. 

The way I posted the code for you, will achieve what you want, which is to add the machine with their computer name to the contacts list.

Thank you!!!