Posted by danuk75
Henagon

Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi,

I'm trying to get the assignment options to work on the new deployment improvements method via the MSI.

Below is the command line I've been trying with, this method doesn't seem to run anything at all.

msiexec.exe /i "\\SERVERPATH\f$\TeamViewerMSI-Source\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=CUSTOMCONFIGID APITOKEN=APITOKENNUMBER ASSIGNMENTOPTIONS="--alias "%COMPUTERNAME%" --group "GROUPNAME WITH SPACES" --reassign --grant-easy-access"

If I drop the command line down to the following below I can see the device  connected to the portal but without any assignment settings such as deviceID renamed

msiexec.exe /i "\\SERVERPATH\f$\TeamViewerMSI-Source\TeamViewer_Host.msi" /qn CUSTOMCONFIGID=CUSTOMCONFIGID APITOKEN=APITOKENNUMBER

Has anyone else had trouble getting the assignment settings to work?

7 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi danuk75,

please try it this way:

msiexec /i "TeamViewer_Host.msi" /log "%temp%\TeamViewer_Host.msi.log" /qn CUSTOMCONFIGID=<CUSTOMIZATIONID> APITOKEN=>TOKEN> ASSIGNMENTOPTIONS="--reassign --alias '%COMPUTERNAME%' --group '<GROUP>' --grant-easy-access"
Team Lead Product Development (Enterprise)

Did my reply answer your question? To help others, please accept it as solution. Thanks!
Posted by GCGMSP
Henagon

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

First Issue I see with your script deployment path is that you are using an administrative share (F$) which is not normally available to domain computers and domain users (non-admin).  If you are trying to install this via a network share you need to create a network share that is accessible to both domain users (authenticated) and domain computers with at least "Read & Execute, List Folder Contents, and Read" NTFS permissions and (Read & Write) in Share Access.

Regards,

GCG

Posted by diegonunez
Henagon

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi, What about Teamviewer Full version, how can i mass deploy and assign deployed desktops to a group created in management console?

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi @diegonunez

installing TeamViewer Full version is quite similar to the Host. The major difference is, that you can't use a ConfigurationID in order to customize the Full version.
All you need is:

  1. The TeamViewer_Full.msi installer
  2. an API Token - either create a custom Host to get one easily or create a script token with the following permissions:
    Group management: View groups
    Computers & Contacts: View, add, edit and delete entries
  3. your assignment options - a list of available options can be found here.

So the following example should do it:

msiexec.exe /i "Path\To\TeamViewer_Full.msi" /qn APITOKEN=<YOUR_APITOKEN> ASSIGNMENTOPTIONS="--group <GROUP_NAME>"

 

Regards

Sven

3 Replies
Posted by azelle
Henagon

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi @Sven_F

is there a way to automatically assign a policy to full clients installed that way?

Account assignment with groupmembership works fine, but policies wont get assigned. Until Teamviewer 13 I could set a default policy in the host module, e.g. inherit from group, and install the full client it with the configuration id. This is missing in Teamviewer 14

Regards

Andreas

Posted by TeamViewer Staff
TeamViewer Staff

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Hi @azelle

this is currently a known limitation we will be working on starting next year. There is however a workaround: You can use the TeamViewer WEB API in order to assign policies to devices.
You can download the WEB API documentation here. The API methods from chapter 4.9 "devices" should help you to achieve your goal.

Regards
Sven

Posted by azelle
Henagon

Re: Mass deployment improvements - ASSIGNMENTOPTIONS not working?

Ok, thanks.

I tried and it worked

BR
Andreas