Announcements

The Community is moving next week! 

Find all information incl. the timeline and tips for a smooth migration here.


We will be in read-only mode from this Sunday to Tuesday.

Posted by Community Manager
Community Manager

Sunsetting active support of macOS 10.11 and macOS 10.12

Dear all,

We would like to announce that as of February 11th, 2020, TeamViewer will no longer be actively supporting macOS 10.11 and macOS 10.12 operating systems for upcoming TeamViewer releases.

Stopping the active support of an operating system means that no updates or fixes which are specific to these operating systems will be implemented and TeamViewer versions newer than TeamViewer in version 15.2 won´t be compatible with these operating systems.

What does this mean if you are running macOS 10.11 and macOS 10.12 as an operating system?

  • You can update your macOS to a newer version in case you are not using a device from the following list and continue using TeamViewer with the latest version.
  • You can still use TeamViewer up to version 15.2 if you are using one of the devices below.

We generally recommend to only run current operating systems and software versions. So please make sure to update to the most recent version of macOS and TeamViewer.

To see a full list of our supported operating systems by TeamViewer, please see our Knowledge Base article here: Which operating systems are supported

As Apple provides updates of those operating systems to a newer version, only the following devices* on these systems are affected by the sunsetting. 

  • 20" iMac Early/Mid 2009
  • 24" iMac Early 2009
  • 24" iMac Early 2008
  • 20" iMac Early 2008
  • 24" iMac Mid 2007
  • 20" iMac Mid 2007
  • Mac mini Server Late 2009
  • Mac mini Late 2009
  • Mac mini Early 2009
  • Mac Pro Early 2009
  • Mac Pro Early 2008
  • MacBook 13" Aluminum Late 2008
  • MacBook Air Mid 2009
  • MacBook Air Late 2008
  • MacBook Pro 13" Mid 2009
  • MacBook Pro 15" Mid 2009
  • MacBook Pro 17" Early 2009
  • MacBook Pro 15" Late 2008
  • MacBook Pro 17" Early/Late 2008
  • MacBook Pro 15" Early 2008
  • MacBook Pro 17" Mid/Late 2007
  • MacBook Pro 15" Mid/Late 2007

*As these devices are 10 years old or even older, Apple removed the possibility to update the operating systems of these devices.


For downloads from devices running macOS 10.11 and macOS 10.12, you get the correct TeamViewer version here:

TeamViewer Full version 15.2.2756

TeamViewer Host 15.2.2756

TeamViewer QuickSupport 15.2.2756

TeamViewer QuickJoin 15.2.2756

 

Thanks and all the best,

Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.