Highlighted
Posted by
Henagon

Programs and applications not showing up when connecting to a system that does NOT have a monitor attached.

This is for when you are trying to dial into a remotely located system that does not have a monitor connected or turned on, and some programs are NOT showing up in your Teamviewer connection. This is not an issue with Teamviewer or any other remote connection program. This has to deal with the host system's graphic card. If there is no monitor connected, the GPU essentially decides it doesn't have to actually do anything, so for many programs, it will not render any visuals, although the program itself IS actually running perfectly fine. If you plug a monitor in, your GPU will then render everything and it seems fine to unplug the monitor. However, at that point, your GPU stops doing anything, so minimizing a program will cause the program to go away and 'never return,' leaving you wondering why it's not working though it was working when you checked it and then pull out your hair.  

Here's how to get around it. If you don't want a monitor attached to your host computer, or don't have room (as was may case), get a Dummy Plug. I got one of these. Dummy plugs can come in VGA, mine just happened to need HDMI. Once I plugged this in to the monitor connection on my remote computer, Teamviewer properly displayed every program as it should. 

HDMI dummy plug - $10 from amazonHDMI dummy plug - $10 from amazon

 

Hope this helps. This could have saved me a LOT of time, trouble, and hair.