Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Henagon

Remote control older version 8 from the latest version (15)

I am trying to connect and remote a Windows 10 computer running TEamviewer 8 from my Mac running the latest version 15 of Teamviewer. 

I get the error message "The remote Teamviewer is running an old version ...." 

How do I then remote other peoples computeres? 

I haven't bought the license yet, because I want to check if this works prior to ordering. 

BR Mikkel

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Senior Moderator Senior Moderator
Senior Moderator
Solution

Re: Remote control older version 8 from the latest version (15)

Hello @MikkelG 

Thank you for your message.

Please know that TeamViewer is backwards compatible, meaning that licensed versions can connect to any older version of TeamViewer running.

Last year, we asked all users on the free version to upgrade to the latest version of TeamViewer in order to continue using the services; therefore, it would not be possible to make a connection to the version 8 device (or any running older than the latest version) without a license

If you would like to test this ability prior to purchasing a license, I would recommend reaching out to our licensing team directly. They can discuss your use case, and provide any other clarification or material that you may require prior to purchase.

You can find local numbers here. I hope this helps! 

Josh P.
Senior Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below.

You can also say thanks by clicking on the Thumbs Up button!

Thanks for being an active member of our Community!

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区) |  German Community (Deutschsprachig) | French Community (Communauté française) | English Community | Spanish Community (Comunidad española)

View solution in original post

3 Replies
Highlighted
Posted by Senior Moderator Senior Moderator
Senior Moderator
Solution

Re: Remote control older version 8 from the latest version (15)

Hello @MikkelG 

Thank you for your message.

Please know that TeamViewer is backwards compatible, meaning that licensed versions can connect to any older version of TeamViewer running.

Last year, we asked all users on the free version to upgrade to the latest version of TeamViewer in order to continue using the services; therefore, it would not be possible to make a connection to the version 8 device (or any running older than the latest version) without a license

If you would like to test this ability prior to purchasing a license, I would recommend reaching out to our licensing team directly. They can discuss your use case, and provide any other clarification or material that you may require prior to purchase.

You can find local numbers here. I hope this helps! 

Josh P.
Senior Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below.

You can also say thanks by clicking on the Thumbs Up button!

Thanks for being an active member of our Community!

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区) |  German Community (Deutschsprachig) | French Community (Communauté française) | English Community | Spanish Community (Comunidad española)

View solution in original post

Highlighted
Posted by
Henagon

Re: Remote control older version 8 from the latest version (15)

Hi Josh - thank you for explaining. I would suggest that you add the information about buying the licens to be able to control older versions in the error message. Just idea :) 

1 Reply
Highlighted
Posted by
Proton

Re: Remote control older version 8 from the latest version (15)

Yes, PLEASE add the info about backward compatibility!!! I've spent the whole afternoon trying to help an older person who I have helped before on teamviewer, and not found ANY INFO in your knowledge base.  All your info makes it sound like it works, but won't offer the latest features.   PLEASE ADD THE INFO ABOUT BACKWARDS COMPATIBILITY TO YOUR ERROR MESSAGES!!!!!!!!