Highlighted
Posted by Closed account
Not applicable

Screen cannot be captured / fast user switching / disconnected remote desktop

Hi,

In the last 2 weeks I've started getting the below error when trying to remotley connect to one of my MACS. I get the error trying to connect from iphone, macbooks and windows pcs. I get it if my MAC is on the login screen and I have to put in my password.

I can see if I'm sitting beside the machine that the password is accepted and the machine gets to the desktop but on the controlling machine i just see the screen shot below.

If I am already logged into the MAC when i try connect via team viewer I dont get the error. 

This is rather frustrating as nothing has changed on the setup of the mac thats having a problem. It does have 2 monitors but it's had those for years. TV is updated to latest versions on all devices.

Capture.JPG

9 Replies
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

Dear Vebnara,

Thank you for your post.

To be able to understand your issue we need more information.

What's the module of TeamViewer you're using Full, Host, QS, etc?

What's the TeamViewer version your Mac is using?

You may find it under TeamViewer \ About TeamViewer.

How many users are available on your login screen?

With this information, we'll try to reproduce your issue and provide you a solution.

We are looking forward to your comments.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Highlighted
Posted by
Photon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

Do you have a solution?

Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

Try this out:

Do not connect using the Your ID that shows up in the main UI of the remote box.  Instead, look for a lightbulb to the right of that ID and click it.  Hidden in the description that appears is another string of ID numbers that you should use instead.

Connect this way and It should take you to a login screen where you select your user account and can log in there.

Note you may briefly see something that says "...Fast user switching..." while connecting this way, but it should disappear after 10-20 seconds.

Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

I am only aware of connections through the management console.which takes me directly to my remote computers.  I don't know what you mean by "Do not connect using the Your ID that shows up in the main UI of the remote box.  Instead, look for a lightbulb to the right of that ID and click it.  Hidden in the description that appears is another string of ID numbers that you should use instead".  Can you clarify your suggestion?

2 Replies
Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

I am seeing this every single time now when I use teamviewer. I was previously using version 11 and never once had a problem with this error. Now with teamviewer 14, its every 10 seconds when flipping between screens on the system. How can we DISABLE this completely! Its becoming a pain in the neck. This is for personal use only, to connect to 1 computer remotely that hosts a file server on my local area network.

 

 

Highlighted
Posted by
Electron

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

I have the same problem with two Win10 PCs connected.

Each time the remote computer requires a text entry or user action, the connection is disconnected. This is not helpful if I want to start Admin mode or log in to another user. As soon as the logon page of Windows appears, the connection is disconnected.

I saw the topic in different posts. Is there a solution?

Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

Same problem here, going between TV 14 and 15.  This has made the product unreliable, IMO

Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

I am having the same problem beginning from the last week. I haven't changed anything on either the client or host PC. Is there a solution to the issue?

Highlighted
Posted by
Henagon

Re: Screen cannot be captured / fast user switching / disconnected remote desktop

The only thing I've found that works is editing my registry.  This workaround is assuming you have admin rights to the computer in question.

Go to:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

Find the DWORD value for HideFastUserSwitching and set it from 0 to 1.

My particular computer has a Group Policy that changes this back to 0 every so often, so I've made it a habit to check this in the morning.

 

hfus.JPG