Highlighted
Posted by SkyLukeQc
Tetragon

After solving the "audio ducking" issue, we now have an "audio boosting" issue on macOS

Dear TeamViewer Community,

In a previous topic / thread (see Audio ducking issue (and resolution)), it was acknowledged by TeamViewer's support and development teams that there was indeed an "audio ducking" issue that was introduced in release 12.0.78517 for macOS.

For many of us, the workaround was to downgrade to the previous release of TV (12.0.75813), where the "audio ducking" issue did not exist, while waiting for the official fix.

Recently, TV released version 12.0.80984, which corrected the "audio ducking" issue, but introduced a new one : the sound is now boosted to its maximum level (I'll refer to this as the "audio boosting" issue from now on) when establishing a remote connection or when accessing the TeamViewer for macOS' Audio properties.

There are a few variables in this case : which sound device is selected in macOS, which sound device is selected in TeamViewer's audio properties, is there more than one audio device available on the computer, etc.  This will hence need some investigation in order to establish what really works and doesn't and how one setting affects the others.

Step-by-step procedures to reproduce this "sound boosting" issue would be welcome from all contributors in this community.

BTW, version 12.0.81460 was released shortly after 12.0.80984, but the "audio boosting" issue persisted in the latter as well.

So... Community !!  Let's give the TeamViewer team a hand to sort out and pinpoint this issue so that we may finally get a great audio experience when using their application !  :smileywink:

Thank you all in advance !!

Kind regards,

SkyLukeQc

10 Replies
10 Replies
Posted by Szienz
Trigon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

This is on TV 12.81460
OSX 10.12.6
Sound settings is on internal speakers, no other devices are connected

  • Volume is set to low,  internet connection disabled
  • I start TV, sound stays low
  • connect to internet, TV logs in and sound is directly set to max volume

When I change back to the old interface mode, results are the same.
Bug is very reproducible.

Posted by dewege
Electron

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

Hi SkyLukeQc

I am very annoyed about this, since I use IP-telephony with my headset. Mac sound is therefore always switched to the USB-headset, only ringing (of the VoIP-Software) to internal speaker (mac mini, 10.12.5).

  • After loggin into Mac account, teamviewer start automatically --> always max volume, so I turn it down to protect my ears.
  • Customer calls, I talk with him, start Teamviewer session --> max volume (!!), I turn it down as fast as I can to PROTECT my ears.

Its very reproducable and VERY annoying because I do not want Teamviewer to cause damage to my ears. This should really be a high proirity top issue in your development since it can cause health issues

Why is there still nothing mentioned on the teamviewer knowledge base or on the downloads page? Also the changelog seems not to takle the audio problem.

Is there a way to get a notification when the bug is solved ?

Regards

dewege

BTW: Furthermore I can second one of the posters (@Zen, Message-ID: M5487) in the preceeding thread: To stay compatible with clients is in fact forcing paying customers to yearly upgrade their license for quite a sum of money. So the marketing argument used by teamviewer ("you pay once and use it for ever - don't pay yearly as with our competitors") does not really hold anymore.

I did now downgrade again to 12.0.75813 (rmember to switch off automatic updates in TV-settings), so I can not provide any more feedback to the failing version.

Posted by SkyLukeQc
Tetragon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

@Julia and @Esther,

Your attention and contribution to this thread, as well as to the last comments posted on the previous one (click here) would be more than welcome !!  :smileyhappy:

The issue went from "audio ducking" to "audio boosting", and the latter is, in my opinion, far worse...

It would be nice to get this solved as soon as possible !

Thank you in advance !!

Kind regards,

SkyLukeQc

Posted by life
Henagon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

It's called poor programming and testing before releasing. Just negligence on the programmers part.

Posted by TeamViewer Staff
TeamViewer Staff

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

Hi SkyLukeQc,

Thank you for your question. I talked to our development and as you alreadys expected - this is a bug in the current version and they are working on a solution. I will of course keep you updated when I receive more information.

Cheers

Julia
Senior Support Engineer - 2nd level Support
Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button.
Posted by DeafByTV
Henagon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

After a few ringing ears and being terribly annoyed by this bug... I think I might have found a workaround. I found it by accident, by messing around in the audio section, so I'm hoping these are the correct instructions.

I'm on version 12.0.81460, MacOS 10.12.6, early 2013 Macbook Pro. My TeamViewer app is in the Dutch language so I'll be guessing what the English translations are for the controls on the audio section.

  • Start off by playing some music in for example iTunes.
  • Put in your earplugs to prevent hearing loss.
  • Start TeamViewer.
  • Go to preferences, go to the audio section.
  • There's a dropdown box that probably says 'Built-in speakers' and which you can also set to 'Standard output' or 'Standard output device'. You're going to turn the volume down on both options.
  • Select 'Standard output' or 'Standard output device'. Turn the volume slider way down by dragging it to the left.
  • Hit the 'Apply' button.
  • In the dropdown box, select 'Built-in speakers'. Again, turn the volume slider way down.
  • Again, hit the 'Apply' button.
  • Uncheck 'Noise Cancelation' and hit the 'Apply' button.
  • Select some random other section in the preferences. You'll notice the volume is louder again. The volume decreases whenever you select the audio section.
  • Select the audio section to check if your volume slider settings were saved. The volume slider should be completely to the left. This should be the case for both settings of the Speaker drop-down box. If not, set the volume slider to the left and re-apply.
  • Exit the preferences.
  • Exit TeamViewer.
  • Let's test and see if it's working: lower the volume on your Mac.
  • Start TeamViewer. If there is no audio boost, chances are great it's working for you.
  • Open a connection. If there is no audio boost, you're set!

This worked for me. And it turns out to be persistent even after restarting my Macbook.
If it doesn't work... I also fiddled with the checkbox (noise threshold? right above 'Apply') in combination with the dragging down the volume sliders.

AudioSettings.png

[edited: I added the instructions for unchecking 'Noise Cancelation'. Thank you @Szienz for adding and confirming that setting.]

 

Posted by Szienz
Trigon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

Good trick, it worked, but it indeed needed Noise Cancellation to be UNmarked.

Thans for sharing

Posted by DeafByTV
Henagon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

Great and thanks @Szienz for confirming. I added unchecking Noise cancelation to the instructions.

Posted by SkyLukeQc
Tetragon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

This is sooo wonderful !!  I really like this community !

Thank you @DeafByTV (best nickname EVER !!) and @Szienz for your very helpful contributions to this thread !

I will now proceed and implement this workaround myself while we all wait to receive some news regarding the official bug fix by TeamViewer's maintenance and support teams.

Have an excellent day !

Regards,

SkyLukeQc

Posted by rockit99
Henagon

Re: After solving the "audio ducking" issue, we now have an "audio boosting" iss

Excellent! It worked for me too. Thanks!