Posted by Doug_Allison
Henagon

Assignment.json never created

This is my process as we deploy TeamViewer at this location, it has worked on all machine except three (out of 72).  Sometimes it takes a bit of time for AssignmentData.json to show up but it does.

 here is my process

 I run TeamViewer_Host-xxxxxxxxx.msi

Wait for AssignmentData.json to show up in ${ProgramFiles}\TeamViewer\

Run teamviewer.bat

 

On three machines AssignmentData.json never gets created therefore the bat file fail with file not found.

 The bat file contains only:

 TeamViewer_Assignment.exe -apitoken xxxxxxxxxxxxxxxxxxxxx -datafile "${ProgramFiles}\TeamViewer\AssignmentData.json"

Pause

 

its worked 69 times but will not create the file on these few machines.  I have looked thru all the logs and see nothing that tells me why. 

 I have cleared the registry of all teamviwer entries as well as this will cause the file not to be created.

I am at a loss as what to try next.

 

5 Replies
Posted by iainwels
Pentagon

Re: Assignment.json never created

Hello Doug_Allison,

This is just a guess in the dark but did you try deleting all the teamviewers on that computer with deleting all settings on as well and then reinstalling the client?

I hope this helps!

 

With kind regards, Met vriendelijke groet,
Iain Wels,
ICT-Support
If you found this helpfull please verify it as an solution, so it could help other people
Posted by Doug_Allison
Henagon

Re: Assignment.json never created

Thanks, I have tried that at this point, a lot of times.  I am actually getting pretty good at it :)

Posted by iainwels
Pentagon

Re: Assignment.json never created

Hello Doug_Allison,

So i think that you mean it is not helped with that?

With kind regards, Met vriendelijke groet,
Iain Wels,
ICT-Support
If you found this helpfull please verify it as an solution, so it could help other people
Posted by Former Staff Jonathan
Former Staff

Re: Assignment.json never created

Hi Doug_Allison,

Thanks for your post's!

@iainwels, thanks again for your help with this one.

@Doug_Allison, I see that you are having a TeamViewer license. Please contact your local TeamViewer support center so our support engineers can assist with your question.

All the best,

Jonathan

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Highlighted
Posted by stijnosb
Henagon

Re: Assignment.json never created

Did you ever get this fixed?