Posted by HansRaaijmakers
Henagon

Automatically log off on session start

Hi Guys,

We are using a business license for teamviewer.
Most of the times when I login to a remote computer, the user logged on will be automatically logged of. 

I don't know if this is a setting, or some error.

Please help!

Thanks, Hans

1 Accepted Solution

Accepted Solutions
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Automatically log off on session start

Dear @HansRaaijmakers,

Thank you for your message.

Can you please uninstall TeamViewer Host on the remote PC (Note: activate the option to delete all Settings of TeamViewer when you uninstall it) and delete all Reg entries for TeamViewer?
Please click on Windows with a right mouse click and go to “run” and type on regedit and accept.

Then navigate to 32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer or 64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer and HKEY_CURRENT_USER\Software\TeamViewer and delete all files related to TeamViewer.
Also please download a fresh Version of TeamViewer 12 Host and install it as an administrator.
You can find all Versions of TeamViewer here: https://www.teamviewer.com/en/download/windows.aspx

Once done this please try once again to connect to that machine, please be sure that you are running the latest TeamViewer version 12 also on your machine.

I hope that this will help you.

Take care,

Giovanni.

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)
9 Replies
Posted by Raven
Trigon

Re: Automatically log off on session start

Do you mean logged-off, or machine-locked ?  As in ... during a TeamViewer session, if you bring down the top pane of buttons, and go actions > lock > there is an option called "lock on session end", which is enabled by default.

This is obviously a security setting that works great on servers, but it can prove irritating to end-users because, if you are remote-accessing a colleague's workstation to fix a problem they are having, for them to have to unlock their terminal after you have finished your remote-access session is just ... unnecessary.

The good news is that you can uncheck this box on a per-workstation basis, and TeamViewer will remember the setting being on/off for that given workstation the next time you access it.

In this way you can enabled it for servers, and disable it for client workstations.

Hope that helps =]

- Raven
Posted by HansRaaijmakers
Henagon

Re: Automatically log off on session start

Hi Raven,

Thank you for your reply. I actually mean locks the computer.
When I start a remote session, the computer automatically locks. Not just once, even when the user logs in again, and I move my mouse again, the computer locks again. 

Unfortunately this is not just with one computer, this is with most of them. 
On client computers, I run TV12 host, while on my computer the full version is installed.

Posted by Raven
Trigon

Re: Automatically log off on session start

So ... again, sorry, just to clarify ... is this :-

A) You remote a PC and you're ok, then you close your connection, re-connect and find it has locked; or

B) You remote a PC and find it has locked literally as soon as you have taken remote control, and the end-user confirms that the machine was not locked before you arrived ?

Because if it's B ?  Then that is really really weird ...

- Raven
Posted by HansRaaijmakers
Henagon

Re: Automatically log off on session start

Hi Raven,

No problem, ask me anything you want. You are helping me, not the other way around ;).

It's actually B, I can see it unlocked when I log in, and it immediately locks as soon as I want to do something on the remote machine. When the user logs back in, and I try to do something on the remote machine again, it locks immediately again.

I agree, it's really really weird... And I would add annoying to that ;).

Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: Automatically log off on session start

Dear @HansRaaijmakers,

Thank you for your message.

Can you please uninstall TeamViewer Host on the remote PC (Note: activate the option to delete all Settings of TeamViewer when you uninstall it) and delete all Reg entries for TeamViewer?
Please click on Windows with a right mouse click and go to “run” and type on regedit and accept.

Then navigate to 32 bit: HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer or 64 bit: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer and HKEY_CURRENT_USER\Software\TeamViewer and delete all files related to TeamViewer.
Also please download a fresh Version of TeamViewer 12 Host and install it as an administrator.
You can find all Versions of TeamViewer here: https://www.teamviewer.com/en/download/windows.aspx

Once done this please try once again to connect to that machine, please be sure that you are running the latest TeamViewer version 12 also on your machine.

I hope that this will help you.

Take care,

Giovanni.

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)
Posted by HansRaaijmakers
Henagon

Re: Automatically log off on session start

@Giovanni

That seemed to do the trick, thanks!

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: Automatically log off on session start

@HansRaaijmakers

you're welcome. Glad to hear that I could help you.

I wish to you a nice day and an excelent weekend.

Take care,

Giovanni.

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)
2 Replies
Posted by Anita984
Henagon

log off

hi. I have licence bought all ready 2 comp connected with one in Poland, but one computer are logged off and wrote message are : that I need buy licence, maybe I didnt correct add comp to the licence? how to do this correct?

Posted by Moderator Moderator
Moderator

Re: log off

Hi @Anita984,

Can you kindly make sure sure that with either one side of the connection device has signed in your licensed account please.

For further assistance, feel free to contact TeamViewer for individual support.

Regards

Ying_Q