Announcements

A new TeamViewer version for Windows has been released. Read the Change Log for 15.7.7 here!

Highlighted
Posted by
Henagon

Can't activate license

When clicking the activation link in the activation email sent to me I get the popup notification that the license has already been activated. I have two teamviewer accounts and have tested it under both. Neither show an active subscription.

I can't open a ticket for it because I don't have an active license.

I can't get support over the phone because the license is not a business one.

There are no other support options than this community support forum and I find this to be absolutely ridiculous.

I have my Order number and receipt and the account details that the license was ordered under. I would appreciate some support.

I just tried getting through to their support over the phone through the business section and was hung up on as soon as we gave them the order email address.

This is the worst excuse for support that I've ever seen.

EDIT: Just tried to submit this question and get "There was an error while attempting to post your message. Try again in a few minutes."

Doing great here guys.

 

1 Reply
1 Reply
Highlighted
Posted by Moderator Moderator
Moderator

Re: Can't activate license

Hello @ncloutier79,

Thank you for your message and welcome to the TeamViewer Community! 🙌

We are sorry to hear you had a bad customer support experience.

However, if you cannot open any ticket, you can get support via phone, as you have an order number to give through. Please contact our support directly, they will be able to help: https://www.teamviewer.com/en/support/contact/ 

Best regards

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.