Posted by augoose
Henagon

Can't connect to version 12.0.132598 with newer versions

I'm trying to connect to a desktop remotely running version 12 and I'm getting error which states "the remote Teamviewer is running an older version which is out of date. Therefore you cannot connect to this version anymore".

I've tried numerous devices on my end (tablet, phone, desktop) and have tried several versions (12,13, and 14) on my end in an attempt to match the version 12 on the remote PC.

I thought there used to be a way to remote update computers visible under my management console. Is that no longer an option?

3 Replies
3 Replies
Posted by Moderator Moderator
Moderator

Re: Can't connect to version 12.0.132598 with newer versions

Hello @augoose

Thank you for your message.

In order to keep using TeamViewer for free, you need to update it to the latest version on both sides of the connection.

You will find all the information you need in our Knowledge Base article here: Enjoy using the best version of TeamViewer we made so far! - How to proceed?

Also, this could also be interesting for you: How do I update TeamViewer?

I hope this could help. If not, do not hesitate to ask your questions here.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Posted by augoose
Henagon

Re: Can't connect to version 12.0.132598 with newer versions

sorry, I wasn't clear. the remote computer is temporarily inaccessible so it is not able to be updated at the moment. I've tried the most recent versions of the software of my end and also went back to the same version that is on the computer I'm trying to connect to and I'm still getting the same error. I presume based on your response that there is no option to update the version of team viewer remotely?
Posted by Moderator Moderator
Moderator

Re: Can't connect to version 12.0.132598 with newer versions

Hello @augoose,

Thank you for your message.

According to what you say, the remote update is not possible anymore for you, as you have (after several warnings) been blocked. You need to update manually TeamViewer on the remote side to keep using the software.

I thank you in advance for your understanding.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.