Posted by musicissilver
Electron

Can't reinstall Teamviewer - "Rollback framework could not be initialized"

PLEASE READ THE ENTIRE POST! I'VE ALREADY TRIED ALL SOLUTIONS CURRENTLY AVAILABLE ON THESE FORUMS.

I can't seem to reinstall Teamviewer after previously uninstalling it. The error says: "Rollback framework could not be initialized. Installation aborted!" I tried updating the .NET framework, and running the installer as administrator, but neither of those worked and there aren't any solutions online. I also tried deleting the folder: "C:\Users\**yourusernamehere**\AppData\Local\Temp\TeamViewer" to no avail. It deleted, but TeamViewer still won't install. If you have any ideas, let me know? Thanks.

Capture.PNG

2 Replies
2 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: Can't reinstall Teamviewer - "Rollback framework could not be initialized"

Dear @musicissilver

This issue you described could be caused by corrupted registry keys left behind by a faulty installation, or a Windows update.

Please try the following:

-Remove any versions of TeamViewer via the add/remove programs option from Control Panel.

-Go to Regedit: remove the full TeamViewer folders located in
[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\]
[HKEY_CURRENT_USER\SOFTWARE\]

and if there the folder "TVInstallTemp" (also located in [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\] )

-Also, please delete the entire TeamViewer folder located in %temp%

-Restart the machine.

-Disable all the Antivirus/security software

-Reinstall a fresh copy of TeamViewer from our website and during the installation select "advance" and change the installation path from C:\Program Files (x86)\TeamViewer to C:\TeamViewer

I hope this solves the issue.

Giovanni

Giovanni
Enterprise Solutions Engineer

If my reply answered your question, help out other users and click the "Accept as a Solution" button below.
You can also say thanks by clicking on the "Thumbs Up" button! (Kudo)
Posted by Sextant
Photon

Re: Can't reinstall Teamviewer - "Rollback framework could not be initialized"

I have the same problem, tried your suggested solution, but still didn't work. Thanks.