Posted by Domenico
Photon

DNS not working

It seems DNS name resolution is not working inside latest version of TV
(12.0.71510 NI) on Linux Ubuntu Zesty Zapu.

If I go to master4.teamviewer.com by browser I can read the diagnostic message "This site is running TeamViewer."

I enclose a little part of the log file.

Any help?


2017/01/27 23:37:00.037 5456 4127587136 NX0!!!CTcpConnectionBase[1]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: asio.netdb:2
2017/01/27 23:37:00.037 5456 4127587136 NX0 Activating Router carrier
2017/01/27 23:37:00.040 5456 4115659584 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/01/27 23:37:00.041 5456 4115659584 NX0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0
2017/01/27 23:37:00.041 5456 4115659584 NX0!! NetWatchdog: Port 443 proxy search failed! No working setting found.
2017/01/27 23:37:00.041 5456 4115659584 NX0 Activating Router carrier
2017/01/27 23:37:00.044 5456 4135979840 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/01/27 23:37:00.044 5456 4135979840 NX0!! NetWatchdog: Port 80 proxy search failed! No working setting found.
2017/01/27 23:37:00.044 5456 4135979840 NX0! CKeepAliveClientClient::HandlePing(): ping failed
2017/01/27 23:37:00.044 5456 4135979840 NX0 Activating Router carrier
2017/01/27 23:37:00.045 5456 4135979840 NX0 CProcessCommandHandlerMasterConnect[4]::CreateMasterConnect(): master4.teamviewer.com:80, Connection 4, proxy=''
2017/01/27 23:37:00.047 5456 4144372544 NX0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve proxy name (5), Could not resolve proxy: master4.teamviewer.com
2017/01/27 23:37:00.047 5456 4144372544 NX0! CProcessCommandHandlerMasterConnect[4]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/01/27 23:37:00.048 5456 4144372544 NX0!! LookUpDNS failed for master4.teamviewer.com, socket error = -3, Errorcode=11
2017/01/27 23:37:00.048 5456 4144372544 NX0!!!Connect to Master master4.teamviewer.com / failed!, Errorcode=11
2017/01/27 23:37:00.048 5456 4144372544 NX0!! CMasterConnectorAsio::HandleMasterResponseRegister(): MasterConnect failed. ErrorCode=10, Errorcode=11
2017/01/27 23:37:00.091 5456 4127587136 NX0 UpdateOnlineState newOnlineValue 1
20

4 Replies
4 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: DNS not working

Dear Domenico,

Thank you for your post.

May you please try if the following command works for you?

sudo teamviewer daemon restart

Then open up TeamViewer again.

Let us know if this solution works for you.

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by mwolf
Digon

Re: DNS not working

same to me...I got it working by adding a proxy manually...but thats no solution

Posted by mwolf
Digon

Re: DNS not working

2017/07/04 17:31:23.445  2668 4081056576 S   CProcessCommandHandlerMasterConnect[44]::CreateMasterConnect(): master14.teamviewer.com:80, Connection 44, proxy=''
2017/07/04 17:31:23.447  2668 4143713088 S!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: master14.teamviewer.com
2017/07/04 17:31:23.447  2668 4143713088 S!  CProcessCommandHandlerMasterConnect[44]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/07/04 17:31:23.448  2668 4143713088 S!! LookUpDNS failed for master14.teamviewer.com, socket error = -5, Errorcode=110
2017/07/04 17:31:23.448  2668 4143713088 S!!!Connect to Master master14.teamviewer.com /  failed!, Errorcode=110
2017/07/04 17:31:23.448  2668 4143713088 S!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10, Errorcode=110
2017/07/04 17:31:26.449  2668 4104117056 S   Activating Router carrier
2017/07/04 17:31:26.450  2668 4093639488 S!!!CTcpConnectionBase[45]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: asio.netdb:1
2017/07/04 17:31:26.450  2668 4093639488 S   Activating Router carrier
2017/07/04 17:31:26.452  2668 4072663872 S!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/07/04 17:31:26.452  2668 4072663872 S!! Port443Connection::ConnectInternal: failed with HTTP status code = 0
2017/07/04 17:31:26.452  2668 4072663872 S!! NetWatchdog: Port 443 proxy search failed! No working setting found.
2017/07/04 17:31:26.453  2668 4072663872 S   Activating Router carrier
2017/07/04 17:31:26.455  2668 4116704064 S!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/07/04 17:31:26.455  2668 4116704064 S!! NetWatchdog: Port 80 proxy search failed! No working setting found. -- next log entries will be omitted --
2017/07/04 17:31:26.455  2668 4116704064 S!  CKeepAliveClientClient::HandlePing(): ping failed
2017/07/04 17:31:26.455  2668 4116704064 S   Activating Router carrier
2017/07/04 17:31:26.455  2668 4116704064 S   CProcessCommandHandlerMasterConnect[48]::CreateMasterConnect(): master9.teamviewer.com:80, Connection 48, proxy=''
2017/07/04 17:31:26.458  2668 4143713088 S!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: master9.teamviewer.com, Errorcode=110
2017/07/04 17:31:26.458  2668 4143713088 S!  CProcessCommandHandlerMasterConnect[48]::HandleMasterConnect(): MasterConnect to 0.0.0.0 failed
2017/07/04 17:31:26.458  2668 4143713088 S!! LookUpDNS failed for master9.teamviewer.com, socket error = -5, Errorcode=110
2017/07/04 17:31:26.458  2668 4143713088 S!!!Connect to Master master9.teamviewer.com /  failed!, Errorcode=110
2017/07/04 17:31:26.458  2668 4143713088 S!! CMasterConnectorAsio::HandleMasterResponseLogin(): MasterConnect failed. ErrorCode=10, Errorcode=110

Posted by TeamViewer Staff
TeamViewer Staff

Re: DNS not working

Dear Domenico,

Thank you for your message.

Could you please update TeamViewer to the latest version v12.0.76279 from our website and try again?

https://www.teamviewer.com/en/download/linux/

If the problem still occurs after the update, please feel free to contact us again.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.