Announcements

Shape the future of your TeamViewer product with our Product Team. Click here to join!

Posted by DescPlatit
Henagon

Informations about compatibility

Hello,

I would like to find formal informations about the compatibility between versions. For example, TeamViewer 14 can connect to versions x -> 14 and TeamViewer 13 can connect to versions y -> 13. I couldn't find that information in support or knowledge base.

Thank you.

3 Replies
3 Replies
Posted by Moderator Moderator
Moderator

Re: Informations about compatibility

Hi @DescPlatit ,

thank you for your post. Welcome to the Community! :)

If you have a license, you will be able to connect to older versions of TeamViewer
If you are using the free version, then TV --> TV 14

Let me know if you need further information

Best, Alena

Spanish Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below. You can also say thanks by clicking on the Thumbs Up button!
English Community |  Deutsche Community | 日本語コミュニティ |  中文社区 | Communauté française | Comunidad española

Posted by DescPlatit
Henagon

Re: Informations about compatibility

Thank you @AlenaC

I want to have a confirmation that if I have a licence for TV 13 or TV 14, I can connect to a very old version like TV 8 or TV 10 and not get a message like "The remote TeamViewer is running an old version which is out of date".

Regards,
David

Posted by Moderator Moderator
Moderator

Re: Informations about compatibility

Hi @DescPlatit ,

if the older version is supported in the installed OS (please have a look at: Which operating systems are supported? ) then you should be able to connect from a newer TeamViewer license.

Best, Alena

Spanish Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below. You can also say thanks by clicking on the Thumbs Up button!
English Community |  Deutsche Community | 日本語コミュニティ |  中文社区 | Communauté française | Comunidad española