Announcements

Shape the future of your TeamViewer product with our Product Team. Click here to join!

Posted by FluoCrayKenny
Henagon

No connection to TeamViewer Server - Please check your internet connection

I'm using TeamViewer v12 on windows since a long time and have no problem with it until this morning. 2 stations : one desktop at home and one laptop at my company. I use my laptop at work to connect on my desktop at home.

NOTE : Yesterday I probably messed up with another program : Proxifier. It had probably messed up windows socks but TeamViewer seems not to have any trouble to connect at that moment so it may not be related but I think it worth mentionning.

This morning after a fresh reboot TeamViewer can't connect to master server. (TV v12 on laptop works perfectly fine)

The log file contains some strange lines

2017/09/27 22:06:53.814 13544 13516  0   Logger started.
2017/09/27 22:06:53.856 13544 13516  0!! LocalIPAddresses: getaddrinfo failed with socket error 11001, Errorcode=1008
2017/09/27 22:06:53.856 13544 13516  0!  AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
2017/09/27 22:06:53.858 13544 13516  0   UpdateOnlineState newOnlineValue 1
2017/09/27 22:06:53.858 13544 13516  0!! LocalIPAddresses: getaddrinfo failed with socket error 11001, Errorcode=1008
[...]
2017/09/27 22:06:57.401 13544 14080 S0!!!CTcpConnectionBase[5]::HandleResolve(): Resolve failed, ping3.teamviewer.com, Error: system:11001
2017/09/27 22:06:57.401 13544 14992 S0   Activating Router carrier
2017/09/27 22:06:57.416 13544 14992 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/09/27 22:06:57.416 13544 14992 S0!! Port443Connection::ConnectInternal: failed with HTTP status code = 0
2017/09/27 22:06:57.416 13544 13496 S0!! NetWatchdog: Port 443 proxy search failed! No working setting found.
2017/09/27 22:06:57.416 13544 13496 S0   Activating Router carrier
2017/09/27 22:06:57.432 13544 14992 S0!! HttpRequestImpl::CurlFinished(): curl request failed: Couldn't resolve host name (6), Could not resolve host: ping3.teamviewer.com
2017/09/27 22:06:57.432 13544 13496 S0!! NetWatchdog: Port 80 proxy search failed! No working setting found.

as you can see, it seems that TeamViewer can't resolve any address therefor can't connect to master server. Oh, and only TeamViewer seems to have trouble to  Internetaccess. I have no problem with every other programs.

So after some search on Internet I found some hints on what to look and what to do and on this forum I had numerous possible solution. So here are my attempt to fix it :

  • I've tried to stop service and start again => No connection either
  • I've tried a fresh install, and even with a previous version (from July) => No connection
  • I've tried to disable IPv6 to force IPv4 DNS resolve without success
  • I've change my ISP DNS by Google's one - 8.8.8.8 and even with independant French DNS to test it => No connection
  • Because I can in console ping everything, I've tried to put IP of ping3 / master1-2-3-etc/ directly in etc/hosts to force resolving locally => Still no connection
  • I've tried to flush socks with netsh winsock reset in console => still no connection
  • I've tried to patch Windows.NET with some patch recommanded on forums => still no connection

So i'm little out of option here... Do you have any idea of what can I do to fix that ?

9 Replies
1 Accepted Solution

Accepted Solutions
Posted by FluoCrayKenny
Henagon
Solution

Re: No connection to TeamViewer Server - Please check your internet connection

Ok guys, I have found a fix

It seems that the bug is between socket opening from TeamViewer and Windows (10 for me). After many tries I figure out that TeamViewer may not be in fault here and may be Windows is the real traitor in this problem. I had confirmation 2 days ago.

With the last major Windows update (Creator fall 2017) Windows asked me if I want a full update and I say yes. Windows litteraly installed a whole new version of Windows 10 (fresh install with settings migration). After that TeamViewer works fine again (v12 and v13).

So my suggestion is either re-install a new version of windows or force the migration to a new major update (Creator falls 2017 works for me).

I hope it will help you

View solution in original post

9 Replies
Posted by CCWTechnology
Digon

Re: No connection to TeamViewer Server - Please check your internet connection

Happening on V13 for me as well. Any solution?

Posted by khsjds
Henagon

haRe: No connection to TeamViewer Server - Please check your internet connection

I have the same problem.

I had exactly the same problem in TV12 under windows 10, and thus I modified the hosts file to make it work.

This is not working anymore today, even when I updated to TV13.

However, pinging the domain name under cmd looks fine...

Other internet connection looks fine, too.

Posted by FluoCrayKenny
Henagon
Solution

Re: No connection to TeamViewer Server - Please check your internet connection

Ok guys, I have found a fix

It seems that the bug is between socket opening from TeamViewer and Windows (10 for me). After many tries I figure out that TeamViewer may not be in fault here and may be Windows is the real traitor in this problem. I had confirmation 2 days ago.

With the last major Windows update (Creator fall 2017) Windows asked me if I want a full update and I say yes. Windows litteraly installed a whole new version of Windows 10 (fresh install with settings migration). After that TeamViewer works fine again (v12 and v13).

So my suggestion is either re-install a new version of windows or force the migration to a new major update (Creator falls 2017 works for me).

I hope it will help you

View solution in original post

Posted by CCWTechnology
Digon

Re: No connection to TeamViewer Server - Please check your internet connection

In my case, I found out the client had double NAT'ed.

One router (supplied by ISP) in front of another router (their own). Removing the 2nd router solved the issue.

 

Posted by edunwat
Henagon

Re: No connection to TeamViewer Server - Please check your internet connection

I'm having trouble with TV v8 unable to get a connection after the Fall Update. It knows there's an update available and clicking the teamviewer.com link works fine.

It was working fine before, but something in Windows has changed to prevent it.

I've since been in Windows and done a full Reset to reset the operating system back to default state and that didn't fix it. I've also reinstalled Windows from a memory stick & that didn't fix it. I've reformatted the hard drive & reloaded Windows and it's now working fine. I have several PCs in the same state & I really don't want to have to reformat them all just to get the TV Host to register itself! 

I have a license for commercial use of TV8  so I don't want to upgrade to TV13 as I'll have to pay lots of money & it may not fix it!

Posted by Mortal-Wombat
Henagon

Re: No connection to TeamViewer Server - Please check your internet connection

Hi,

Came across this post as I had the exact same issue.  I was using Kaspersky Total Security 2017 (patch k) and  Fall Creators Update (Windows Version 1709).

I've just upgraded Kaspersky to 2018 (18.0.0.405 patch f) and the problem no longer exists.

The upgrade was quick and painless and after reboot my team viewer application (13.1.1548) in my tray connected successfully.

Hope this helps someone.  So if you have an active Kaspersky subscription then you should be able to upgrade and hopefully teamviewer should start functioning again.

Happy to respond to any specific questions.

All the best.

Duncan aka Mortal-Wombat

Posted by Willem48
Henagon

Re: No connection to TeamViewer Server - Please check your internet connection

teamviewer.png

I am on a camping and get these announcement , but when i AM AT HOME THERE IS NO PROBLEM. iNTERNnet works fine. Who can help me.

Posted by AndyMac
Photon

Re: No connection to TeamViewer Server - Please check your internet connection

I spent a few hours uninstalling and reinstalling Teamviewer and uninstalling and reinstalling virus protection and firewall and TV still would not connect. This has been a problem for me for at least a month. 

Finally found a simple fix and it does relate to the internet connection and works for the latest TV version. The problem is a conflict with network adapter IPv4 and IPv6. Disable IPv6 and TV will connect instantly.

In Windows 10: All settings>Network and Sharing Center>Change Adapter Settings>WIfi Properties>Untick IPv6

Posted by radek_
Photon

Re: No connection to TeamViewer Server - Please check your internet connection

Just bumped into this thread today having the same issue.

In my case upgrading VGA driver solved the problem immedaitely.

I vaguely remember that few months ago TV13 was playing up, then started working again after few days with no appparent reason - I bet the fix was the same back then.