Posted by gabriel0515
Digon

Not ready, Please check your connection

Hi, i'm using TeamViwer on a Windows 10.1 and since last month I couldn't connect to any computer since this message started showing up.

I've tried the support, and they only say to make sure that port 5938 has been opened for outgoing connections and also unblock the following URL:  *.teamviewer.com

Which I did, and it didn't work. I also tried to stop Windows Firewall and nothing changed.

I don't use any other security programs beside the windows defender and firewall.

I've been getting this error since I reinstalled Windows, it was working just fine before, nothing changed besides that. Any solution to this?

 

1 Accepted Solution

Accepted Solutions
Posted by Chiron
Hexagon
Solution

Clear TeamViewer from your hosts file

master9.teamviewer.com is resolving to 178.77.120.106 because that is in your hostfile. Check one of the working computers you have access to, hopefully they can ping master9.teamviewer.com and have it resolve to a different (closer) IP.

I think you can delete the TeamViewer entries from your hosts file, and make sure you are using the same DNS as the working computers.

I don't work for TeamViewer. I'm just a user.

View solution in original post

29 Replies
Posted by Chiron
Hexagon

Re: Not ready, Please check your connection

  • Is networking OK? Make sure internet access is working, access to file shares, printers, etc.
  • Can others connect to you with TeamViewer? Check if the problem is just outgoing connections.
  • Did Windows update to build 1703? We have had some issues with other applications after that upgrade.
  • Have you tried re-installing TeamViewer? You can keep your settings, watch for the checkbox during the uninstall wizard.
  • What version of TeamViewer are you using? May need to upgrade (or down-grade).

Let us know if you find a solution!

I don't work for TeamViewer. I'm just a user.
Posted by gabriel0515
Digon

Re: Not ready, Please check your connection

  • Yes, my internet is working just fine, and I can see other computer in my network
  • They can't, since my teamviewer doesn't show any information like ID or Password neither let me connect to my account
  • Yes, my Windows 10 PRO is at 1703 build
  • Yes I tried a clean reinstall
  • 12.0.82216, I've tried installing v11 and didn't work
Posted by Chiron
Hexagon

Re: Not ready, Please check your connection

Are you set to only accept LAN connections?

Options > General Tab > Incomming LAN Connections >

LANOnly.pngLAN Only

Otherwise, can you enable and use LAN connections? Just use your IP address instead of a TeamViewer ID. This will help determine if there is someting wrong with your TeamViewer install or your access through your router\firewall.

I don't work for TeamViewer. I'm just a user.
Posted by gabriel0515
Digon

Re: Not ready, Please check your connection

It was deactivated, I set to "accept" and the message teamviewer shows is "Only LAN Connection avaliable". I was successful in triying to connect to my IP address.

Here is how I set my firewall Outbound and inbound rules.

teamv rules.jpg

I have also paste the below in "C:\Windows\System32\drivers\etc\hosts"

"# Teamviewer
178.77.120.6 master1.teamviewer.com
178.77.120.104 master2.teamviewer.com
178.77.120.100 master3.teamviewer.com
178.77.120.102 master4.teamviewer.com
178.77.120.6 master5.teamviewer.com
178.77.120.100 master6.teamviewer.com
178.77.120.102 master7.teamviewer.com
178.77.120.104 master8.teamviewer.com
178.77.120.106 master9.teamviewer.com
178.77.120.104 master10.teamviewer.com
178.77.120.100 master11.teamviewer.com
178.77.120.6 master12.teamviewer.com
178.77.120.102 master13.teamviewer.com
178.77.120.106 master14.teamviewer.com
178.77.120.106 master15.teamviewer.com
178.77.120.106 master16.teamviewer.com"

Posted by Chiron
Hexagon

Re: Not ready, Please check your connection

OK, so TeamViewer functions on LAN. Are you in Germany? Because I am in the USA and my IP addresses don't match yours.

I can ping master15.teamviewer.com and it resolves to 185.188.32.5

Try to ping one of the servers, if it fails try tracert to see where it stops.

I don't work for TeamViewer. I'm just a user.
Posted by gabriel0515
Digon

Re: Not ready, Please check your connection

I'm from Brazil, I got those ip on a youtube video trying to fix this issue, I could not ping to them, are there others I should include on that host file?

Here is tracert to master15

"Rastreando a rota para master9.teamviewer.com [178.77.120.106]
com no máximo 30 saltos:

1 1 ms 1 ms <1 ms 192.168.0.1
2 * * * Esgotado o tempo limite do pedido.
3 12 ms 12 ms 8 ms bb24c0e1.virtua.com.br [187.36.192.225]
4 21 ms 20 ms 23 ms embratel-T0-0-0-1-uacc03.rjoen.embratel.net.br [201.30.79.1]
5 24 ms 26 ms 23 ms ligtacao-H1-0-0-0-tcore01.rjoen.embratel.net.br [200.244.216.89]
6 140 ms 142 ms 139 ms ebt-BP1222-intl02.nyk.embratel.net.br [200.230.251.126]
7 131 ms 130 ms 134 ms 62.157.249.105
8 194 ms 200 ms 197 ms lon-sb4-i.LON.GB.NET.DTAG.DE [62.154.5.42]
9 196 ms 213 ms 194 ms 80.157.204.158
10 199 ms 224 ms 197 ms ae0.cr-merak.lon5.core.heg.com [87.230.114.114]
11 208 ms 208 ms 207 ms ae12.cr-pollux.cgn3.core.heg.com [87.230.114.33]
12 208 ms 208 ms 206 ms ae4.dr-master.r1.cgn3.plusserver.com [87.230.114.170]
13 * * * Esgotado o tempo limite do pedido.
....14 to 30 time out. ...."

Posted by Chiron
Hexagon
Solution

Clear TeamViewer from your hosts file

master9.teamviewer.com is resolving to 178.77.120.106 because that is in your hostfile. Check one of the working computers you have access to, hopefully they can ping master9.teamviewer.com and have it resolve to a different (closer) IP.

I think you can delete the TeamViewer entries from your hosts file, and make sure you are using the same DNS as the working computers.

I don't work for TeamViewer. I'm just a user.

View solution in original post

Posted by gabriel0515
Digon

Re: Clear TeamViewer from your hosts file

I put the same DNS as the computer teamviewer was working and it worked in mine too. I even deleted the teamviewer entries I had on Host file.

 

Thank You very much!

Posted by malai
Henagon

Re: Clear TeamViewer from your hosts file

yes

Posted by malai
Henagon

Re: Clear TeamViewer from your hosts file

Not reeady 

Posted by snipes
Electron

Re: Clear TeamViewer from your hosts file

i am using google dns and teamviewer v12 never worked for me but v11 is still running excelent.. my pc is resolving the same dns ip's like whoer.net lookup for every masterx subdomain.. On my windows server it's the same problem..

05e9f2e04c

Posted by khchuang
Henagon

Re: Not ready, Please check your connection

My teamviewer cannot connect after update windows update KB4033631 at my tablet.

I have to uninstall the update and the teamviewer can conenct again.

Posted by Biwel
Henagon

Re: Clear TeamViewer from your hosts file

gabriel0515  :can you explay how you did that?

and khchuang :how did you know what update you need to delete ?

i did a lot updates and dont have the one you have.

 

 

Posted by gabriel0515
Digon

Re: Clear TeamViewer from your hosts file

I went on the other computer TeamViewer was working on:

Network and Sharing Center > Change adapter Settings > Right click on the connection > Propieties > IP V4 Protocol  to see what DNS that computer was using, and did the same thing on mine to put the same DNS. You can also do that by cmd command.

It was a DNS problem for me, so try chaging you DNS somehow

Posted by kingpric
Henagon

Re: Not ready, Please check your connection

Reinstalling did solved my problem.

Posted by jasonsmells1328
Photon

Re: Not ready, Please check your connection

this happened to me during AVG installation. See if that ain't the problem. I re-installed Teamviewer, signed back in, VOILA! 

Posted by johnny77
Henagon

couple of questions

I have two questions

1. yesterday, I was working on one of my client's computers and Windows was asking for the administrator (domain) credentials. The TeamViewer screen blanked and at the client's end, it was waiting for the credentials to be installed. I had to abort doing this remotely because I didn't want to give the client that information. Thus, a trip down to their office.

So, is there a way to get around this?

2 second question, when I restart a workstation, sometimes I'm given the option to reconnect after a restart but most times not. How can I set that so that I always am able to log back in without the client having to re-run the TV program and sending me a new password?

Thanks

Posted by TheStonedDruid
Electron

Re: Clear TeamViewer from your hosts file

I have no teamviewer entries in my hosts file, nothing blocking it in router, pc firewall is off, my PC DNS matches DNS in router settings, I can ping the master1.teamviewer.com server (and others)... yet still no connection. Any ideas?

Posted by richardfoleher
Digon

Re: Not ready, Please check your connection

I have a similar issue with my laptop whereby at home Teamviewer is not ready but if I vpn to the office or use my laptop in the office, Teamviewer works fine.

I've checked the routing tables on my router, all good, checked the firewall rules, TV is allowed (uPNP is on anyway but I added a specific rule anyway)

Still no joy, so as of now, if I need to use it at home, I use the vpn to my office first.

If you touched it and it stopped working, the first question to ask is "Did anyone see me touch it..."
Highlighted
Posted by dominicon
Henagon

Re: Clear TeamViewer from your hosts file

This video will show you how.



https://www.youtube.com/watch?v=7e2MmyPvnhs
A step by step, in-depth process on how to edit your windows hosts file. Very brief steps: 1. Open your Hosts file (%windows%/system32/drivers/etc) 2. open hosts file using a text editor 3. delete the 5 lines of unwanted redirects 4. Save as to the desktop with the name "hosts" with the filetype ...
Posted by ZGralewski
Digon

SOLVED - Re: Not ready, Please check your connection

I have many of these problems on many workstations. Usually it is connected with ESET Antivirus. So what I do (that always helps) is usually:

1. Add teamviewer and teamviewer service to exclusions in scanning. Then restart pc.
2. Run in command line (as admin):
netsh winsock reset
netsh int ip reset
(then restart) that usually helps and teaviewer starts to connect again.
3. If above doesn't help, I go to network interfaces in device management and then delete lan and wifi interfaces (without deleting drivers) - just delete interfaces and restart pc.
These steps always help to restore teamviewer connectivity.

Many of my hosts fail randomly after some windows updates (i think). I often have to use other software to remotely connect to a host, use these steps in order to repair teamviewer.

Posted by dmichaels
Henagon

Re: SOLVED - Re: Not ready, Please check your connection

My problem resolved when I unchecked the "Use new interface" option (under the General" tab)

Posted by AnbuKira
Electron

Re: SOLVED - Re: Not ready, Please check your connection

thank you.
Its work for on the no. 2
Posted by dkane999
Electron

Re: NOT SOLVED for me - Re: Not ready, Please check your connection

I tried all above suggestions above to no avail. I inherited my laptop from company that went Bankrupt in July 2018. I think the TV ID: (tied to MAC address?) has not changed and I suspect the TV ID is blocked by teamviewer. If there are actually TV internal support persons here that can help, please email me at [edited by a moderator] and I can send you the TV IF to check internal records. I have used TV in both windows and Linux since 2009 and really enjoyed using it. Thanks everyone for the above suggestions. Very Frustrating problem and support access seems limited without a valid license.

Posted by ZGralewski
Digon

Re: NOT SOLVED for me - Re: Not ready, Please check your connection

Well, I found out that also Eset Security (NOD32 Antivirus) is blocking Teamviewer, too. I exclude Teamviewer_Service.exe from scanning, restart PC and it's working again. Try that way, too. Maybe some AV is blocking it.

Posted by Den_LiteManager
Digon

Re: NOT SOLVED for me - Re: Not ready, Please check your connection

sometimes antivirus block the software

Posted by Simkin
Photon

Re: Clear TeamViewer from your hosts file

The other thing that can do this is a broken IPv6 network. Turn off IPv6 on the client and see if it works.....

Posted by SFFS
Henagon

Re: Not ready, Please check your connection

Check to ensure the proper firewall settings exists.  

When I started receiving this error, I found that the settings for the Private network were not allowing Teamviewer to connect.  It was only allowed on public networks.  Allowed private networks and it connected immediately.

Posted by hsomaiya
Electron

Re: Not ready, Please check your connection

All of a sudden i had faced same issue. I went to task manager, deleted all teamviewer processes, and then started teamviewer again. Guess what, it worked.  This is just a workaround and not solution but atleast your work won't stop.

HTH

Harsh