Highlighted
Posted by tflora
Digon

Quick Support and Mac

Tried using Quick Support with a client on a Mac (I'm on PC) yesterday. Client gave me his Partner ID and each time it said he was running an older version so we couldn't connect. So I had him go up and download again (thinking the current version would be the one available). He downloaded, gave me his Partner ID (as displayed in the Quick Remote app) and it still said he was running an outdated version.

Anybody have any ideas as to what I'm missing here? Never had a problem with this process before. Is it that he's on a Mac? Or maybe that he's in Canada and I'm in the US? Full moon? Really stumped here.

3 Replies
3 Replies
Highlighted
Posted by tflora
Digon

Re: Quick Support and Mac

Really need some help regarding this issue. If no one can help, can someone at least let me know the best way to contact TeamViewer support directly?

Highlighted
Posted by tflora
Digon

Re: Quick Support and Mac

Gee what an active support group! Color me gone. I'll find another product that works better, has more features and company actually answers product-related questions so their users can get their jobs done. Sad....disappointing.

Highlighted
Posted by Senior Moderator Senior Moderator
Senior Moderator

Re: Quick Support and Mac

Hello @tflora 

Thank you for your post.

Please know the TeamViewer community is a user-based community - many solutions come from other users like yourself; we cannot guarantee every post may be seen by a support rep.

Licensed users are able to receive phone and ticket support for any TeamViewer-related issues.

In regards to your case, I can confirm both download pages download 15.2.2756 - the first step would be to confirm that both of you are on this version (Help -> About TeamViewer on Windows, TeamViewer -> About TeamViewer on Mac). 

Please also ensure the remote machine has not installed the Insider Builds, as this would also cause such an alert. If this was installed, TeamViewer and the configuration settings would need to first be uninstalled before the latest official version could be installed.

Josh P.
Senior Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below.

You can also say thanks by clicking on the Thumbs Up button!

Thanks for being an active member of our Community!

Japanese Community (日本語コミュニティ) |  Chinese Community (中文社区) |  German Community (Deutschsprachig) | French Community (Communauté française) | English Community | Spanish Community (Comunidad española)