Highlighted
Posted by catdroid
Henagon

Suppress Login Pop Up?

We want to use Teamviewer in a Citrix (terminal services) environment. We do not want our users to see this pop-up, not even once. Is there some way to suppress it?

Screen Shot 2017-01-23 at 11.07.41 AM.jpg

 

 

8 Replies
1 Accepted Solution

Accepted Solutions
Posted by Community Manager
Community Manager
Solution

Re: Suppress Login Pop Up?

Hi @catdroid

Thank you for your question.

Please try the following:

To disable the dialog box upon installation, please close TeamViewer completely and make sure that all TeamViewer services that might be running on your system have been stopped.

After that, please open the registry editor and add the following DWORD entry:

For version 10 or higher:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\DefaultSettings]

"HostInfoDialog"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\DefaultSettings]

"HostInfoDialog"=dword:00000000

Located in HKEY_CURRENT_USER\Software\TeamViewer\VersionX

Value 1 = Show

Value 0 = Don’t show

 

For version 9 or lower – replace X with version number: 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\VersionX\DefaultSettings]

“HostInfoDialog"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\VersionX\DefaultSettings]

"HostInfoDialog"=dword:00000000

 

Let me know, if this helps. If yes, please accept my reply as a solution.

Best,

Esther

 

8 Replies
Posted by Community Manager
Community Manager
Solution

Re: Suppress Login Pop Up?

Hi @catdroid

Thank you for your question.

Please try the following:

To disable the dialog box upon installation, please close TeamViewer completely and make sure that all TeamViewer services that might be running on your system have been stopped.

After that, please open the registry editor and add the following DWORD entry:

For version 10 or higher:

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\DefaultSettings]

"HostInfoDialog"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\DefaultSettings]

"HostInfoDialog"=dword:00000000

Located in HKEY_CURRENT_USER\Software\TeamViewer\VersionX

Value 1 = Show

Value 0 = Don’t show

 

For version 9 or lower – replace X with version number: 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\VersionX\DefaultSettings]

“HostInfoDialog"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\VersionX\DefaultSettings]

"HostInfoDialog"=dword:00000000

 

Let me know, if this helps. If yes, please accept my reply as a solution.

Best,

Esther

 

Posted by jeffslim
Photon

Re: Suppress Login Pop Up?

Hi, I'm running TV 12 and my registry does not have that entry at all, but I also want to suppress this popup. Any ideas??? 

Posted by DomLan
Heptagon

Re: Suppress Login Pop Up?

Hi @jeffslim,

Have you tried adding the voice manually? Via right mouse button

2017-05-02_19-13-48.png

Hope this help

Regards

Domenico Langone
MCSD: App Builder
Posted by jeffslim
Photon

Re: Suppress Login Pop Up?

I think the AutoStartGUI key set to 0 worked for me! So that's the solution for version 12 if you guys have that!

Posted by jeffslim
Photon

Re: Suppress Login Pop Up?

Me again ... I have to push TeamViewer out to maybe 50 computers; is there a script I can run to write this registry change? 

Posted by jsimmens
Photon

Re: Suppress Login Pop Up?

Located in HKEY_CURRENT_USER\Software\TeamViewer\VersionX

Value 1 = Show

Value 0 = Don’t show

So, for version 12 we would write

[HKEY_CURRENT_USER\Software\TeamViewer]

"12"=dword:00000000

Posted by Jerry_Cope
Photon

Re: Suppress Login Pop Up?

THis works fine for a PC but how do I do the same for a Mac? Why doesn't clearing the 'Don't show this dialog again' tick box achieve the desired result? It didn't work in TV11 either!

Posted by uy
Photon

Re: Suppress Login Pop Up?

How do you suppress the popup on a Mac? This solution seems very Windows/PC based.