Announcements

Shape the future of your TeamViewer product with our Product Team. Click here to join!

Posted by mperez265
Henagon

Teamviewer 14 Not Working because of older version

I updated to Teamviewer 14 from previous working version.  When I tried to open Teamviewer 14, an error message appeared that stated it could not run due to a previous older version that was out of date; and, I had to update to a newer version.

Since I have the latest version, how do I stop the older version from running and how do I delete it?

Any working solution appreciated.

3 Replies
3 Replies
Posted by ganbaa_elmer
Henagon

Re: Teamviewer 14 Not Working because of older version

am in China. is there any block from greatwall ?

Posted by ganbaa_elmer
Henagon

Re: Teamviewer 14 Not Working because of older version

i using vpn and now its working.

i think its chinese firewall blocking teamviewer now ?

Posted by mperez265
Henagon

Re: Teamviewer 14 Not Working because of older version

No, there is no block from greatwall.