Posted by afeudale
Trigon

Teamviewer can't connect to older version??

A client was trying to connect to her work computer this morning.  It told her that her local TV12 needed to be updated to a newer version...so she proceeded to allow it to update to version 14.

After updating, when she tried to connect into her work computer, it told her that the *work* computer needed to be updated!  Obviously she cannot do that remotely...

I was able to login with my TV and saw the TV version was 12.  I proceeded to upgrade to v14 and now she can connect.

This is not an anomaly as it happened to two other clients last week as well.

TV was always able to connect with a newer version into an older version.

Please fix your ridiculously buggy software guys.  Don't appreciate shelling out all this money for junkware...

2 Replies
2 Replies
Posted by Moderator Moderator
Moderator

Re: Teamviewer can't connect to older version??

Hello @afeudale,

Thank you for your message.

You will find all the information about where we are asking our users to update their software here: Enjoy using the best version of TeamViewer we made so far! - How to proceed?

We understand that a dysfunctional might generate some frustration, but I politely ask you to stay respectful towards the hard work our developers and support do every single day. I thank you in advance for respecting our Community guidelines.

Best

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
Posted by afeudale
Trigon

Re: Teamviewer can't connect to older version??

So is this a "forced" upgrade to the latest TV14?

What happens if a user with TV14 is trying to connect into an older version, like v12 above?  It will fail?

TV has always been of the opinion that newer versions should be able to connect into older versions.

Is this another money-grab by TV trying to get everyone on the latest version?