Announcements

********

First Step Guides

********

  1. Are you new to TeamViewer and Home Office and need some help? Check out our FAQ here.
  2. New to the Remote Access Plan? Find our first steps FAQ here.
  3. Are you new to blizz and online meetings or classes and need some help? Check out our FAQ here.

********

Highlighted
Posted by
Electron

Update tries to install wrong version.

I need to fix my sister's macbook remotely.

She is not very computer literate so I wanted to do a dry run here.

A:  Your download page does NOT tell you that downloading version 15 won't install on an older mac.  (Machines concerned are running 10.10.4 TV 15 requires OS-X 10.13.)  This is a bug.

B: If I try using "Check for Updates" from within my older version of TV, it ALSO will try to download version 15. This is a bug.

C:  If I search the Downloads page for older versions, YOU DONT SAY WHICH WILL WORK ON WHICH OS's. This is bad website design.

D:  Nowhere on your website can I find anything that details the tradeoffs of mis-matched versions -- whether they interoperate at all.

At one point you had a version of TV that didn't have to be installed.  You could run it off a thumb drive.  Is this still available?

How do I find out which version of TV a given OS will accept?

Are all versions of TV interoperable?

Are there performance penalties for using differing versions?

1 Reply
1 Reply
Highlighted
Posted by TeamViewer Star
TeamViewer Star

Re: Update tries to install wrong version.

Hi @sgbotsford 

Thank you for contact about your concerns especially these difficult crisis days.

I'd like to inform you about the aspects that you mentioned and I will try to answer all of your worries.

The compatibility list of the operating systems exists in the download page at the bottom right place (please see the screenshot). 

Screenshot 2020-03-26 02.16.34.png

 

If you are using a free version and not licensed, then you must use the last version of the TeamViewer app. Licensed users have many extra features enabled and one of them is to connect between different versions of the app.

If you want to take a look at this related post especialy to the answers of Esther and Youri because they have the full knowledge of the products.

So in the case of a free license, it is logical that your computer must be using the latest version. If it is not compatible with the latest version, then you must change something, either to update the macOS (if it can be updated), either you can buy a license.

The version that does not needs to be installed is the Quick Support app and it is for accepting incoming connections to the computer. You can download it from the website, run the .DMG file and you will see the following screen:

Screenshot 2020-03-26 02.28.40.png

Just double click on the blue icon and it will run the app instead like the following screenshot:

Screenshot 2020-03-26 02.28.51.png

I hope to answer all the questions that you had.

Thank you and best regards

IT Pro