Announcements

TeamViewer 14.5 has been released. See the Change Logs here.

Posted by Ch3z
Henagon

Version backwards compatibility

Hello,

My scenario involves a remote pc with custom OS having teamviewer 5 and cannot upgrade further that team viewer 8.

If i understand correctly,free users cannot connect to a previous than the lastest release,so if i want remote control i have yo buy a license.

My question is if i buy a license for this release(lets say TV5), will i be able to use such a dated release of teamviewer and control remotely the pc? 

 

Thanks!

1 Accepted Solution

Accepted Solutions
Posted by Moderator Moderator
Moderator
Solution

Re: Version backwards compatibility

Hello @Ch3z,

Thank you for your message.

The advantage you have with a paid license is that you can use all versions of TeamViewer that are still functional. This includes obviously also previous versions.

However, even if you buy a license, it is not guaranteed that it will work out for your use case, as the software has to be compatible with the hardware you are using. TeamViewer 5 and 8 are considered as very old and out-dated versions, even though they might run perfectly fine on many devices in the world.

You will find all the information regarding compatibilities you need in our Knowledge Base article here: Which operating systems are supported?

This is only to make sure you get all the information before taking a decision that may involve a financial investment.

I hope this could help.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.
3 Replies
Highlighted
Posted by Moderator Moderator
Moderator

Re: Version backwards compatibility

Hi @Ch3z ,

Thanks for your post.

Please feel free to reach out to our service team to discuss your options directly.

Here is the link to get the phone number or to submit a ticket: https://www.teamviewer.com/en/support/contact/

Thanks a lot and best,

Alena

Spanish Community Moderator

If my reply answered your question, help out other users and click the Accept as a Solution  button below. You can also say thanks by clicking on the Thumbs Up button!
English Community |  Deutsche Community | 日本語コミュニティ |  中文社区 | Communauté française | Comunidad española

2 Replies
Posted by Ch3z
Henagon

Re: Version backwards compatibility

Thank you for your response,

The solution you've provided leads me again either in community or knowledge base the only other option is a ticket to the sales team.

Should i submit a ticket to them?

Thanks again.

Posted by Moderator Moderator
Moderator
Solution

Re: Version backwards compatibility

Hello @Ch3z,

Thank you for your message.

The advantage you have with a paid license is that you can use all versions of TeamViewer that are still functional. This includes obviously also previous versions.

However, even if you buy a license, it is not guaranteed that it will work out for your use case, as the software has to be compatible with the hardware you are using. TeamViewer 5 and 8 are considered as very old and out-dated versions, even though they might run perfectly fine on many devices in the world.

You will find all the information regarding compatibilities you need in our Knowledge Base article here: Which operating systems are supported?

This is only to make sure you get all the information before taking a decision that may involve a financial investment.

I hope this could help.

Cheers

Jean

French Community Moderator
Did my reply answer your question ? Accept it as a solution to help others.
Find this helpful ? Say thanks by clicking on the Thumbs Up button.