Posted by Iamnotanumber
Trigon

no automatic sign in

Good Morning

I have noticed in the past week that some of our computers do not automatically sign into TeamViewer 12...and a physical sign in must be accomplished on screen after logging into windows account. This process is OK when sat at the computer...but what if you are signing into a remote secure computer that has been started by a friend or family member who does not have Admin rights?

The other problem...today I restarted this computer I am using now and had to again open TeamViewer and click "Sign in"...no auto sign in!...and yes I do have admin rights on this computer. I can find no reference to any posts with this problem.

Thanks for any help

1 Accepted Solution

Accepted Solutions
Posted by TechGuy56
Tetragon
Solution

Re: no automatic sign in

I have 2 suggestions for you. First go to the Options/ General settings and make sure that "Start Teamviewer with Windows" is selected, see 1st image for reference.

Next go to Options/ Advanced and scroll down until you see "More" almost all the way to the bottom and select "Disable Teamviewer Shutdown" (image item 1), while there look at "Teamviewer Options" and make sure that "Changes require administrative rights on this computer" (Image item 2) isn't selected. See the 2nd image for reference.

If you have those settings set, Teamviewer will start whenever you start windows and it won't get turned off so you will always have access to it.Teamviewer-start-with-computer

 Teamviewer-disable-shutdown

 

 

 

Mike Crabill
10 Replies
Posted by TechGuy56
Tetragon
Solution

Re: no automatic sign in

I have 2 suggestions for you. First go to the Options/ General settings and make sure that "Start Teamviewer with Windows" is selected, see 1st image for reference.

Next go to Options/ Advanced and scroll down until you see "More" almost all the way to the bottom and select "Disable Teamviewer Shutdown" (image item 1), while there look at "Teamviewer Options" and make sure that "Changes require administrative rights on this computer" (Image item 2) isn't selected. See the 2nd image for reference.

If you have those settings set, Teamviewer will start whenever you start windows and it won't get turned off so you will always have access to it.Teamviewer-start-with-computer

 Teamviewer-disable-shutdown

 

 

 

Mike Crabill
Posted by Iamnotanumber
Trigon

Re: no automatic sign in

Hi TechGuy56

Thanks for your input. I found the tick already in place in caption 1

Tick was missing 'Advanced/More' Disable Shutdown and also missing from admin requirements. in caption 2

I have ticked 'Disable shutdown' and will check the results the next time I reboot...and check other computers when powered ON & logged in. Thanks again.

 

Posted by TechGuy56
Tetragon

Re: no automatic sign in

Hi Iamnotanumber

That's good, what usually happens is a person will open Teamviewer while the computer is on and then they either disable it, thinking they are minimizing, but actually closing it, or it gets closed inadvertently somehow. With shutdown disabled and starting with windows set, it's not able to be closed without using the task manager and always available. Hopefully that will take care of your problem.

Good luck! Mike

Mike Crabill
Posted by Iamnotanumber
Trigon

Re: no automatic sign in

Update:

Today(04/15/17) TeamViewer again refuses to load with windows log in. I looked at msconfig and there is a tick to the left of TeamViewer address, but to the right of the address it states "STOPPED". So I have deleted TeamViewer and rebooted and reinstalled Teamiewer again. Set up the app by signing in and rebooted the computer with exactly the same reoccuring fault...WIll not load when windows starts.

In the program window I see my "Start TeamViewer with windows", blue and a tick to the left..."Assign device to account" is grayed as is "Grant easy access". I rechecked the options mentioned by TechGuy56 and they remain the same! I have even removed and readded the computer to TeamViewer program

Posted by TechGuy56
Tetragon

Re: no automatic sign in

Hello,

Open the Services.msc by going to the search on the toolbar and typing Services, you will see a shortcut to the Services app, select it, then scroll down to Teamviewer and make sure it's running and also set to "automatic" instead of manual. That most likely is your problem.

See attached image:

Services-Teamviewer.png

Mike Crabill
Highlighted
Posted by Iamnotanumber
Trigon

Re: no automatic sign in

Hello TechGuy56 again

The service app states that TeamViewer is already set to automatic as shown in your snip

I have discovered that even though I am signed into the computer as administrator, I do not have admin privileges to assign this new install to my account??? I think that is why the area on the left is grayed out..."Assign device to account"

TeamV.PNG

3 Replies
Posted by TechGuy56
Tetragon

Re: no automatic sign in

Ok, that adds a little more info to the mix, are you signed in with a Microsoft account? Here is a link to how to add admin priveledges to your program and have the "User  Account Control" setup correctly. You may have other programs that you find aren't configured correctly, if so this will helo you get everything setup correctly.  https://answers.microsoft.com/en-us/windows/forum/windows_7-security/how-to-give-admin-rights-for-sp...

On the off chance that isn't your problem, here are some other items you can check to rectify the situation. You can also look at this previous post regarding assigning a device to your Teamiewer account. This may shed some more light on the issue. Also in the services.msc can you right click on Teamviewer and select properties. If you can look at the "Logon" tab and check the setting there. I included a screenshot from my computer for reference. Depending on the setting you may have to include your logon info to this tab to get full priviledges.

I just though of one other thing you could try, at an elevated command prompt you could enter: net start "teamviewer" to get it running if it sshows stopped instead of running.

I know I provided a lot but I believ in covering all bases in the off-chance the first item doesn't do the job. Let me kow how you make out and we'll get your problem cleared upone way or another!

TechGuy56

Teamviewer-services-account

Mike Crabill
Posted by Iamnotanumber
Trigon

Re: no automatic sign in

Hi TechGuy56

I decided to cut my losses and I grabbed an image from a week after purchase(September 2015/TeamViewer 10) with all our Programs/Apps already installed. Updated all the software; All our data is stored with various cloud services, so that was not an issue and TeamViewer is working as advertised.

I believe we had software issues as start up and running of the device is so much faster now

Thank you for all your help and input

Stu

Posted by TechGuy56
Tetragon

Re: no automatic sign in

Great! I'm glad you have it resolved. Going back was definitely a good solution, as startup appears to have been an obvious symptom of deeper problems. Good job!

Best Wishes!
TechGuy56

Mike Crabill
Posted by HamRichards
Henagon

Re: no automatic sign in

Where is "Disable TeamViewer shutdown" in TeamViewer 11.0.73955 (Mac OS X 10.11.06)?