Posted by JuanmaFraga
Henagon

ITbrain Bakckup activation failed (code 14)

Hello,

I'm trying to activate ITbrain Backup in a Windows 7 pc, but  I get error code 14 every time.

I've tried to disable windows firewall, running TeamViewer as Administrator, but I still get the same error.

6 Replies
Posted by Former Staff Celestin
Former Staff

Re: ITbrain Bakckup activation failed (code 14)

Hello JuanmaFraga

Thank you for your message .

Please have a look here to be sure that your operating system is supported. If the issue persists contact your support.

https://community.teamviewer.com/t5/ITbrain-Knowledge-Base/Which-operating-systems-are-supported-for...

Thank you for your interest in ITbrain Backup.

 

Posted by mrjoetate
Trigon

Re: ITbrain Bakckup activation failed (code 14)

I have a supported OS that had IT Brain backup running and then failed for no reason.  I have tried to reinstall and even completely removed/reinstalled teamveiwer trying to get IT Brain backup working but it still fails.  It's 2+ years old and still acts like a 2 month old pre-alpha product... any idea when you'll get basic installation failures resolved and stability issues resolved?

Posted by mrjoetate
Trigon

Re: ITbrain Bakckup activation failed (code 14)

Their support is absolutely horrible, I wouldn't waste your time.  You are better to just spend time figuring it out yourself or switch products. I use them for a very select few people who want cheap backups and don't want to pay licensing for decent software and I make them all sign waivers understanding they're getting the most inferior online backup in existance (I actually tell them all to use Google Drive, as it's free and better, and take a firm "no" before I allow them to buy this off of me).

Bottom line, their support expects everyone to have a 2nd grade education and ends everything with "it seems like that is a problem we plan on having fixed soon"... and then they never fix the problems.  

Posted by mrjoetate
Trigon

Re: ITbrain Bakckup activation failed (code 14)

Alright, got it figured out on my end here... force kill the program, uninstall, then MANUALLY DELETE "%PROGRAMDATA%\ITBRAIN" because removing the program doesn't delete that directory... wtg with poor uninstallers guys.  Anyway, installed and working again.

Hopefully this helps someone else, cheers

Highlighted
Posted by Remote Management Staff
Remote Management Staff

Re: ITbrain Bakckup activation failed (code 14)

Hi @mrjoetate

Thanks for posting your findings on how you solved this situation. 

Currently, we are looking into improving the error messages and the current behaviour for installation errors.

At this moment if the Backup installation will not finish successfully it will try to uninstall all components. As you discovered some parts remain behind.  After a reboot, all of them get cleaned and a new installation is possible. We will improve the install logic as well in order to have better results and allow users to try again if it will fail the first time.

If you encountered any other issues during your use of ITbrain Backup or other ITbrain Services please let us know and we could schedule an interview to discuss them and see how we can improve in the future.

 

Product Owner, Remote Management services.
Posted by mrjoetate
Trigon

Re: ITbrain Bakckup activation failed (code 14)

This is still an issue... resolution is still the same... just figured I'd repeat the "they never fix bugs" comment here.  Just ran into this issue again and found I had posted the solution to it myself... Hah!  The above solution worked, again, to resolve this for me and restarting did nothing to help (like the IT Brain person suggested it might in the previous post).