Highlighted
Posted by Sc0tTy
Digon

Fix your support process

Hi,

Today I had to request support from you guys, sadly that wasn't easy.

Firstly, the submit ticket page on the website doesn't work: when I submit my ticket the site just crashes and I loose all my input.
(A usability fix would also be to load my details from the profile)

Secondly when I tried calling the support number and after selecting the support option. A robot told me that "all your representatives where busy and I had to try later" and then hung up the phone. It would be nice if there was a wait system.

I now opened a post on this community page where hopefully somebody will read and help me with my issue...

I was very surprised that for such a well known tool the support process is so bad.H
opefully you will do something with my feedback, I'm a software developer and have to provide a lot of support myself.

With kind regards,
Robin

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by Community Manager
Community Manager
Solution

Re: Fix your support process

@Sc0tTy Thank you for your fast responds.

I forwarded the information internally to the person in charge and I am happy to hear, that it is working now. 

As the Community Manager, let me say: You are always welcome to post your question in our Community :-)

Enjoy your weekend and all the best, Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

View solution in original post

3 Replies
Posted by Community Manager
Community Manager

Re: Fix your support process

Hi @Sc0tTy

Thank you for reporting the issue.

May I ask you to give us some more information in regards to the submit a ticket issue?

We would need:

  • Which browser did you use?
  • Which URL did you enter?
  • From which country are you entering the support page and which language is your browser using?
  • Did you try to attach an attachement?
  • If possible: Can you provide a screenshot of the error?

Thank you for your help and your patience!

Best, Esther

 

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

2 Replies
Highlighted
Posted by Sc0tTy
Digon

Re: Fix your support process

Hi @Esther,

Offcourse!

Using Microsoft Edge from The Netherlands and I tried with and without attachments.
Though I tried both the Dutch and English versions of the site


https://www.teamviewer.com/nl/support/contact/submit-a-ticket
https://www.teamviewer.com/en/support/contact/submit-a-ticket

I've tried recreating my ticket but it seems its working now :|
(You have received several fake tickets now).

The error I received was a generic "Something went wrong" error.

Highlighted
Posted by Community Manager
Community Manager
Solution

Re: Fix your support process

@Sc0tTy Thank you for your fast responds.

I forwarded the information internally to the person in charge and I am happy to hear, that it is working now. 

As the Community Manager, let me say: You are always welcome to post your question in our Community :-)

Enjoy your weekend and all the best, Esther

Community Manager

Did my reply answer your question? Accept it as a solution to help others.
Find this helpful? Say thanks by clicking on the Thumbs Up button. Find more information here: Knowledge Base | Community Blog | How to get started

View solution in original post