Announcements

Shape the future of your TeamViewer product with our Product Team. Click here to join!

Posted by Jeromekk
Photon

AD Connector issue

Hello,

I am trying to set up the AD Connector but i get and error message either by running the bat file or the Invoke-Configuration.ps1 file.

The bat file closes itself and nothing happens.

When i try to run it from the powershell ISE :

Configure TeamViewer AD Connector.bat :  AuthorizationManager check failed.
At line : 1 Caractère : 2
+ & <<<<  '.\Configure TeamViewer AD Connector.bat'
    + CategoryInfo          : NotSpecified: (Échec de la vér...izationManager.:String) [], RemoteException
    + FullyQualifiedErrorId : NativeCommandError
 
At line : 1 Caractère : 52

+ & {.\TeamViewerADConnector\Invoke-Configuration.ps1 <<<<  ; exit $LastExitCod

e }

    + CategoryInfo          : NotSpecified: (:) [], PSSecurityException

    + FullyQualifiedErrorId : RuntimeException

 

When running the PS1 file i get this :

Impossible to link argument to  parameter « Path », because it has a Null value.
In D:\TMV\TeamViewerADConnector\Invoke-Configuration.ps1 : 28 Caracter : 36
+     $ConfigurationFile = (Join-Path <<<<  $PSScriptRoot "TeamViewerADConnector.config.json"),
    + CategoryInfo          : InvalidData: (:) [Join-Path], ParentContainsErrorRecordException
    + FullyQualifiedErrorId : ParameterArgumentValidationErrorNullNotAllowed,Microsoft.PowerShell.Commands.JoinPathCommand

 

My ISE is in french so i have somewhat translated in english, i put the modified text in Italic.

1 Reply
1 Reply
Posted by BTB
Henagon

Re: AD Connector issue

Same problem here.
The exact error in English is:

Join-Path : Cannot bind argument to parameter 'Path' because it is null.
At C:\Users\Tomas\Desktop\TeamViewer_AD_Connector\TeamViewerADConnector\Invoke-Configuration.ps1:28 char:36
+ $ConfigurationFile = (Join-Path <<<< $PSScriptRoot "TeamViewerADConnector.config.json"),