Compatibility with older operating systems

0% helpful (0/1)

You can easily use TeamViewer on older operating systems as well

Please refer to the description below on how to remotely control a computer with an older operating system and how to join a meeting/presentation when working from or involving one of these platforms.

Mac OSX 10.6

Remote control one of these operating systems:
Please execute TeamViewer 9 QuickSupport or install the TeamViewer 9 full version on the computer you want to control remotely. It is now possible to connect to this computer using your TeamViewer 9 (or higher).

Participate in a meeting under these operating systems:
The complete meeting must be held in TeamViewer 9 (or higher). The presenter needs to start TeamViewer 9 full version (or higher) and any participants need to start TeamViewer 9 QuickJoin. If any other TeamViewer full- or Host version is installed, please make sure it is closed before launching.

Windows 2000 / Windows Server 2000 / Mac OSX 10.5

Remote control one of these operating systems:
Please execute TeamViewer 8 QuickSupport or install the TeamViewer 8 full version on the computer you want to control remotely. It is now possible to connect to this computer using your TeamViewer 8 (or higher).

Participate in a meeting under these operating systems:
The complete meeting must be held in TeamViewer 8 (or higher). The presenter needs to start TeamViewer 8 full version (or higher) and any participants need to start TeamViewer 8 QuickJoin. If any other TeamViewer full- or Host version is installed, please make sure it is closed before launching.

Windows 98, Windows ME or Windows NT / Mac OSX 10.4

Remote control one of these operating systems:
Please execute TeamViewer 6 QuickSupport or install the TeamViewer 6 full version on the computer you want to control remotely. It is now possible to connect to this computer using your TeamViewer 6 (or higher).

Participate in a presentation under these operating systems:
The complete presentation must be held in TeamViewer 6. The presenter needs to start TeamViewer 6 full version and any participants need to start TeamViewer 6 QuickJoin. If any other TeamViewer full- or Host version is installed, please make sure it is closed before launching. A quick guide on how to start a presentation using version 6 can be found under: First steps presentation (PDF).

TeamViewer Web-Connector, TeamViewer Portable, and TeamViewer Host are not compatible with Windows 98, ME, or NT.

Version history
Revision #:
1 of 1
Last update:
‎13 Mar 2017, 10:34 AM
Updated by:
 
Contributors