Announcements

Did you already try the new Windows 10 October 2020 Update?


Share your feedback and experience with TeamViewer on the new Windows build with our developers here.

Highlighted
Posted by
Henagon

Teamviewer don't start on Debian stretch/testing

Hello,

The application don't start and display only in terminal:

Init...
Checking setup...
Launching TeamViewer ...

 

This is the /opt/teamviewer9/logfiles/TeamViewer9_Logfile.log

[The logfle has been removed as per the community guidelines.]

It is a xauth problem?

Thank you in advance.

5 Replies
5 Replies
Highlighted
Posted by
Henagon

Re: Teamviewer don't start on Debian stretch/testing

Ok I complete with the wine.log

vim ~/.config/teamviewer9/logfiles/winelog

 

fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
fixme:service:scmdatabase_autostart_services Auto-start service L"PlugPlay" failed to start: 2
wine: configuration in '/home/ebr/.config/teamviewer9' has been updated.
fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),0,3,(nil),0,(nil)) - stub!
fixme:heap:HeapSetInformation (nil) 1 (nil) 0
fixme:process:SetProcessDEPPolicy (3): stub
fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
fixme:resource:GetGuiResources (0xffffffff,0): stub
fixme:win:EnumDisplayDevicesW ((null),0,0x32f724,0x00000000), stub!
fixme:win:EnumDisplayDevicesW (L"\\\\.\\DISPLAY1",0,0x32f3dc,0x00000000), stub!
fixme:win:EnumDisplayDevicesW ((null),1,0x32f724,0x00000000), stub!
fixme:ntdll:NtQueryInformationToken QueryInformationToken( ..., TokenElevation, ...) semi-stub
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x40c040c, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x40c040c, 0000: semi-stub!

And when I launch manually Teamviewer inaty like this:

/opt/teamviewer9/tv_bin/wine/bin$ ./wine ../drive_c/TeamViewer/TeamViewer.exe

It appear a dialog box with messages: could not load ... tvwine.dll.so

Anyone can help please?

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Teamviewer 9 doesn't start on Debian stretch/testing

May I ask why you are trying to run a 3-year-old TeamViewer release on a bleeding-edge distribution? We do not support that. I'd recommend to uninstall this version and install TeamViewer 12.

You can either use the new (wine-free!) TeamViewer HOST, or the full package. You can get them here: TV Download Linux

Linux Developer
Highlighted
Posted by
Henagon

Re: Teamviewer 9 doesn't start on Debian stretch/testing

Hello,

I have open a Ticket (ID: 3175774). I need this version because our licenses are in version 9 for my enterprise.

TV12 not work too (but TV10 is ok!).

 

Highlighted
Posted by
Electron

Re: Teamviewer 9 doesn't start on ubuntu 18.04 lts

hi

im using teamviewer9 paid version. when ever i start teamviewer in my UBUNTU 18.04

its not working. if i run it from terminal with root privilages the i can see this log...

2018/07/10 18:28:52.747  Session Information provided by systemd
2018/07/10 18:28:52.747  XSocketSessionObserver: watching /tmp/.X11-unix
2018/07/10 18:28:52.782  Unable to get XAuth for :1024
2018/07/10 18:28:52.782  XSession: Unable to open XAuthority file ""
2018/07/10 18:28:52.811  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.811  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.811  systemd: no active session found for display :1024, assuming login screen
2018/07/10 18:28:52.811  systemd: no active session found for display :1024, assuming login screen
2018/07/10 18:28:52.812  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.812  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.812  DBus: expected optional property DefaultControlGroup not found
2018/07/10 18:28:52.812  DBus: expected optional property KillProcesses not found
2018/07/10 18:28:52.814  XSocketSessionObserver: thread_interrupted
2018/07/10 18:28:52.814  TVGuiSlave: Running
2018/07/10 18:28:52.814  XClipboard: Plain data for 'CLIP_TEMPORARY'
2018/07/10 18:28:52.814  Audio: PulseAudio enabled
2018/07/10 18:28:52.815  PulseAudio: Connected to server 'unix:/run/user/1000/pulse/native' (protocol version 32, library version 11.1.0
2018/07/10 18:28:52.815  PulseAudio: Connection established
2018/07/10 18:28:52.815  PulseAudio: Exit main loop (0), err=-2
2018/07/10 18:28:52.815     8    21 G0   Slave connected to GUI master
2018/07/10 18:28:52.989     8     9 G0!!!CRASH: Saved dump file to '/opt/teamviewer9/logfiles/TeamViewer_9_0_32150__20180710T182852.mdmp'
Highlighted
Posted by
Henagon

Re: Teamviewer 9 doesn't start on ubuntu 18.04 lts

Any solution found?