Posted by Arjai
Henagon

3 identical computers...2 not online

I have 3 i3's crunching numbers for WCG.

I just switched to 18.3 Mint and now, only the hardlined computer shows online. In fact, I am writing this on a computer that TV is running on but, does not show to be online. My internet connection to the two wireless machine's is strong. All three are fresh install's (OS, BOINC, TV).

All three have 13.0.9865

My laptop, that I monitor these 3 i3's from, all in the same room, next to the router, is using 13.1.1548 and is running Win 8.1.

Even on this computer, that I can remote to my laptop, is shown offline! I cannot remote to this computer from any of them, same thing with the other computer running of wifi.

I had no problems, with this in 12. But my laptop upgraded to 13 and I decided to upgrade the 3 i3 Mint Crunchers so I could remote to them again...13 would not open 12...

I have only 1 monitor for these three machines and primarily remote in to them, now I can only do that with the Lan lined one.

Why are these 2 wifi machines showing as offline, both are currently runing TV with green, "Ready to Connect" Thanks, for any help, in advance.

P.S. I am running the personal use version, and I am a newbie with Linux, for the most part.

1 Accepted Solution

Accepted Solutions
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: 3 identical computers...2 not online

As said, please install the update.
Sorry, that should not have been a link... It's a command, to be executed as root:

teamviewer daemon restart

Reasons why those machines might appear to be offline:

  • no user logged in and "start with system" not enabled
  • "start with system" enabled, but log-in screen is running on Wayland

In the latter case, have a look at State of Wayland & TeamViewer

Cheers,
Daniel

Linux Developer
1 Reply
6 Replies
Posted by Arjai
Henagon

Re: 3 identical computers...2 not online

2018/03/17 12:17:13.652 5510 140264474655872 S! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!
2018/03/17 12:17:13.653 5510 140264474655872 S UpdateOnlineState newOnlineValue 0
2018/03/17 12:17:13.653 5510 140264474655872 S+ tvnetwork::Offline: online state 0
2018/03/17 12:17:13.653 5510 140264474655872 S! AsioSettings::FindExternalIP: found 0 external IPs instead of 1!

This was in the TV Log file on one of the problem pc's

how do I help it find an external IP?

Posted by TeamViewer Staff
TeamViewer Staff

Re: 3 identical computers...2 not online

Are all three devices showing different TeamViewer IDs?
If the status says "green", then they should actually be online. Please update to the latest version. [Update: 13.1.3026] Spring Update

If that fixes it but the problem comes back, a temporary solution is to restart the background service: teamviewer daemon restart.

Best regards,
Daniel

Linux Developer
Posted by Arjai
Henagon

Re: 3 identical computers...2 not online

Sorry, but I don't understand.

How do I do that restart?

Can I just click that link, while on the linux machine?

BTW, they are all now hard lined to my new router. still no difference. Next time I will have time to monkey with them is next Monday...

 

 

Posted by Arjai
Henagon

Re: 3 identical computers...2 not online

Yes, all three have seperate ID's
Laptop is 13.1.369?
i3's are 13.09865
Highlighted
Posted by TeamViewer Staff
TeamViewer Staff
Solution

Re: 3 identical computers...2 not online

As said, please install the update.
Sorry, that should not have been a link... It's a command, to be executed as root:

teamviewer daemon restart

Reasons why those machines might appear to be offline:

  • no user logged in and "start with system" not enabled
  • "start with system" enabled, but log-in screen is running on Wayland

In the latter case, have a look at State of Wayland & TeamViewer

Cheers,
Daniel

Linux Developer
1 Reply
Posted by Arjai
Henagon

Re: 3 identical computers...2 not online

I got one to work. Just need more time to get the others updated. Thanks a lot!!