Posted by zzc_actual
Henagon

How to install TeamView Host for Raspberry Pi 3?

I want to install TeamView Host on Raspberry Pi 3 (Debian 8, ARM, 32-bit), but I meet some problems.

The manual shows that:

------------------------------------------------------------------------------------------------------------------------

Debian, Mint, Ubuntu, Kubuntu, Xubuntu…

For modern DEB-systems (32/64-bit) you need the teamviewer_i386.deb package.

For installing TeamViewer, we recommend using the graphical installer, as described above.

Installation via command line

If you prefer to use the command line, or if there is no graphical installer available, you can use one of these commands as an administrator: 

apt install teamviewer_12.0.xxxxx_i386.deb 

Older systems (Ubuntu 14.04, Debian 7 and below)

Run this command:

dpkg -i teamviewer_12.0.xxxxx_i386.deb 

In case dpkg indicates missing dependencies, complete the installation by executing the following command:

apt-get install -f 

Older 64-bit DEB-systems without Multiarch (Ubuntu 12.03, Debian 6 and below)

Download the teamviewer_amd64.deb package.

To install, use dpkg and apt-get as described above.

Notes on Multiarch: On newer 64-bit DEB-systems with Multiarch-support (Debian 7), teamviewer_linux_x64.deb cannot be installed because the package ia32-libs is not available anymore on these systems. In this case you can use teamviewer_12.0.xxxxx_i386.deb instead.

In case you get the error “wrong architecture i386” you have to execute the following command lines as an administrator:

dpkg --add-architecture i386 
apt-get update 

For further information: http://wiki.debian.org/Multiarch/HOWTO

------------------------------------------------------------------------------------------------------------------------

Here are problems:

Method #1

root@raspberrypi:~ # apt install ./teamviewer-host_12.1.83885_armhf.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'teamviewer-host' instead of './teamviewer-host_12.1.83885_armhf.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
teamviewer-host : Depends: libqt5qml5 (>= 5.2.1) but it is not going to be installed
Depends: libqt5quick5 (>= 5.2.1) but it is not going to be installed
Depends: libqt5webkit5 (>= 5.1.1) but it is not going to be installed
Depends: qtdeclarative5-qtquick2-plugin (>= 5.2.1) but it is not installable or
qml-module-qtquick2 (>= 5.2.1) but it is not going to be installed
Depends: qtdeclarative5-controls-plugin (>= 5.2.1) but it is not installable or
qml-module-qtquick-controls (>= 5.2.1) but it is not going to be installed
Depends: qtdeclarative5-dialogs-plugin (>= 5.2.1) but it is not installable or
qml-module-qtquick-dialogs (>= 5.2.1) but it is not going to be installed
Depends: qtdeclarative5-window-plugin (>= 5.2.1) but it is not installable or
qml-module-qtquick-window2 (>= 5.2.1) but it is not going to be installed
Depends: qtdeclarative5-quicklayouts-plugin (>= 5.2.1) but it is not installable or
qml-module-qtquick-layouts (>= 5.2.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
root@raspberrypi:~ #

Method #2

root@raspberrypi:~ # dpkg -i teamviewer-host_12.1.83885_armhf.deb
Selecting previously unselected package teamviewer-host.
(Reading database ... 124575 files and directories currently installed.)
Preparing to unpack teamviewer-host_12.1.83885_armhf.deb ...
Unpacking teamviewer-host (12.1.83885) ...
dpkg: dependency problems prevent configuration of teamviewer-host:
teamviewer-host depends on libqt5qml5 (>= 5.2.1); however:
Package libqt5qml5 is not installed.
teamviewer-host depends on libqt5quick5 (>= 5.2.1); however:
Package libqt5quick5 is not installed.
teamviewer-host depends on libqt5webkit5 (>= 5.1.1); however:
Package libqt5webkit5 is not installed.
teamviewer-host depends on qtdeclarative5-qtquick2-plugin (>= 5.2.1) | qml-module-qtquick2 (>= 5.2.1); however:
Package qtdeclarative5-qtquick2-plugin is not installed.
Package qml-module-qtquick2 is not installed.
teamviewer-host depends on qtdeclarative5-controls-plugin (>= 5.2.1) | qml-module-qtquick-controls (>= 5.2.1); however:
Package qtdeclarative5-controls-plugin is not installed.
Package qml-module-qtquick-controls is not installed.
teamviewer-host depends on qtdeclarative5-dialogs-plugin (>= 5.2.1) | qml-module-qtquick-dialogs (>= 5.2.1); however:
Package qtdeclarative5-dialogs-plugin is not installed.
Package qml-module-qtquick-dialogs is not installed.
teamviewer-host depends on qtdeclarative5-window-plugin (>= 5.2.1) | qml-module-qtquick-window2 (>= 5.2.1); however:
Package qtdeclarative5-window-plugin is not installed.
Package qml-module-qtquick-window2 is not installed.
teamviewer-host depends on qtdeclarative5-quicklayouts-plugin (>= 5.2.1) | qml-module-qtquick-layouts (>= 5.2.1); however:
Package qtdeclarative5-quicklayouts-plugin is not installed.
Package qml-module-qtquick-layouts is not installed.

dpkg: error processing package teamviewer-host (--install):
dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
teamviewer-host
root@raspberrypi:~ #
root@raspberrypi:~ # apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
teamviewer-host
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 46.3 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 124674 files and directories currently installed.)
Removing teamviewer-host (12.1.83885) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for gnome-menus (3.13.3-9) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
root@raspberrypi:~ #

So what should I do?

5 Replies
Posted by zzc_actual
Henagon

Re: How to install TeamView Host for Raspberry Pi 3?

I got it!

TeamViewer Host depends on some package of qt, and my Raspberry Pi 3 fails to install them because of some serious dependence problems. So it is impossiple for me to install TeamViewer Host on Raspberry Pi 3.

Posted by zzc_actual
Henagon

Re: How to install TeamView Host for Raspberry Pi 3?

Could you provide the static compilation version of TeamViewer Host (with all dependence in) for Linux to solve this problem?

Posted by keziah
Henagon

Re: How to install TeamView Host for Raspberry Pi 3?

Hey, I ran into this issue too. After running

> dpkg -i teamviewer-host_armhf.deb

I hit the issue you described with dependencies. 
I managed to get through the install by doing the following:

> sudo apt install qt5-default

This returned: 

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 qt5-default : Depends: qtbase5-dev but it is not going to be installed
               Depends: qtchooser (>= 55-gc9562a1-1~) but it is not going to be installed
 teamviewer-host : Depends: libqt5gui5 (>= 5.2) but it is not going to be installed
                   Depends: libqt5widgets5 (>= 5.2) but it is not going to be installed
                   Depends: libqt5qml5 (>= 5.2) but it is not going to be installed
                   Depends: libqt5quick5 (>= 5.2) but it is not going to be installed
                   Depends: libqt5dbus5 (>= 5.2) but it is not going to be installed
                   Depends: libqt5webkit5 (>= 5.1.1) but it is not going to be installed
                   Depends: libqt5x11extras5 (>= 5.2) but it is not going to be installed
                   Depends: qtdeclarative5-qtquick2-plugin (>= 5.2) but it is not installable or
                            qml-module-qtquick2 (>= 5.2) but it is not going to be installed
                   Depends: qtdeclarative5-controls-plugin (>= 5.2) but it is not installable or
                            qml-module-qtquick-controls (>= 5.2) but it is not going to be installed
                   Depends: qtdeclarative5-dialogs-plugin (>= 5.2) but it is not installable or
                            qml-module-qtquick-dialogs (>= 5.2) but it is not going to be installed
                   Depends: qtdeclarative5-window-plugin (>= 5.2) but it is not installable or
                            qml-module-qtquick-window2 (>= 5.2) but it is not going to be installed
                   Depends: qtdeclarative5-quicklayouts-plugin (>= 5.2) but it is not installable or
                            qml-module-qtquick-layouts (>= 5.2) but it is not going to be installed
                   Recommends: ttf-liberation but it is not going to be installed or
                               fonts-liberation but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

 

Following the error on the screen, I did the following:
> apt --fix-broken install

This allowed me to get all the dependencies, and then I was able to run the dkpg -i on the .deb again, and it installed successfully. 

I don't know for sure that the qt5-default attempt was necessary, but those are the steps I used. I hope this helps someone!

Highlighted
Posted by TeamViewer Staff
TeamViewer Staff

Re: How to install TeamView Host for Raspberry Pi 3?

@keziah, @zzc_actual, I don't know what you have done to your systems, but generally speaking all those dependencies should be resolvable without any problems on Debian 8 / Raspbian 8.

@zzc_actual you might follow keziah's way and try to install Qt manually. The output should tell you what's wrong.

Best regards,

Daniel

Linux Developer
Posted by rcampbellnc
Photon

Re: How to install TeamView Host for Raspberry Pi 3?

Thanks for posting about doing the qt5-default install! I have a recent pi 3B+ and could not get teamviewer-host 14 installed, but after installing qt5-default, BAM, installed without any further issue.