Announcements
Posted by TimRiker
Electron

No input running Xorg

Running:

$ teamviewer info
 TeamViewer                           14.0.14470  (DEB)
 TeamViewer ID:                        xxxxxxx
 teamviewerd status                   ● teamviewerd.service - TeamViewer remote control daemon
   Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-12-14 13:39:57 MST; 44min ago
  Process: 26232 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
 Main PID: 26234 (teamviewerd)
    Tasks: 30 (limit: 4915)
   CGroup: /system.slice/teamviewerd.service
           ├─14172 --IPCport 5943
           └─26234 /opt/teamviewer/tv_bin/teamviewerd -d
Dec 14 13:39:56 slick systemd[1]: Starting TeamViewer remote control daemon...
Dec 14 13:39:56 slick systemd[1]: teamviewerd.service: Can't open PID file /var/run/teamviewerd.pid (yet?) after start: No such file or directory
Dec 14 13:39:57 slick systemd[1]: Started TeamViewer remote control daemon.

I can connect to the machine while it's running Xorg lightdm lightdm-gtk-greeter but no mouse or keyboard input works.
if I switch to a virtual console, by running chvt 2 or similar, keyboard input works there.
What am I missing? How do I know if teamviewer is correctly seeing Xorg?

1 Reply
1 Reply
Posted by TimRiker
Electron

Re: No input running Xorg

Note: It does not appear to be a a client issue. I can connect and control other hosts. I can connect to this same box from windows or from another linux box, with the same result. Mouse clicks on menu do nothing, keyboard can't type. switching to a bare console remotely and I can type there.