Announcements

Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by iadegesso
Henagon

Re: teamviewer 12.0.85001 UI doesn't start on Gentoo

Not only teamviewer12 but also any previous version doesn't show any kind of GUI

3 Replies
3 Replies
Posted by TeamViewer Staff
TeamViewer Staff

Re: teamviewer 12.0.85001 UI doesn't start on Gentoo

Dear iadegesso,

Thank you for contacting TeamViewer.

To be able to troubleshoot your issue, May you please describe your system.

Please include if you're using X or WayLand, Display Manager and Desktop Environment.

This information will help us understand better your issue.

We are looking forward to your comments.

 

Best regards,

Christian

Did my reply answer your question? Accept it as a solution to help others, Thanks.
Posted by DanielT
Photon

Re: teamviewer 12.0.85001 UI doesn't start on Gentoo

I had the same issue on Gentoo.

Two things to make sure:

1. run "tv-setup checklibs" from inside the teamviewer folder, this checks if all required libraries are in place. On Gentoo, you have to manually install some 32bit versions.

2. Teamviewer/Wine doesn't run with freetype > 2.8. If you have the current ~ version installed (2.8.1), it won't open the GUI. A downgrade will solve this.

 

So this goes to the devs here: This is probably a wine issue. Can we expect a TV version which is compatible to a recent freetype lib?

Cheers,
Daniel

Posted by iadegesso
Henagon

Re: teamviewer 12.0.85001 UI doesn't start on Gentoo

Hi,

I solved upgrading Wine to the 2.18 version with staging pathes.

 

Thx a lot

 

Iade