Announcements

Shape the future of the TeamViewer product with our Product Team. Click here to join!

Posted by Wintermute
Digon

Teamviewer 14 not working on Ubuntu 14.04 64

Here's the output when I start teamviewer 14 from the CLI: 

olivier@adm-dev:~/Téléchargements$ teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
terminate called after throwing an instance of 'boost::wrapexcept<boost::uuids::entropy_error>'
what(): getrandom
/opt/teamviewer/tv_bin/script/tvw_exec : ligne 38 : 5485 Abandon (core dumped) "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...

In spite of what's displayed at the end, there's no GUI launched. 

What's the problem ?

 

 

16 Replies
Posted by BusHost
Photon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

have the same problem on Linux Mint 18

Posted by dom-theory
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Same issue. Did you ever get a response?

Posted by digitalmaciek
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

same problem on centos 7.2

Linux  3.10.0-327.el7.x86_64 #1 SMP Thu Nov 19 22:10:57 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

 

any help would be appreciated

Posted by dossgenny007
Photon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

As it is not working on the Ubuntu, it is also not working in my Windows as well. But can it be due to the Error code 2000-0151 which might have occurred in my device? What can be the solution for such an error?

Posted by TommyTang168
Photon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

I got the same problem. No solutions can be found. I am using Centos 7. Had to upgrade to Teamviewer 14 because can no longer use Teamviewer 12 that was working perfectly fine.

$ teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
terminate called after throwing an instance of 'boost::wrapexcept<boost::uuids::entropy_error>'
what(): getrandom
/opt/teamviewer/tv_bin/script/tvw_exec: line 38: 32633 Aborted (core dumped) "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...
Aborted (core dumped)

Posted by OnTheiPhone
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

I'M EDITING THIS ANSWER AFTER THE POST FROM @Wintermute . PLEASE DO NOT CONSIDER THIS AS A REAL SOLUTION. 

sudo teamviewer repo preview

sudo apt-get update

sudo apt-get upgrade 

.... Unpacking teamviewer (14.4.1688) over (14.3.4730) ...

teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

 

and here we gooo

 

Posted by Wintermute
Digon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Thank you for your help. 

Unfortunately, that's not working either.

Firstly, the right command order is not "sudo apt-get upgrade sudo apt-get update", but "sudo apt-get update sudo apt-get upgrade".

Secondly, though running teamviewer with "teamviewer" ends up with "Launching TeamViewer GUI ..." there's no actual teamviewer client running, nor any related icon. Furthermore there is now a process called "/opt/teamviewer/tv_bin/teamviewerd -f" that cannot be killed (keeps on respawning). 

Also when trying to launch '/opt/teamviewer/tv_bin/Teamviewer" directly, it complains about a missing library "./TeamViewer: error while loading shared libraries: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory"

So no, here we don't go at all... :s

Posted by OnTheiPhone
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

you are right @Wintermute . I've gone too fast with the enthusiasm :-( 

The only thing I can add here is that the log files suggest something wrong with the Qt libs and some plugin such as TVWindow. I don't have with me that laptop here.

I am very sorry for not having double checked everything before posting. I'll try to edit it 

Posted by LinuxUser2019
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

I have the same problem, see my topic: https://community.teamviewer.com/t5/Linux/Ubuntu-14-04-5-GUI-not-working-in-TV-13-x-and-14-x/td-p/66...

Well, Linux version updated today and it still not working for me. I repeat - this is the only program that can't display GUI on Linux that I ever know. Dear programmers and support members of TV team! Please, don't be a blind to our problem. Do you think we are trolling? It's not a joke, we need working TV. Do we need to find another remote control solution???

Posted by Wintermute
Digon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

You should reply to existing topics with same problems instead of creating new one... Just kidding! :p


@LinuxUser2019 wrote:

I have the same problem, see my topic: https://community.teamviewer.com/t5/Linux/Ubuntu-14-04-5-GUI-not-working-in-TV-13-x-and-14-x/td-p/66...

Well, Linux version updated today and it still not working for me. I repeat - this is the only program that can't display GUI on Linux that I ever know. Dear programmers and support members of TV team! Please, don't be a blind to our problem. Do you think we are trolling? It's not a joke, we need working TV. Do we need to find another remote control solution???



Highlighted
Posted by LinuxUser2019
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Sorry, already corrected myself, your topic was first :)

Do you have solution to this problem? May be some workarounds? Could support team reproduce this problem? May be they just not believe us by taking it as joke or flashmob?

Now I have 14.3.4730 version installed which is the most recent one. Still out of luck observing nice TV GUI...

5 Replies
Posted by Wintermute
Digon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

I'm sorry but no, still no solution. The only "workaround" I've found is to run teamviewer inside a Windows VM that I already had. I can live with that because I don't need remote guest to connect my desktop... It's possible the developers don't want to spend time fixing this bug because ubuntu 14.04 is EOL since last April. 

Posted by LinuxUser2019
Henagon

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Win+VM? Me too, it's ridiculous! Also, have you tried Ubuntu 16.04, 18.04? May be TV team just awaits when all 14.04 users die and ressurect as 16/18.04 users, then problem will be fixed for them without any effort?

Although, since this information https://wiki.ubuntu.com/Releases Ubuntu 14.04 is at end of standard support, however still be supported up to 2022 year.

Posted by Moderator Moderator
Moderator

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Hi there, 

Thank you for your posts. 

Unfortunately, I have to tell you that TeamViewer 14 is not compatible with Ubuntu 14.04.

You can find all supported operating systems for Linux and TV 14 in the following article: Which operating systems are supported | Linux

Hope this could help and sorry for any inconvenience caused. 

Wish you all a great day and all the best,
Natascha

Posted by digitalmaciek
Henagon

Re: Teamviewer 14 not working on Centos 7

Hi Natascha,

Finally a Team Viewer moderator !

Well unfortunately it doesn't work on Centos 7.2 either. Please see my original comment below

I am using Centos 7.2  After an upgrade to Teamviewer 14. TV fails to run...Had to go back to v.12

$ teamviewer

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
terminate called after throwing an instance of 'boost::wrapexcept<boost::uuids::entropy_error>'
what(): getrandom
/opt/teamviewer/tv_bin/script/tvw_exec: line 38: 32633 Aborted (core dumped) "$TV_BIN_DIR/teamviewerd" -n -f
Network process already started (or error)
Launching TeamViewer GUI ...
Aborted (core dumped)

 


@Natascha wrote:

Hi there, 

Thank you for your posts. 

Unfortunately, I have to tell you that TeamViewer 14 is not compatible with Ubuntu 14.04.

You can find all supported operating systems for Linux and TV 14 in the following article: Which operating systems are supported | Linux

Hope this could help and sorry for any inconvenience caused. 

Wish you all a great day and all the best,
Natascha



@Natascha wrote:

Hi there, 

Thank you for your posts. 

Unfortunately, I have to tell you that TeamViewer 14 is not compatible with Ubuntu 14.04.

You can find all supported operating systems for Linux and TV 14 in the following article: Which operating systems are supported | Linux

Hope this could help and sorry for any inconvenience caused. 

Wish you all a great day and all the best,
Natascha





Posted by overtherainbow
Electron

Re: Teamviewer 14 not working on Ubuntu 14.04 64

Hi,

Same problem on CentOS 7.2.  Defitively not working.  Looks like the boost call that try to call getrandom (kernel call) is not supported on CentOS  7.2 kernel.

We need to use define=BOOST_UUID_RANDOM_PROVIDER_FORCE_POSIX to compile with boost to avoid this.

At the same time, it can be great to have teamviewer <self-contain>, without dependency. For example, with Teamviewer 14, QT 5 needs to be installed, and with a specific version.  You should package teamviewer with all the required dependency installed in the teamviewer folders.  This way, your app will have no or minimal dependencies on other rpms.

A great example of this is Visual Studio Code.  1 rpm.  That's only what you need to install!